Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 2:49 pm

So is the file you're trying to upload larger than 2MB? If so then you can't upload it with those settings you have.

I assume you're stopping and restarting services when you change these settings by the way.

Try also changing your script timeout range.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 2:54 pm

I found this on a Joomla forum:
Workaround: Create a directory "files" in your JOOMLA root; CHMOD this to 777. The Attachment Mod doesn't use the right path to com_forum.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Etherfast
Registered User
Posts: 372
Joined: Mon May 22, 2006 10:58 pm
Location: Bucharest, RO
Contact:

Post by Etherfast » Fri Jul 14, 2006 3:18 pm

That WORKED!
I would have never thought of that as it doesn't make sense at all.

Thaks a lot for all the given help and sorry for the lost time.
Keep up the good work :P

Later edit :
Hmm, by any chance, do you happen to know why isn't the MOD creating thumbnails?

This is how it looks like, the archives have a download button, but the images don't, and the images are not even thumbnailed.

Image

I tried to play with the MOD's settings, but I didn't find anything related to that.

ctroyp
Registered User
Posts: 87
Joined: Sat Oct 08, 2005 8:58 pm

Post by ctroyp » Fri Jul 14, 2006 5:17 pm

I have search for this answer, but without positive results...

Is there a standalone attachment mod version that can be installed on an existing phpBB 2.0.21 board? I have seen the package that can be used on a vanilla 2.0.21, but what about for applying this to a 2.0.21 that is not vanilla?

Thanks!

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 5:23 pm

ctroyp wrote: I have search for this answer, but without positive results...

Is there a standalone attachment mod version that can be installed on an existing phpBB 2.0.21 board? I have seen the package that can be used on a vanilla 2.0.21, but what about for applying this to a 2.0.21 that is not vanilla?

Thanks!

You have to do all the edits manually or using EZMod.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 5:24 pm

Etherfast wrote: That WORKED!
I would have never thought of that as it doesn't make sense at all.

Thaks a lot for all the given help and sorry for the lost time.
Keep up the good work :P

Later edit :
Hmm, by any chance, do you happen to know why isn't the MOD creating thumbnails?

This is how it looks like, the archives have a download button, but the images don't, and the images are not even thumbnailed.

Image

I tried to play with the MOD's settings, but I didn't find anything related to that.

It may have something to do with the previous problem. It might be looking in the right folder but the images are getting uploaded elsewhere. Are they in your files folder or in another folder? Might need to change that in the directory config for this mod...
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

ctroyp
Registered User
Posts: 87
Joined: Sat Oct 08, 2005 8:58 pm

Post by ctroyp » Fri Jul 14, 2006 5:29 pm

DavidIQ wrote:
ctroyp wrote:I have search for this answer, but without positive results...

Is there a standalone attachment mod version that can be installed on an existing phpBB 2.0.21 board? I have seen the package that can be used on a vanilla 2.0.21, but what about for applying this to a 2.0.21 that is not vanilla?

Thanks!

You have to do all the edits manually or using EZMod.

So 2.4.1 is the latest version to use with easymod?

Also, will this be compatible with the categories hierarchy mod 2.6.1, I think...?

Etherfast
Registered User
Posts: 372
Joined: Mon May 22, 2006 10:58 pm
Location: Bucharest, RO
Contact:

Post by Etherfast » Fri Jul 14, 2006 5:46 pm

DavidIQ wrote: It may have something to do with the previous problem. It might be looking in the right folder but the images are getting uploaded elsewhere. Are they in your files folder or in another folder? Might need to change that in the directory config for this mod...


The files are getting uploaded to (Joomlaroot)/files.

I noticed that in the old location (/www/components/com_forum/files) there was a 'thumbs' directory so I created one in joomlaroot/files too and chmoded it to 777 and did another test. The same result, no thumbnail was created and there was no download link either.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 6:51 pm

ctroyp wrote:
DavidIQ wrote:
ctroyp wrote:I have search for this answer, but without positive results...

Is there a standalone attachment mod version that can be installed on an existing phpBB 2.0.21 board? I have seen the package that can be used on a vanilla 2.0.21, but what about for applying this to a 2.0.21 that is not vanilla?

Thanks!

You have to do all the edits manually or using EZMod.

So 2.4.1 is the latest version to use with easymod?

Also, will this be compatible with the categories hierarchy mod 2.6.1, I think...?

Actually for that you'll need to go to ptrhik's website and download the drop-in that he has. That one's easier than doing it on a regular phpBB installation. Reason it's a drop-in is because he had already incorporated checks into his CH system to see if attachment mod is present or not. Sort of the same thing that's going to happen in phpBB3. Anyways...go to his website and check in goodies under his downloads section.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Fri Jul 14, 2006 6:52 pm

Etherfast wrote: The files are getting uploaded to (Joomlaroot)/files.

I noticed that in the old location (/www/components/com_forum/files) there was a 'thumbs' directory so I created one in joomlaroot/files too and chmoded it to 777 and did another test. The same result, no thumbnail was created and there was no download link either.

That's what I was afraid of. Are you able to open this files directory in a browser?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

drib
Registered User
Posts: 11
Joined: Fri May 12, 2006 6:44 am

Re: Flash Files in Attachment Mod

Post by drib » Fri Jul 14, 2006 6:59 pm

DavidIQ wrote:
drib wrote:I have the Attachment Mod installed and I realise that it does allow SWF files to be added as an attachment, but what I have been looking for is a button on the attachment that gives the poster the option of attaching a flash file from his own server by posting a link to it. This way all swf files will not be needed to keep on my own server. I know I have seen this on another phpBB site, but for the life of me, I can't find a mod for this anywhere. I would truly appreciate someone's assistance in locating this mod (or option) or at least pointing me in the right direction.
Thanks in advance!

First...this is the attachment mod thread.

Second...you could just allow html although this could pose a security issue.

Third...you'll need to ask your question in the support forum.


Yes, I realise this is the attachment mod thread...my question was about the attachment mod. Perhaps I wasn't clear. I want to allow people to post flash movies IN AN ATTACHMENT but from their own server. I've seen this option before. When you selected the attachment, there was a flash button and that allowed you to either upload the swf file, or type in your url for where the flash was kept. Either way, it would play in the attachment.
I have posted this question in the Support Forum and was told it was a mod issue. If it's just a matter of altering the BBCode file, could someone please give me a hint. Thanks again.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17052
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Flash Files in Attachment Mod

Post by DavidIQ » Fri Jul 14, 2006 7:27 pm

drib wrote:
DavidIQ wrote:
drib wrote:I have the Attachment Mod installed and I realise that it does allow SWF files to be added as an attachment, but what I have been looking for is a button on the attachment that gives the poster the option of attaching a flash file from his own server by posting a link to it. This way all swf files will not be needed to keep on my own server. I know I have seen this on another phpBB site, but for the life of me, I can't find a mod for this anywhere. I would truly appreciate someone's assistance in locating this mod (or option) or at least pointing me in the right direction.
Thanks in advance!

First...this is the attachment mod thread.

Second...you could just allow html although this could pose a security issue.

Third...you'll need to ask your question in the support forum.


Yes, I realise this is the attachment mod thread...my question was about the attachment mod. Perhaps I wasn't clear. I want to allow people to post flash movies IN AN ATTACHMENT but from their own server. I've seen this option before. When you selected the attachment, there was a flash button and that allowed you to either upload the swf file, or type in your url for where the flash was kept. Either way, it would play in the attachment.
I have posted this question in the Support Forum and was told it was a mod issue. If it's just a matter of altering the BBCode file, could someone please give me a hint. Thanks again.

Is this not what you're trying to accomplish?
http://www.phpbb.com/phpBB/viewtopic.ph ... ight=flash
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

ctroyp
Registered User
Posts: 87
Joined: Sat Oct 08, 2005 8:58 pm

Post by ctroyp » Fri Jul 14, 2006 8:32 pm

DavidIQ wrote:
ctroyp wrote:
DavidIQ wrote:
ctroyp wrote:I have search for this answer, but without positive results...

Is there a standalone attachment mod version that can be installed on an existing phpBB 2.0.21 board? I have seen the package that can be used on a vanilla 2.0.21, but what about for applying this to a 2.0.21 that is not vanilla?

Thanks!

You have to do all the edits manually or using EZMod.

So 2.4.1 is the latest version to use with easymod?

Also, will this be compatible with the categories hierarchy mod 2.6.1, I think...?

Actually for that you'll need to go to ptrhik's website and download the drop-in that he has. That one's easier than doing it on a regular phpBB installation. Reason it's a drop-in is because he had already incorporated checks into his CH system to see if attachment mod is present or not. Sort of the same thing that's going to happen in phpBB3. Anyways...go to his website and check in goodies under his downloads section.

Thanks David...I'm up and running now...

Qudeid
Registered User
Posts: 27
Joined: Wed Jun 28, 2006 2:17 pm

Post by Qudeid » Fri Jul 14, 2006 10:33 pm

Hi there,

My actual state is that I have the Attachment-Mod installed and this "thumbnail to dimension" thingy. Everything works properly.

But, since in the thumbnail to dimension thingy is no comment integrated (you know, the "comment" you can type in when uploading your attachment), I added it manually. There is no problem with that.
The only thing I want to "fix" now is: If there is no comment at all, I don't want this cell under the thumbnail to be there.

I don't have any idea how to achieve that. It would be possible if there were the possibility of php in the templates. But isn't there any other way to get that? Okay, it's nothing too important. It would really be nice, though.

thanks to you in advance

Qudeid

Oh.. and the topic (for an example) is this one: http://wv.awardspace.com/WV/viewtopic.php?p=21#21 (Sorry it's german, but I guess you'll get the idea)

madpwr1
Registered User
Posts: 93
Joined: Mon Mar 06, 2006 4:24 am

Post by madpwr1 » Fri Jul 14, 2006 11:04 pm

Qudeid wrote: My actual state is that I have the Attachment-Mod installed and this "thumbnail to dimension" thingy. Everything works properly.


how did you get the "thumbnail to dimension" to work?

Post Reply

Return to “[2.0.x] MOD Database Releases”