Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

Liehon
Registered User
Posts: 21
Joined: Wed Jun 28, 2006 8:02 am

Post by Liehon »

I uploaded the mod but it doesn't appear in EasyMod and I have no idea how I should do it manually :?

(if this problem has been solved before you'll have to excuse me, I tried to read all the pages but after number 4 I stopped and decided to post :oops: :D )

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

dcpaq2 wrote: Group,

"Tried to upload empty file"

What does this actually mean and what is causing this to appear? My users are getting this error when trying to upload an attachment and its not letting them upload files, how do I fix this?

Thanks

Doug

How big are the files being uploaded?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

Liehon wrote: I uploaded the mod but it doesn't appear in EasyMod and I have no idea how I should do it manually :?

(if this problem has been solved before you'll have to excuse me, I tried to read all the pages but after number 4 I stopped and decided to post :oops: :D )

Referring to the docs/install.txt file...
## Author Notes:
##
## Complete feature list: docs/features.txt
## The user guide: docs/user_guide.html
##
## Some tips:
## - I suggest reading the user guide first if you haven't installed any Mods before.
## - Please note that this Mod is NOT written to be EasyMod compatible (i haven't tested it).
## - Please follow the installation instructions as strict as you can.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Liehon
Registered User
Posts: 21
Joined: Wed Jun 28, 2006 8:02 am

Post by Liehon »

Oooh ... I kept looking in the install folder ... why did he hide it in docs? :)
Well, I'm gonna try to install it .... gulp ... I'll probably need help for every two steps :p

dcpaq2
Registered User
Posts: 87
Joined: Fri Oct 17, 2003 1:45 pm
Location: Chicago, Illinois

Post by dcpaq2 »

DavidIQ wrote:
dcpaq2 wrote:Group,

"Tried to upload empty file"

What does this actually mean and what is causing this to appear? My users are getting this error when trying to upload an attachment and its not letting them upload files, how do I fix this?

Thanks

Doug

How big are the files being uploaded?


Less than 50kb. I havent changed anything within phpbb either, it just started doing it. It did this about 4 days ago too a member said and then just fixed itself out of the blue. I just have no idea what is causing this or how to fix it.

Doug

my4skcg
Registered User
Posts: 60
Joined: Sun May 07, 2006 8:10 pm

Post by my4skcg »

I had attachment mod installed & working. I then installed a few fairly minor mods (updated to most current phpBB, Quick Reply, eXtreme Styles, and a new style), now I have a problem with attachments.

I have both a Mac and a PC and I use Firefox on both. When I view a post with an attachment on the PC, the attachment doesn't appear. I thought it wasn't working right, then I was visiting my forum on the Mac and noticed the attachment was displayed.

They do not appear using IE on the PC either. But, then neither does my avatar.

This obviously is not really an attachment mod issue, but I thought I would post here hoping someone would be able to help.

scoobysrt
Registered User
Posts: 9
Joined: Wed Jul 12, 2006 11:16 pm

Post by scoobysrt »

DavidIQ wrote:
scoobysrt wrote:How do i get it to resize the attachment if its an image and that image is too big?

Ive tried the size settings but they dont seem to alter anything, i am sure i am making a simple mistake,

I have been to the special Categories part and changed the image size but users can still post massive images,

Is it somthing simple?

Thanks in advance,

http://www.phpbb.com/phpBB/viewtopic.php?t=362983



Thanks for that but thats not what i want,

What i want is for example if someone uploads an image 1000x1000 i want it to rezise to 500x500 for example, ive set the maximum size limit on the mod panel but i can still upload big pics and they are shown full size,




dcpaq2,

I was having that problem, what causes it is the host you are useing has a limit to what can be uploaded, its likely that limit is being exceeded,
Try up loading a really small file size to test if thats the case,

my4skcg
Registered User
Posts: 60
Joined: Sun May 07, 2006 8:10 pm

Post by my4skcg »

Another problem that may or may not be related is ... after installing these mods, I can't see the attachments in posts that were created before the mods. If I go to the attachment control panel, the attachment is listed and I can click on the attachment file and view the attachment. It just doesn't display in the post. This is on the PC and the Mac.

dcpaq2
Registered User
Posts: 87
Joined: Fri Oct 17, 2003 1:45 pm
Location: Chicago, Illinois

Post by dcpaq2 »

scoobysrt wrote: [dcpaq2,

I was having that problem, what causes it is the host you are useing has a limit to what can be uploaded, its likely that limit is being exceeded,
Try up loading a really small file size to test if thats the case,


How much smaller do I have to go? I'm already trying to upload 43kb image files.

I dont beleive thats what is causing this issue im having as the standard php limit is 2mb.

Doug

my4skcg
Registered User
Posts: 60
Joined: Sun May 07, 2006 8:10 pm

Post by my4skcg »

Marion here again.

Another issue is ... the little paperclip icon that shows a post has an attachment is not appearing anymore. Can you point me in the direction of where to look for the error? The image file DOES exist - I already checked that.

Thanks so much for all of your help! I just really hate it when you have something working and it breaks. KWIM?

Marion

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

my4skcg wrote: Marion here again.

Another issue is ... the little paperclip icon that shows a post has an attachment is not appearing anymore. Can you point me in the direction of where to look for the error? The image file DOES exist - I already checked that.

Thanks so much for all of your help! I just really hate it when you have something working and it breaks. KWIM?

Marion

Check the viewforum.php edit.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

my4skcg wrote: Another problem that may or may not be related is ... after installing these mods, I can't see the attachments in posts that were created before the mods. If I go to the attachment control panel, the attachment is listed and I can click on the attachment file and view the attachment. It just doesn't display in the post. This is on the PC and the Mac.

Check viewtopic.php and viewtopic_body.tpl. The edits to those might have gotten wiped out.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

scoobysrt wrote:
DavidIQ wrote:
scoobysrt wrote:How do i get it to resize the attachment if its an image and that image is too big?

Ive tried the size settings but they dont seem to alter anything, i am sure i am making a simple mistake,

I have been to the special Categories part and changed the image size but users can still post massive images,

Is it somthing simple?

Thanks in advance,

http://www.phpbb.com/phpBB/viewtopic.php?t=362983



Thanks for that but thats not what i want,

What i want is for example if someone uploads an image 1000x1000 i want it to rezise to 500x500 for example, ive set the maximum size limit on the mod panel but i can still upload big pics and they are shown full size,

???
I think you're confused as this is exactly what that mod does. Did you read the description? :roll:
Attachment mod as it is doesn't do what you're looking for without some editing which is what the Thumbnail-on-Dimensions mod (for Attachment mod) does.
Last edited by DavidIQ on Sun Aug 06, 2006 10:34 pm, edited 1 time in total.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17163
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ »

dcpaq2 wrote: How much smaller do I have to go? I'm already trying to upload 43kb image files.

I dont beleive thats what is causing this issue im having as the standard php limit is 2mb.

Doug

Are you running your site on your own server? This is a PHP configuration issue and not an issue with the mod itself... something with timeouts I believe.

You might be exceeding resource usage for your site and the host has decided to disable the uploading via PHP.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Father_Time
Registered User
Posts: 4
Joined: Sun Aug 06, 2006 1:45 am

Post by Father_Time »

hey DavidIQ no more problems... just posting because i wanted to tell that you are amazing..!! thanks a lot for your help! :D , pre-modified files worked perfectly, thanks! im in doubt with you! sorry for the problems! and again... thanks for your time! :D take care

Post Reply

Return to “[2.0.x] MOD Database Releases”