Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
P-40
Registered User
Posts: 9
Joined: Mon Mar 26, 2007 5:58 am
Contact:

Attachment and calendar mod question

Post by P-40 » Mon Apr 16, 2007 3:39 am

I have been working on trying to install both the attachment and calendar mods, I have gotten each to work separately but not together. I have started from fresh a couple times. This time I installed the calendar mod first and then tried the attachment mod (the pre installed version) and I get the following error message:

Fatal error: Call to a member function on a non-object in /home/p40warha/www/www/phpbb/includes/page_header.php on line 491

Here is the code before and after line 491.

header ('Cache-Control: private, pre-check=0, post-check=0, max-age=0');
}
header ('Expires: 0');
header ('Pragma: no-cache');

//-- mod : calendar ------------------------------------------------------------
//-- add
global $user, $config, $calendar_api;
$user->set();
$calendar_api->set();
if ( !defined('IN_CALENDAR') && !defined('HAS_DIED') && (intval($config->data['calendar_header_cells']) || (intval($user->data['user_calendar_header_cells']) && !intval($config->data['calendar_header_cells_over']))) )
{
include($config->url('includes/class_calendar_handler'));

calendar_extend_template();
$calendar_header_box = new calendar_header_box('index');
$calendar_header_box->display();
$calendar_header_box->destroy();
unset($calendar_header_box);
calendar_extend_template();
}
$template->assign_vars(array(
'L_CALENDAR' => $user->lang('Calendar'),
'I_CALENDAR' => $user->img('menu_calendar'),
'U_CALENDAR' => $config->url('calendar', '', true),
));
//-- fin mod : calendar --------------------------------------------------------

$template->pparse('overall_header');

?>

I have been struggling with this for a while now. Does anyone know what I did wrong or how to get both mods installed?

Thanks

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Mon Apr 16, 2007 11:28 am

As you can clearly see...there's nothing about attachment mod in those lines. Your question should be done in the calendar mod topic or website. Attachment mod does nothing to the page_header.php file. If it's something that happens after you install attachment mod then you're somehow eliminating edits needed for calendar mod. I really hope you're not using the pre-modified files to install attachment mod AFTER you've installed calendar mod as this would most definitely undo and break your calendar mod.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Fatcat67
Registered User
Posts: 15
Joined: Thu Apr 05, 2007 11:49 pm

Two small issues

Post by Fatcat67 » Mon Apr 16, 2007 5:32 pm

I have just installed the attachment mode using the pre-modified files and it seems to work good so far. I have also installed one other style (jasidogdotcom). Now when veiving posts the authors names are not showing up just their avatar and their short profile info. Any ideas how to fix this, only does this in jasidogdotcom theme subsilver seems to be fine. Also what is the best image resize mod to use i am running phpbb 2.0.22. Thank you

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf » Mon Apr 16, 2007 5:40 pm

Neither of these questions has anything to do with attachment mod.

If your style does not show what you want, you either alter it, or use a different style.

Attachment mod already uses thumbnails to resize its images. If you are trying to resize images posted with the [img] bbcode, that has nothing to do with attachment mod.

Fatcat67
Registered User
Posts: 15
Joined: Thu Apr 05, 2007 11:49 pm

Re: Attachment Mod

Post by Fatcat67 » Mon Apr 16, 2007 5:48 pm

Thanks for the reply but the style jasidogdotcom showed the author before the mod and now it doenst. Also how do i use the thumbnail option in the attachment mod. Sorry if these questions sound amatuer because i am very new to all of this and am learning as i go.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf » Mon Apr 16, 2007 5:59 pm

This mod does not alter the profile part of posting. Therefore it could not have any impact on that part of your forum.

The thumbnail options are in your ACP under Extensions Special Categories.

Fatcat67
Registered User
Posts: 15
Joined: Thu Apr 05, 2007 11:49 pm

Re: Attachment Mod

Post by Fatcat67 » Mon Apr 16, 2007 6:16 pm

Thanks, I have found the settings for thumbnails but I tried a test post and got this:

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'files/thumbs/t_boat_132.jpg' for writing in /data/9/1/57/26/1220678/user/1301472/htdocs/phpBB2/attach_mod/includes/functions_thumbs.php on line 212

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'files/thumbs/t_boat_132.jpg' for writing in /data/9/1/57/26/1220678/user/1301472/htdocs/phpBB2/attach_mod/includes/functions_thumbs.php on line 212


Any suggestions here?

Thanks again

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf » Mon Apr 16, 2007 6:18 pm

Did you create that files/thumbs/ directory and CHMOD it to 777?

Fatcat67
Registered User
Posts: 15
Joined: Thu Apr 05, 2007 11:49 pm

Re: Attachment Mod

Post by Fatcat67 » Mon Apr 16, 2007 6:25 pm

I am a dummy, that fixed it!

Thank you for your help

HVAC Tech Forum
Registered User
Posts: 108
Joined: Sun Feb 25, 2007 9:45 pm
Contact:

Re: Attachment Mod

Post by HVAC Tech Forum » Mon Apr 16, 2007 7:20 pm

Oh, just wanted to say...

NICE MOD !

murphygonzalez
Registered User
Posts: 2
Joined: Sat Nov 06, 2004 2:08 pm

Re: Attachment Mod

Post by murphygonzalez » Mon Apr 16, 2007 10:32 pm

Forgive me if this isn't the place to post this.
The attachment mod was working on my site and then I upgraded to php 5 and to the latest version of phpbb. I then updated the mod attachement.

Now the attachment mod doesn't work and I don't know why. When I go in to the admin part of the forum I see the section for attachments just like before. However, when I go to preview the forum and upload an attachement, there is no form for uploading the attachment.

Any ideas?

Thanks in advance.
--Murphy Gonzalez

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Tue Apr 17, 2007 12:08 am

How exactly did you "update" attachment mod?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Ts_Dreams_
Registered User
Posts: 4
Joined: Sun Apr 08, 2007 6:07 am

Re: Attachment Mod

Post by Ts_Dreams_ » Tue Apr 17, 2007 4:02 am

Error in attach mod. When i try to attach a file i get a "No Post Mode Specified". Any idea how to fix this?

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Tue Apr 17, 2007 4:27 am

Yeah...you missed an edit or two to the posting_body.tpl file most likely the encryption looking edit.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

SlickR
Registered User
Posts: 17
Joined: Tue Apr 03, 2007 10:32 am
Contact:

Re: Attachment Mod

Post by SlickR » Tue Apr 17, 2007 5:05 am

Download not working!

Post Reply

Return to “[2.0.x] MOD Database Releases”