Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
r4wMUnt34q
Registered User
Posts: 167
Joined: Sat Aug 19, 2006 5:41 am
Location: Hard to explain :)
Contact:

Re: Attachment Mod

Post by r4wMUnt34q »

avg123, does it show the Add attachment in posting body ? Or have you CHMODed files directory to 777 (Im not sure about the second thing, but nothig better gets on my mind) ? Specify the problem please...
avg123
Registered User
Posts: 2
Joined: Wed May 02, 2007 8:41 am

Re: Attachment Mod

Post by avg123 »

Yes, permition to files directory is 777. There is no Add files button in replies, thats exactly the problem. There were no problems during instalation of the mod. All files were copied to root directory of the script and install.php was executed. Currently Attachment and Extension panels are availabale in Administration panel, but there is no panel in posts. Language of the forum is different from English (I don't know if this is connected to the problem). I dont know what else to specify...
User avatar
r4wMUnt34q
Registered User
Posts: 167
Joined: Sat Aug 19, 2006 5:41 am
Location: Hard to explain :)
Contact:

Re: Attachment Mod

Post by r4wMUnt34q »

Try changing to English language (and then try to post an attachment) to see if it works. If it works then you have to copy the lang_..._attach.php files to the other language(s) directory(ies)...

If it wont work then you will have to specify more or deeper...
Last edited by r4wMUnt34q on Wed May 02, 2007 11:30 am, edited 1 time in total.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52127
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

avg123 wrote: All files were copied to root directory of the script and install.php was executed.


There are a bunch of file edits that need to be done too, unless you get the pre-modded files from DavidIQ's forum and use those. Please read the instructions in the docs/install.txt
viper7
Registered User
Posts: 17
Joined: Sun Apr 29, 2007 12:58 am

Re: Attachment Mod

Post by viper7 »

Hi,

Iam really dumb on installing mods, i done a search and found a Easy MOD 0.3.0, it was easy to install and ihave install the quick reply MOD it works fine , but iam unable to install the Attchment Mod with it, when i go to ACP --> Install Mods... its not listing the Attachment Mod , if some one has done it please do let me know , much appericated
maria
Thanks to All PHPBB Team & Lovely Members Special Thanks to Drixie
funnybunny
Registered User
Posts: 6
Joined: Mon Apr 30, 2007 8:14 pm

Re: Attachment Mod

Post by funnybunny »

Hello!

Are there any mods to this mod that allows you to upload a lot of files at once, for example as zip-files (and then extracted to get out the files) or as some kind of multi-file upload?

That is, working together with this mod.

Please reply.
meoblast001
Registered User
Posts: 5
Joined: Sun Apr 15, 2007 12:18 am

Re: Attachment Mod

Post by meoblast001 »

When i selected my upload file and tried to upload it tryed to go to posting.php (with no posting mode). This caused the error "No post mode specified" to occur. How do I fix this?
amandhary
Registered User
Posts: 38
Joined: Mon Dec 18, 2006 5:30 am

Re: Attachment Mod

Post by amandhary »

hey everyone i need some help....
i cant seem to figure out why i get this problem

Warning: include_once() [function.include-once]: Unable to access ./language/lang_english/lang_activity.php in /home/desient/includes/functions_amod_plus.php on line 17

The problem comes up when i click on a "username" and try to view there profile
i dont understand i did reupload the whole folder of Includes and lang_english
but its not working any have any idea

Thanks!
drixie
Registered User
Posts: 76
Joined: Mon Apr 23, 2007 12:12 am

Re: Attachment Mod

Post by drixie »

The only premodded files installation pack for vanilla phpbb available on sourceforge.net are for version .21 there's none for .22, i want to know where i can get that for .22 and if its not available, i want to know if .21 files will work fine with it.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17326
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Premodified files for 2.0.22 can be found at http://phpbb.davidiq.com
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17326
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

meoblast001 wrote: When i selected my upload file and tried to upload it tryed to go to posting.php (with no posting mode). This caused the error "No post mode specified" to occur. How do I fix this?

You've most likely missed this edit:

Code: Select all

# 
#-----[ OPEN ]---------------------------------------------
# 
templates/subSilver/posting_body.tpl

# 
#-----[ FIND ]---------------------------------------------
# around line 258
<form action="{S_POST_ACTION}" method="post" name="post" onsubmit="return checkForm(this)">

# 
#-----[ REPLACE WITH ]---------------------------------------
# 
<form action="{S_POST_ACTION}" method="post" name="post" onsubmit="return checkForm(this)" {S_FORM_ENCTYPE}>
or you're trying to upload a file that's too big.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
drixie
Registered User
Posts: 76
Joined: Mon Apr 23, 2007 12:12 am

Re: Attachment Mod

Post by drixie »

thanx for ur help. i want to know if you are the official support for this mod now.

also, if there are premodded files fo version .22, what about installation files for .22? have they not been created or updates?

Finally, about the edit you gave this guy, is it important?
tridean
Registered User
Posts: 7
Joined: Mon Apr 30, 2007 8:08 am

Re: Attachment Mod

Post by tridean »

Hi All,
A friend of mine installed the Attachment MOD fine, there were no errors during installation at all, but when we tested it by trying to attach an image we got this error message

Upload Error: Could not upload Attachment to ./files/030_227.jpg.
Upload Error: Could not upload Attachment to ./files/030_227.jpg.

Each time we try and upload the picture, the last 3 digits (227) appear and are always different. Don't know what they are as the file we are uploading is called 030.jpg

We have checked the CHMOD of the files folder and that is set to 777, so are not sure what is going on.

He did have to go through the set up process that is for forum owners who have previously installed other MOD's and in his case, the add on MOD was a spam MOD. I'm not sure if this has anything to do with it.

Can anyone help,
Cheers
Dean
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52127
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

drixie wrote: thanx for ur help. i want to know if you are the official support for this mod now.

also, if there are premodded files fo version .22, what about installation files for .22? have they not been created or updates?

Finally, about the edit you gave this guy, is it important?


There is no "Official support"

The install files for 2.4.5 will work with 2.0.22 as long as you do your own edits. If you are using pre-modded files in 2.0.22, you need the ones on DavidIQ's site.

If you are talking about the S_ENCTYPE edit a fews posts up, that is part of the normal install. Sometimes modders miss it in non-subSilver templates. All of the edits are important.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52127
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

amandhary wrote: Warning: include_once() [function.include-once]: Unable to access ./language/lang_english/lang_activity.php in /home/desient/includes/functions_amod_plus.php on line 17


There is no lang_activity.php or functions_amod_plus.php in phpBB or Attachment mod. You will have to seek help for that with whatever activity mod you just installed.
Post Reply

Return to “[2.0.x] MOD Database Releases”