Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: Attachment Mod

Post by JunglistPerfection »

Is this mod compatible with 2.0.22?
If so, I'm having a hard time installing this mod. It wont show up on my easymod at all and I also looked at the install.txt, the text in that file is all jumbled up. Can someone help me with this problem, thanks.
DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Re: Attachment Mod

Post by DivErTido »

Hello,

I have set the "view attached files" permission to REG. Now I would like to have a message for not logged in users saying "You have to be registered and logged in to view attachments" (or something like that). That message should be shown where the attachmant is shown for logged in users.

Anybody having such a add-on? :)
P.S. Please sorry for my poor english...
Legendas Divx
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52143
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

JunglistPerfection wrote: Is this mod compatible with 2.0.22?
If so, I'm having a hard time installing this mod. It wont show up on my easymod at all and I also looked at the install.txt, the text in that file is all jumbled up. Can someone help me with this problem, thanks.


Yes. It is compatible with 2.0.22. Open the install.txt with wordpad, instead of notepad, and it will look fine.
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: Attachment Mod

Post by JunglistPerfection »

When I try to install the install.php, I get this error:
Fatal error: Call to undefined function: session_pagestart() in line 20
Line 20: $userdata = session_pagestart($user_ip, PAGE_INDEX);

What's wrong with this line?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52143
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

You are running install.php already? You did all of the updates in install.txt so quickly?

No wait. The install.php is step 2, after all the uploads. You have the install.php in the install directory under your forum?
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: Attachment Mod

Post by JunglistPerfection »

Ok, ummm.....no! :lol:
I must have read the install.txt wrong, but I got it now.
One more thing, some of the images are corrupted. Where can I get the replacements?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52143
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

The images should be fine.
Just be sure to upload them as Binary, rather than Text, which is for the php and tpl files.
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: Attachment Mod

Post by JunglistPerfection »

No, some of the images in attachment_mod >> contrib >> app_icons are corrupted some how. I can't view them in my image viewer.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52143
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

Ah. I have never used any of them.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17329
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

JunglistPerfection wrote: No, some of the images in attachment_mod >> contrib >> app_icons are corrupted some how. I can't view them in my image viewer.

Do a Google search for images using the filenames of the icons that are corrupted.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17329
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

DivErTido wrote: Hello,

I have set the "view attached files" permission to REG. Now I would like to have a message for not logged in users saying "You have to be registered and logged in to view attachments" (or something like that). That message should be shown where the attachmant is shown for logged in users.

Anybody having such a add-on? :)

See:
http://phpbb.davidiq.com/viewtopic.php?t=19
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
JunglistPerfection
Registered User
Posts: 611
Joined: Mon Apr 09, 2007 11:58 pm
Location: Chicago, IL

Re: Attachment Mod

Post by JunglistPerfection »

I finally got the attachment mod installed but I get this error when I try to test the settings of the attachments management.

Error: Could not access ftp directory: '/forum/uploads'. Please check your FTP Settings.

What am I missing?
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17329
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Are you using the FTP option to upload to an external site? Otherwise you don't really need to use that.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
SUForum
Registered User
Posts: 2
Joined: Wed May 09, 2007 4:31 pm

Re: Attachment Mod

Post by SUForum »

Hi,

I have been using this MOD a long time - and it is fantastic.

However, I have just updated to the latest version of the MOD, and when I click on my attachments, I am getting a Page Not Found Error.

The files are in the files directory, so I am not sure what is causing this - is it possible that the stored url of the attachments is not pointing them to the correct files? If so, what can I do to correct this?

Thanks so much!
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52143
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

How did you update your phpBB?
If you overwrote any files, you will need to reinstall Attachment Mod
Post Reply

Return to “[2.0.x] MOD Database Releases”