Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

blueplanet
Registered User
Posts: 7
Joined: Sat Jul 28, 2007 5:14 am

What's Happened to Me...?

Post by blueplanet »

Images posted in my forums are being hotlinked to POSTIMAGE and a link to an adult website is attached.

Up until tonight, we were running 2.0.06 but I've updated successfully. Image posts still have the same problem.

I did not install the attachment mod. What's happening?
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17286
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

... :?:
Last edited by DavidIQ on Sat Jul 28, 2007 8:50 pm, edited 1 time in total.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
blueplanet
Registered User
Posts: 7
Joined: Sat Jul 28, 2007 5:14 am

Re: Attachment Mod

Post by blueplanet »

So does anyone have any idea why or how this is happening and what I can do about it? I've searched the posting.php and template.php files and found no clues.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52052
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

I would bet the problem is in your template.tpl
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17286
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

If you don't have attachment mod installed then what would make you think that this mod has ANYTHING to do with your issue????? :roll:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
blueplanet
Registered User
Posts: 7
Joined: Sat Jul 28, 2007 5:14 am

Re: Attachment Mod

Post by blueplanet »

I didn't say "I don't have the mod installed" now did I? I said "I didn't install it."

You'll forgive my ignorance but without it, this board wouldn't exist, now would it?

Abusive text removed>>Jim
Last edited by Jim_UK on Sun Jul 29, 2007 5:30 pm, edited 1 time in total.
Reason: Please read rule http://www.phpbb.com/rules/#rule1b
floppydrivez
Registered User
Posts: 2
Joined: Sat May 12, 2007 12:07 am

Re: Attachment Mod

Post by floppydrivez »

For all people having issues with corrupt downloads. This is what I did to fix it. Of course I am using phpnuke, but the same theory applies.

Open download.php
Find

Code: Select all

readfile($filename);
Change to

Code: Select all

header("Location: $filename");
Hope that helps.
floppydrivez
Registered User
Posts: 2
Joined: Sat May 12, 2007 12:07 am

Re: Attachment Mod

Post by floppydrivez »

Keep people from hotlinking your attachments

Create an .htaccess file with this code and drop it in your files directory

Code: Select all

SetEnvIfNoCase Referer "http://www.yourdomain.com" locally_linked=1
SetEnvIfNoCase Referer "http://yourdomain.com" locally_linked=1
<FilesMatch "\.*$">
  Order Allow,Deny
  Allow from env=locally_linked
</FilesMatch>
Not sure if this works with physical downloads. Might fux that up.
StuWright
Registered User
Posts: 17
Joined: Fri Jul 20, 2007 5:58 pm

Re: Attachment Mod

Post by StuWright »

An impressive mod I have to say. What I am even more impressed about is the fact it is free as this is the best site I have ever been on for support. Many thanks.
ronny.jobs
Registered User
Posts: 1
Joined: Fri May 04, 2007 9:35 am

Re: Attachment Mod

Post by ronny.jobs »

Dear all,

I have problem with attachment hack. I'm use phpbb2.022 and latest verion of the mod.
The mod doesn't display attachment in viewtopic.php, but the mod display the attachment in topic review frame.


i have followed the installation guide very very strictly and i check the code twice. There is no error with my instalation.

I am using aphrodite green template.

Does anyone knows what this is happen?
Your help would be so appreciated.

Regards,
Ronny
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17286
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

blueplanet wrote:I didn't say "I don't have the mod installed" now did I? I said "I didn't install it."

You'll forgive my ignorance but without it, this board wouldn't exist, now would it?

What's your excuse for being an ass?
Because you're an idiot. Attachment mod is a MOD and does NOT come installed with phpBB2 so I don't know how you come to the conclusion that this entire website has a connection with attachment mod. This board exists because phpBB exists not because attachment mod exists. Read the website title and check yourself. I was thinking you were confused but in reality you're clueless about what you're doing. My suggestion is to delete your phpBB software and not bother with reinstalling it. Try bothering with one of the other forum software forums with this sort of questioning.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17286
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

ronny.jobs wrote:Dear all,

I have problem with attachment hack. I'm use phpbb2.022 and latest verion of the mod.
The mod doesn't display attachment in viewtopic.php, but the mod display the attachment in topic review frame.


i have followed the installation guide very very strictly and i check the code twice. There is no error with my instalation.

I am using aphrodite green template.

Does anyone knows what this is happen?
Your help would be so appreciated.

Regards,
Ronny
There are several reasons this would happen. viewtopic.php is missing it's edits or viewtopic_body.tpl is missing it's edits. The only other thing that would be causing this would be the redirection mod. If you have that installed you'll need to remove it to make this mod work. They're not compatible in it's default state although some moving around of its code would solve the issue.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
blueplanet
Registered User
Posts: 7
Joined: Sat Jul 28, 2007 5:14 am

Re: Attachment Mod

Post by blueplanet »

DavidIQ wrote:...
Because you're an idiot. Attachment mod is a MOD and does NOT come installed with phpBB2 so I don't know how you come to the conclusion that this entire website has a connection with attachment mod. This board exists because phpBB exists not because attachment mod exists. Read the website title and check yourself. I was thinking you were confused but in reality you're clueless about what you're doing. My suggestion is to delete your phpBB software and not bother with reinstalling it. Try bothering with one of the other forum software forums with this sort of questioning.
My, but you are astute when you can determine from one post when someone is an idiot. One would be inclined to believe that your lack of manners is equaled only by your deficient technical skills, as evidenced by your own sophomoric website and those sky-high (get what you pay for) rates you charge.

If you would dismount off your high horse long enough to realize that this is the mod with the MOST requests for support, you might conclude that it might be an indication that all is not as well in Oz as you think it is. People sometimes need help and when they do it's a far better investment of your time to actually help than to roll your eyes and call them names.

Grow up, son. There's a whole bigger world out there than yours. Learn a few manners and you might get invited to join.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52052
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

You are unlikely to get any help with that attitude.
DavidIQ and I are the only ones offering support for attachment mod.

Since your problem is unrelated to Attachment Mod. You are best off taking your problem to general support, where you are more likely to find help.
blueplanet
Registered User
Posts: 7
Joined: Sat Jul 28, 2007 5:14 am

Re: Attachment Mod

Post by blueplanet »

Brf wrote:... You are best off taking your problem to general support, where you are more likely to find help.
LOL. What a sterling idea. Wish I had thought of that.

Oh, wait...
Post Reply

Return to “[2.0.x] MOD Database Releases”