Page 369 of 1475

Re: uploading big size attachment gives these errors

Posted: Fri Jul 16, 2004 7:42 am
by morpheus2matrix
alyster4k wrote: I got around it by shrinking the photo to fix on a screen but still shrunk somewhat. Any ideas how to avoid this error in the future?

Code: Select all

Warning: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: in /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php on line 200

Warning: imagecreatefromjpeg(): '/tmp/phpQ3ggyk' is not a valid JPEG file in /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php on line 200

Warning: imagecopyresized(): supplied argument is not a valid Image resource in /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php on line 202

Warning: Cannot modify header information - headers already sent by (output started at /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php:200) in /home/alister/public_html/maximumkc/includes/page_header.php on line 528

Warning: Cannot modify header information - headers already sent by (output started at /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php:200) in /home/alister/public_html/maximumkc/includes/page_header.php on line 530

Warning: Cannot modify header information - headers already sent by (output started at /home/alister/public_html/maximumkc/attach_mod/includes/functions_thumbs.php:200) in /home/alister/public_html/maximumkc/includes/page_header.php on line 531


It seems there is a proble with the funtion imagecreatefromjpeg :
: gd-jpeg: JPEG library reports unrecoverable error:

Posted: Fri Jul 16, 2004 7:43 am
by morpheus2matrix
Freecode wrote: I get this error

Code: Select all

Template->make_filename(): Error - file does not exist
Now i think by reading some posts its because of the template. Im not using subSilver. How do i fix this?


be sure you have uploaded all the template files in all your template folder :P

Posted: Fri Jul 16, 2004 9:35 am
by Freecode
problem is i dont use subSilver

Posted: Fri Jul 16, 2004 12:39 pm
by BlaxLash
First of all, great mod!

I was wondering, if anyone knew how to resize images. Story is: a user uploads a picture, but the picture is i.e. bigger than 150X150. In that case, the file must me resized to the smaller format, and the proportions bust me kept intact. so for example when a image of 300 X 100 is submitted, it must be resized to 150 X 75.

Who helps?

Posted: Fri Jul 16, 2004 12:47 pm
by morpheus2matrix
Freecode wrote: problem is i dont use subSilver

so upload the template files of the MOD in your template folder

Posted: Fri Jul 16, 2004 12:50 pm
by Freecode
this is confusing.
So i upload the files from attach_mod>contrib>phpbb_attach>templates>subSilver
all the files in there to my template folder?

Posted: Fri Jul 16, 2004 12:53 pm
by morpheus2matrix
yes :)

Posted: Fri Jul 16, 2004 2:16 pm
by BlaxLash
in addition to my previous post, i dont want to use the tumbnailoption, i want to resize the pic itself...

Posted: Fri Jul 16, 2004 2:33 pm
by Freecode
i have done that and still the same error

Posted: Fri Jul 16, 2004 3:21 pm
by morpheus2matrix
now, upload the files of root/templates/subSilver/ in your template folder

old version

Posted: Fri Jul 16, 2004 5:48 pm
by nathan42100
either can i have the older version link, or instructions for installing the latest one w/ easy mod?

please and thank you

Posted: Fri Jul 16, 2004 5:55 pm
by nathan42100
nvm

Posted: Fri Jul 16, 2004 6:31 pm
by alyster4k
I think I solved my problem by switching from relying on GD2 to Imagemagick. I'll post up if I see anymore issues. Thanks.

Posted: Fri Jul 16, 2004 7:14 pm
by nathan42100
i dont know if this was asked before, but i have a forum with 3 templates, and the attachment only shows up on 1 template. whats the fix for this?

Posted: Fri Jul 16, 2004 7:19 pm
by nathan42100
nvm again. lol

sorry