[2.0.18] Cash Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
1036
66%
Very Good
239
15%
Good
121
8%
Fair
36
2%
Poor
126
8%
 
Total votes: 1558

celeb-x
Registered User
Posts: 30
Joined: Sat Jun 18, 2005 10:31 pm
Location: The Netherlands
Contact:

Post by celeb-x »

My adminpanels redirect to /index.php, has anyone else experienced this problem ?

Best Regards,
Celeb-X

User avatar
Snowboardalliance
Registered User
Posts: 98
Joined: Mon Nov 29, 2004 2:36 am

Post by Snowboardalliance »

Goronlink wrote: BTW, I'm having a bit of a problem. For some reason, on viewtopic.php where my cash amount is supposed to be displayed, the image I set for the currency is there but the number isn't. Anyone know how I might fix that? I would appreciate any help!


I know, huge bug. But there's no one developing the mod to fix it :(

User avatar
Goronlink
Registered User
Posts: 205
Joined: Sat Apr 26, 2003 11:26 pm
Location: phpbb.com
Contact:

Post by Goronlink »

I figured out what it was. My problem was a tad different from the one everyone else was having. From what I understand, the cash amounts supposedly arent' supposed to show up in forums that don't have cash enabled. For me, it wasn't showing up anywhere. I figured out the reason was that there were still some places in my database that referred to the points mod that I had installed a long time ago but had abandoned by replacing all of my phpBB files. It was conflicting with my currency, which I had set to user_points, as was suggested with the cash mod so that it would help compatibility issues. After I deleted all instances of points and user_points in my database, then created the currency again, my problems went away.

*chanler
Registered User
Posts: 1
Joined: Sat Jul 16, 2005 6:23 pm
Location: SC
Contact:

Uploads

Post by *chanler »

Do I have to upload all of the files in the zip when I Upload, or just the ones I modified???? Please help!!!
*Chanler* Posted

magnum80
Registered User
Posts: 4
Joined: Sat Jul 16, 2005 8:56 pm

Post by magnum80 »

Its really annoying beacuse when I try to do everything as it says it still comes up with this message "message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?" what have i done!!

magnum80
Registered User
Posts: 4
Joined: Sat Jul 16, 2005 8:56 pm

Post by magnum80 »

now i deleted a line in the functions_cash.php file on line 657 n my forum works but i dont no where the cash is its really not working!!

Swerve1000
Registered User
Posts: 146
Joined: Sat Apr 16, 2005 1:01 am
Location: Nottingham, England

Post by Swerve1000 »

are you adding the Mod manually?

Dorfdad
Registered User
Posts: 6
Joined: Sun Jul 17, 2005 12:20 am

Weird problem after installing CASHMOD with memberlist

Post by Dorfdad »

Ive installed cashmod manually on phpbb 2.016 and its works 100% fine one the board but now Im having a weird problem. Whenever you go to memberlist I get the following error.

Parse error: parse error, unexpected T_VARIABLE in /home/sonyve83/public_html/memberlist.php on line 275

here are the instructions
#-----[ FIND ]------------------------------------------
#
'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id"))

#
#-----[ AFTER, ADD ]------------------------------------------
#
);

$cm_memberlist->listing($template,$row

-------------------------------------------------------


and here is what I did

'U_VIEWPROFILE' => append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=$user_id"))
);
$cm_memberlist->listing($template,$row
$i++)

}

I cannot fiigure this one out and since there was no EZMOD for cashmod I dunno where to go or what to do next? Can someone please help me out.

Thanks in Advance..

Dorfdad

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator »

Can anyone tell me is the amount given per post can be set by group. So say group one gets 1 point per post, group 2 gets 2 points, so on?

happypappy
Registered User
Posts: 463
Joined: Wed Apr 27, 2005 1:44 am

Post by happypappy »

I have EVERYTHING working perfectly.....BUT 2 things i need answered......i have added a bunch of cash to my admin username so i could buy some of the features and see if they work......well i bought a colored username and that worked fine.....tried the glow and shadow with no luck.....what exactly should i look for to fix that problem....also in veiwprofile isnt iot supposed to list what items you have purchased?.....all it says is ITEMS as a link and then underneath it has the name of the cash with amount to the right and under that is the {modify users cash or the donate cash link}.....isnt there supposed to be images displayed?......thanx

User avatar
Snakegamer
Registered User
Posts: 16
Joined: Mon Jul 18, 2005 6:43 am

Post by Snakegamer »

Hey,
I have install this mod.
And when i go to Adminpanel.
And click on the thing that marked.
I see this:

Image

jordan121
Registered User
Posts: 1
Joined: Mon Jul 18, 2005 7:35 am

Post by jordan121 »

im haveing trouble when users post they get max points

User avatar
Snakegamer
Registered User
Posts: 16
Joined: Mon Jul 18, 2005 6:43 am

Post by Snakegamer »

Snakegamer wrote: Hey,
I have install this mod.
And when i go to Adminpanel.
And click on the thing that marked.
I see this:

Image

Anyone?

I hope that anybody knows how I fix this?

edwardsun
Registered User
Posts: 41
Joined: Tue Aug 17, 2004 9:37 pm
Location: Somewhere

Post by edwardsun »

Do I have to upload all of the files in the zip when I Upload, or just the ones I modified???? Please help!!!


Read the install file to see what files you should upload / copy.
its really annoying beacuse when I try to do everything as it says it still comes up with this message "message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?" what have i done!!


You should've read the Troubleshooting guide Xore posted on the first page. But anyways, you should run sql_install.php (upload it to your phpbb root dir. and then run it)
now i deleted a line in the functions_cash.php file on line 657 n my forum works but i dont no where the cash is its really not working!!

You should put it back and do what I stated above
I have EVERYTHING working perfectly.....BUT 2 things i need answered......i have added a bunch of cash to my admin username so i could buy some of the features and see if they work......well i bought a colored username and that worked fine.....tried the glow and shadow with no luck.....what exactly should i look for to fix that problem....also in veiwprofile isnt iot supposed to list what items you have purchased?.....all it says is ITEMS as a link and then underneath it has the name of the cash with amount to the right and under that is the {modify users cash or the donate cash link}.....isnt there supposed to be images displayed?......thanx

This is not cash mod's problem. It's your shop MOD's. But I think it's because the glow/shadow are not compatible with browsers other than IE
Hey,
I have install this mod.
And when i go to Adminpanel.
And click on the thing that marked.
I see this:

From Troubleshooting Guide (first page) wrote: Fatal error: Cannot instantiate non-existent class: cash_menucat

Problem: This class is defined in functions_cash.php, which should be included via common.php (which is included into admin panels via pagestart.php, which most likely means functions_cash.php isn't being included in common.php (or properly)
Fix: Check your install instructions, Find the instructions for common.php and apply the edits properly

--------------------------------

Hope that answers just about everything
ImgNow - Image Uploading Service.

User avatar
Snakegamer
Registered User
Posts: 16
Joined: Mon Jul 18, 2005 6:43 am

Post by Snakegamer »

But i dont understand what i must do.

Post Reply

Return to “[2.0.x] MOD Database Releases”