[2.0.18] Cash Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
1036
66%
Very Good
239
15%
Good
121
8%
Fair
36
2%
Poor
126
8%
 
Total votes: 1558

Flash_619
Registered User
Posts: 29
Joined: Fri Feb 23, 2007 10:20 pm

Post by Flash_619 » Thu Mar 01, 2007 11:24 pm

Fatal error: Call to a member function droplists() on a non-object in C:\Sites\Single23\flash619\webroot\forums\memberlist.php on line 76
--------------------------------------------------------------------------------------
when trying to get to memberlist
--------------------------------------------------------------------------------------
Fatal error: Call to a member function generate_columns() on a non-object in C:\Sites\Single23\flash619\webroot\forums\viewtopic.php on line 400
--------------------------------------------------------------------------------------
when trying to access post

and i still get the original error message while trying to access it from admin panel :evil:

User avatar
MarioSimpson
Registered User
Posts: 71
Joined: Mon Dec 25, 2006 4:24 pm
Contact:

Post by MarioSimpson » Fri Mar 02, 2007 12:24 am

Have you fallowed the steps of coding the other files?

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51870
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Fri Mar 02, 2007 12:54 am

You forgot the edit to common.php

Flash_619
Registered User
Posts: 29
Joined: Fri Feb 23, 2007 10:20 pm

still get errors

Post by Flash_619 » Fri Mar 02, 2007 1:23 pm

now when accessing it through the admin panel i get the following:

Fatal error: Call to a member function sql_query() on a non-object in C:\Sites\Single23\flash619\webroot\forums\includes\functions_cash.php on line 655

When trying to get to memberlist i get the following:

Fatal error: Class 'Template' not found in C:\Sites\Single23\flash619\webroot\forums\includes\classes_cash.php on line 40

and the same whenever you try to post a reply. :?

http://www.gameplayerznews.com/forums2/index.php

http://www.gameplayerznews.com/forums2/memberlist.php[/url]

User avatar
MarioSimpson
Registered User
Posts: 71
Joined: Mon Dec 25, 2006 4:24 pm
Contact:

Post by MarioSimpson » Fri Mar 02, 2007 8:32 pm

well then you forgot to add that file "classes_cash.php"
and you forgot to add functions_cash.php Or you installed it in the rong place, mabby you also forgot to edit those files if it told you to?

also did you read the instructions about you having to use your browser to install part of it? Read:

Code: Select all

1) copy sql_install.php to your main ("root") phpBB directory
		2) load the page via your browser (you will be asked to log in if you have not already)
		3) delete the file.
or if you wish to do them manualy read and fallow the instructions in sql_223.txt file that came with cash mod download.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51870
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: still get errors

Post by Brf » Fri Mar 02, 2007 9:15 pm

Flash_619 wrote: now when accessing it through the admin panel i get the following:

Fatal error: Call to a member function sql_query() on a non-object in C:\Sites\Single23\flash619\webroot\forums\includes\functions_cash.php on line 655


You have the edit to common.php in the wrong place. It belongs after the other includes.

thedahaka88
Registered User
Posts: 59
Joined: Sat Nov 25, 2006 5:45 pm

Post by thedahaka88 » Sat Mar 03, 2007 2:08 am

Error retrieving group data

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND user_pending = 0 ORDER BY group_id ASC' at line 4

SELECT group_id FROM phpbb_user_group WHERE user_id = AND user_pending = 0 ORDER BY group_id ASC

Line : 1227
File : functions_cash.php

i get this error when i make a reply to a topic, i asked the page before but i believe no one answered me. someone told me that
"Tell them the user_id for the cash_user class isn't being set."

any help?

GeekyGirl
Registered User
Posts: 29
Joined: Mon Jan 01, 2007 2:54 pm

Problems With Cash being recorded - Help a contest is under

Post by GeekyGirl » Sat Mar 03, 2007 6:19 am

Hello,

I'm in desparate need of some help with the Cash Mod. I have it set up to use a single currency that has 2 decimal points.

A user gets 0.05 points for replying to a post and 2 points for starting a new topic.

When a user replies to a post, they see the message that they received 0.05 points for the post. But then it doesn't show up in their points listed under their names, in the profile, etc. It also doesn't show up in the log.

Then if a user starts a new post, they get the message that they received 2 points. The points show up in their user profile, under name etc. but not in the log.

I just started a week long contest that is dependent of the points system.

When I first did a test run with this, I didn't have fractions of points, only whole numbers.

Where do I look to fix this?

Is the log supposed to show every single point that is earned? If so, why isn't it showing?
Thanks,
GG

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51870
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Problems With Cash being recorded - Help a contest is un

Post by Brf » Sat Mar 03, 2007 2:05 pm

GeekyGirl wrote: Is the log supposed to show every single point that is earned? If so, why isn't it showing?


No.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51870
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Sat Mar 03, 2007 2:07 pm

thedahaka88 wrote: i get this error when i make a reply to a topic


You missed this edit in posting.php:

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
# 
		$sql = "SELECT f.*, t.topic_status, t.topic_title, t.topic_type

# 
#-----[ IN-LINE FIND ]------------------------------------------ 
# 
t.topic_type

# 
#-----[ IN-LINE AFTER, ADD ]------------------------------------------ 
#
, t.topic_poster

Flash_619
Registered User
Posts: 29
Joined: Fri Feb 23, 2007 10:20 pm

Re: still get errors

Post by Flash_619 » Sat Mar 03, 2007 2:20 pm

Brf wrote:
Flash_619 wrote:now when accessing it through the admin panel i get the following:

Fatal error: Call to a member function sql_query() on a non-object in C:\Sites\Single23\flash619\webroot\forums\includes\functions_cash.php on line 655


You have the edit to common.php in the wrong place. It belongs after the other includes.


ah ye i see well let me try now. :?:

Xcetera
Registered User
Posts: 11
Joined: Sat Feb 10, 2007 3:30 am

Post by Xcetera » Sat Mar 03, 2007 8:13 pm

Thank you for this mod. It works great and I love it! I have one issue I need help with. I think I must have done something wrong.

Here is my error:

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home2/nickelbe/public_html/forum/includes/template.php(127) : eval()'d code:1) in /home2/nickelbe/public_html/forum/includes/sessions.php on line 614
Thanks.

Mourgos
Registered User
Posts: 27
Joined: Thu Mar 01, 2007 8:02 am

It doesn't show the points in memberlist!

Post by Mourgos » Sun Mar 04, 2007 9:41 am

I installed this mod and i am using it a week with no problem! But today i tried to install Democracy MOD. All are working perfect, I've checked all of their features!
The only problem is than under the name of each currency in memberlist it shows only the name of the currency :? I checked the code in memberlist.php and in templates/xxxxxx/memberlist_body.tpl but i couldn't find something that i can fix :S
I would appreciate if someone can help me :)


here are my memberlist.php and templates/AcidTechBlood/memberlist_body.tpl (it also happens the same and in subSilver template :()



Here is a screenshot of what i mean...

thedahaka88
Registered User
Posts: 59
Joined: Sat Nov 25, 2006 5:45 pm

Post by thedahaka88 » Sun Mar 04, 2007 10:33 am

I did that and i still get this error when i reply to a topic, and it dosent show on the recent post section or even on the topic but when i look in the topic it shows it


Error retrieving group data

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND user_pending = 0 ORDER BY group_id ASC' at line 4

SELECT group_id FROM phpbb_user_group WHERE user_id = AND user_pending = 0 ORDER BY group_id ASC

Line : 1227
File : functions_cash.php

jbarrouk
Registered User
Posts: 218
Joined: Mon May 15, 2006 3:10 am
Contact:

Not showing on user CP

Post by jbarrouk » Sun Mar 04, 2007 5:09 pm

Hello,
I just noticed that my currencies are not showing up on my user CP. They used to and I am not sure when they stopped. I have two currencies. One is called "Singular Points", which is points rewarded automaically per post. The other is called "Singular Cash", which is only awarded by me.

I would appreciate any help. My forum is found here: http://asingularcreation.com/Forums/

best regards,
Joe

Post Reply

Return to “[2.0.x] MOD Database Releases”