Page 660 of 798

Posted: Sat Dec 02, 2006 5:16 am
by Jackanape
Always install the latest version of any mod, and always be sure to update to the latest version of phpBB...good rule of thumb!

Posted: Sun Dec 03, 2006 2:55 am
by Yego
:roll:
And which is the last version of this mod?

Posted: Sun Dec 03, 2006 4:45 am
by Cl0wn
I don't know if anybody has had this problem before but sometimes when I moderate a users cash/currency, it will private message them and say that I've modified their cash but it has an extra "n" at the end of it. I've supplied an image of the error and was wondering what file would have to be edited in order to fix it.
Image
As you can see, there is an "n" at the end of "22 Points".

Points is currently set as the currency.

Posted: Sun Dec 03, 2006 7:20 am
by Mega2k
To Jackanape: I have received your PM....
This is my function_display in function_cash.php for number formating in thousand. I post it here to share with the others that may have same problems, hope this will help... give it a try...
(Thank Brf for his great supports...)

Code: Select all

function display($amount,$surpress_image = false,$quotes = false)
	{
		if( $this->mask(CURRENCY_PREFIX) )
		{
			return ($this->name($surpress_image,$quotes,$bbcode) . ' ' . number_format($amount,0,".",","));
		}
		else
		{
			return (number_format($amount,0,".",",") . ' ' . $this->name($surpress_image,$quotes));
		}
	}
Cheers, :)

Posted: Sun Dec 03, 2006 1:07 pm
by Brf
Cl0wn wrote: has an extra "n" at the end of it.


There is something wrong with your version of phpBB that is stripping the slashes from the language variable... That message has

Code: Select all

 "\n" 
in it which is supposed to be a line-break.

Posted: Sun Dec 03, 2006 3:30 pm
by Scriptmaster10
This may have been answered but I cannot be bothered to trail through 660 pages of posts.

Im getting

Fatal error: Call to a member function post_vars() on a non-object etc.....

when I click profile.

what do I need to change?

Posted: Sun Dec 03, 2006 4:11 pm
by Scriptmaster10
Ok, thats sorted with trfs fix.

But Im still not getting any cash displayed on the profile page



I checked that
$cm_viewprofile->post_vars($template,$profiledata,$userdata);

was in usercp_viewprofile.php but still nothing

Posted: Sun Dec 03, 2006 8:18 pm
by Yego
I'll ask once again.

Which is the last version of this mod?

Posted: Sun Dec 03, 2006 8:21 pm
by TheHackMan
Yego, the latest version I know of is what they have uploaded here 2.2.3


I just recently added this mod and now I am getting this error no matter what I try to do(view a profile, post a new topic, view a topic)
Fatal error: Class template_plus: Cannot inherit from undefined class template in C:\Domains\9lordrescue.com\wwwroot\forum\includes\classes_cash.php on line 40


When I try to go to the Cash Admin and Cash Help tabs in the admin section I get this error:
Fatal error: Call to a member function on a non-object in C:\Domains\9lordrescue.com\wwwroot\forum\includes\functions_cash.php on line 659



I installed and uploaded everything like it said, I did the SQL stuff like it said and I cant find anything wrong with how I installed it since I did everything exactly and even double checking my actions as I went. Can anybody help?


Edit: nvm, I searched a bit and found out there was an error in the common.php file(guess I did make a mistake, I put the edit by the wrong area, oh well). It all works perfect great mod!

Posted: Sun Dec 03, 2006 8:54 pm
by felguard
I have CashMod223a installed, everything's fine and stuff except for one thing.

When somone makes a topic/post they get 2 points for it, but if they delete the topic/post, they still keep the 2 points for posting it. How do you make it so that if they delete the post/topic, the 2 points will also be taken away from it?

Posted: Sun Dec 03, 2006 10:28 pm
by Yego
TheHackMan wrote: Yego, the latest version I know of is what they have uploaded here 2.2.3


Thanks, I'll see if that one works with my phpBB 2.0.21

Posted: Sun Dec 03, 2006 11:12 pm
by big_master
Hello I installed cash mod and when I try to veiw a topic I get this error:

Could not obtain post/user information.
DEBUG MODE
SQL Error : 1054 Unknown column 'u.user_cash' in 'field list'
SELECT u.username, u.user_cash, u.user_id, u.user_posts, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile, p.*, pt.post_text, pt.post_subject, pt.bbcode_uid FROM phpbb_posts p, phpbb_users u, phpbb_posts_text pt WHERE p.topic_id = 351 AND pt.post_id = p.post_id AND u.user_id = p.poster_id ORDER BY p.post_time ASC LIMIT 0, 15

Line : 404
File : viewtopic.php

Does any one no what might be wrong ?

pwease help?

Posted: Mon Dec 04, 2006 1:33 am
by lilmatt429
i was installing cashmod 2.2.1 with easymod beta 0.3.0 and i got this error.

Code: Select all

Critical Error

FIND FAILED: In file [posting.php] could not find:

$select_sql = ( !$submit ) ? ", t.topic_title, p.enable_bbcode, p.enable_html, p.enable_smilies, p.enable_sig, p.post_username, pt.post_subject, pt.post_text, pt.bbcode_uid, u.username, u.user_id, u.user_sig" : '';

MOD script line #253 :: FAQ :: Report
i went into the file "posting.php", searched up the code with ctrl+f and it didnt find it. please help?

Posted: Mon Dec 04, 2006 2:15 am
by dvdd127
[deleted by user]
started thread in mod request board

Re: pwease help?

Posted: Mon Dec 04, 2006 5:47 am
by big_master
lilmatt429 wrote: i was installing cashmod 2.2.1 with easymod beta 0.3.0 and i got this error.

Code: Select all

Critical Error

FIND FAILED: In file [posting.php] could not find:

$select_sql = ( !$submit ) ? ", t.topic_title, p.enable_bbcode, p.enable_html, p.enable_smilies, p.enable_sig, p.post_username, pt.post_subject, pt.post_text, pt.bbcode_uid, u.username, u.user_id, u.user_sig" : '';

MOD script line #253 :: FAQ :: Report
i went into the file "posting.php", searched up the code with ctrl+f and it didnt find it. please help?


You have maybe changed that file before, so instead of searching for that entire line just look for something like "$select_sql" or "t.topic_title, p.enable_bbcode," Then when you find it.. mod it by hand, then open your install file in easy mod,, and remove that part from your install file. Then run your easy mod again to install the rest.