Page 661 of 798

Posted: Mon Dec 04, 2006 12:36 pm
by Brf
Scriptmaster10 wrote: I checked that
$cm_viewprofile->post_vars($template,$profiledata,$userdata);

was in usercp_viewprofile.php but still nothing


How about profile_view_body.tpl? Is the edit in the correct edit there? Also, make sure you have your cash enabled to show in profiles.

Posted: Mon Dec 04, 2006 12:39 pm
by Brf
big_master wrote: Hello I installed cash mod and when I try to veiw a topic I get this error:

Could not obtain post/user information.
DEBUG MODE
SQL Error : 1054 Unknown column 'u.user_cash' in 'field list'


That is from your user and cash tables being out of synch. You must have restored one of them from a previous version.

Posted: Mon Dec 04, 2006 3:14 pm
by Scriptmaster10
Yes {CASH} has been placed where it should go (below interests) in profile_view_body.

Posted: Mon Dec 04, 2006 3:16 pm
by Jackanape
Big_Master, did you run your SQL queries? It could be as simple as that...?

Posted: Mon Dec 04, 2006 4:23 pm
by big_master
I went ahead and droped them, and then ran them again. Now it seems to work fine. My new problem is trying to get the cash to show in vewtopic_ body.tpl for MorpheusXRed. The line for sub silver was
#-----[ FIND ]------------
#
{postrow.POSTER_FROM}
#
#-----[ IN-LINE FIND ]-----
#
{postrow.POSTER_FROM}
#
#-----[ IN-LINE AFTER, ADD ]--
#
<br />{postrow.CASH}

For MorpheusXRed it is not so easy.

Code: Select all

<!-- IF C_PM --><!-- DEFINE $CA_NEW_MSGS = true --><!-- ENDIF -->
{TPL_CONTENT_TOPNAV1}<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" class="navbar-links"><a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a></td>
	<td align="right" class="navbar-text">{CURRENT_TIME}</td>
</tr>
</table><!-- IF $CA_NEW_MSGS -->{TPL_CONTENT_TOPNAV2_PM}<!-- ELSE -->{TPL_CONTENT_TOPNAV2}<!-- ENDIF -->
<!-- IF $CA_NEW_MSGS --><!-- INCLUDE newpm.tpl --><!-- ENDIF -->

<table width="100%" cellspacing="0" cellpadding="2" border="0">
  <tr> 
    <td align="left" valign="bottom" width="25%"><a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></td>
	<td align="center" valign="top" width="50%"><span class="gen"><!-- IF $CA_NEW_MSGS --><br /><!-- ENDIF --><a href="{U_VIEW_TOPIC}"><b>{TOPIC_TITLE}</b></a></span></td>
	 <td align="right" valign="bottom" width="25%"><form action="{CA_SEARCH_INDEX}" method="post" class="inline-form"><input type="hidden" name="show_results" value="topics" /><input type="hidden" name="search_forum" value="{CA_SEARCH_FORUM}" />
		<input type="text" name="search_keywords" class="post" size="15" />
		<input type="submit" value="{L_SEARCH}" class="mainoption" />
	</form>
	<span class="pagination">{PAGINATION}</span></td>
  </tr>
</table>

{POLL_DISPLAY} 

<?php

global $userdata, $board_config, $topic_id, $is_auth, $forum_topic_data, $lang, $phpEx;

if(!isset($can_reply))
{
	$can_reply = $this->style_config['quick_reply'] && $userdata['session_logged_in'] ? true : false;
	if($can_reply)
	{
		$is_auth_type = 'auth_reply';
		if(!$is_auth[$is_auth_type])
		{
			$can_reply = false;
		}
		elseif ( ($forum_topic_data['forum_status'] == FORUM_LOCKED || $forum_topic_data['topic_status'] == TOPIC_LOCKED) && !$is_auth['auth_mod'] ) 
		{
			$can_reply = false;
		}
	}
	if($can_reply)
	{
		$this->assign_block_vars('xs_quick_reply', array());
	}
}

$postrow_count = ( isset($this->_tpldata['postrow.']) ) ?  sizeof($this->_tpldata['postrow.']) : 0;
for ($postrow_i = 0; $postrow_i < $postrow_count; $postrow_i++)
{
	$postrow_item = &$this->_tpldata['postrow.'][$postrow_i];
	// set profile link and search button
	if(!empty($postrow_item['PROFILE']) && strpos($postrow_item['POSTER_NAME'],'<') === false)
	{
		$postrow_item['SEARCH_IMG2'] = str_replace('%s', htmlspecialchars($postrow_item['POSTER_NAME']), $postrow_item['SEARCH_IMG']);
		if($this->vars['TPL_CFG_TOPICVIEW'] !== 'hide')
		{
			$search = array($lang['Read_profile'], '<a ');
			$replace = array($postrow_item['POSTER_NAME'],'<a class="name" ');
			$postrow_item['POSTER_NAME'] = str_replace($search, $replace, $postrow_item['PROFILE']);
		}
	}
	// check for new post
	$new_post = strpos($postrow_item['MINI_POST_IMG'], '_new') > 0 ? true : false;
	$postrow_item['TPL_HDR1'] = $new_post ? $this->vars['TPL_HDR1_NEW'] : $this->vars['TPL_HDR1_POST'];
	$postrow_item['TPL_HDR2'] = $new_post ? $this->vars['TPL_HDR2_NEW'] : $this->vars['TPL_HDR2'];
	$postrow_item['TPL_FTR'] = $new_post ? $this->vars['TPL_FTR_NEW'] : $this->vars['TPL_FTR'];
	// set backgrounds
	$num = ($postrow_i % 2) + 1;
	$postrow_item['TPL_CLASS_POST'] = 'post' . $num;
	$postrow_item['TPL_CLASS_PROFILE'] = 'post-left' . $num;
}	

?>

<!-- IF TPL_CFG_TOPICVIEW == "above" --><!-- INCLUDE viewtopic_post_above.tpl --><!-- ENDIF -->
<!-- IF TPL_CFG_TOPICVIEW == "left" --><!-- INCLUDE viewtopic_post_left.tpl --><!-- ENDIF -->
<!-- IF TPL_CFG_TOPICVIEW == "right" --><!-- INCLUDE viewtopic_post_right.tpl --><!-- ENDIF -->
<!-- IF TPL_CFG_TOPICVIEW == "hide" --><!-- INCLUDE viewtopic_post_none.tpl --><!-- ENDIF -->


{TPL_HDR1_ORANGE}<a href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a>{TPL_HDR2}<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
<tr>
	<td class="row1g" align="left" valign="top">
	<table border="0" cellspacing="0" cellpadding="5" width="100%">
	<tr>
		<td align="left" valign="top">
			<span class="gensmall">{S_AUTH_LIST}</span>
		</td>
		<td align="right" valign="top">
			<span class="gensmall">{S_TIMEZONE}&nbsp;&nbsp;<br />
			{PAGE_NUMBER}&nbsp;&nbsp;</span>
			<div class="pagination">{PAGINATION}</div><br />
			<span class="gensmall">{S_WATCH_TOPIC}</span>
		</td>
	</tr>
	</table>
	</td>
</tr>
<tr>
	<td class="catBottom" align="center" valign="middle" nowrap="nowrap"><table border="0" cellspacing="0" cellpadding="2" width="100%">
	<tr>
		<td align="left" valign="middle" nowrap="nowrap"><form method="post" action="{S_POST_DAYS_ACTION}" style="display: inline;">{S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></form></td>
		<td align="right" valign="middle" nowrap="nowrap">{JUMPBOX}</td>
	</tr>
	</table>
	</td>
</tr>
</table>{TPL_FTR}

<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" valign="top" style="padding-top: 5px; padding-bottom: 5px;">&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a>
	<!-- BEGIN xs_quick_reply -->
	&nbsp;<a href="javascript:ShowHide('quick_reply','quick_reply2');"><img src="{T_TEMPLATE_PATH}/images/lang_{T_LANG}/{T_COLOR}/quick_reply.gif" border="0" alt="{CA_QR_BUTTON}" align="middle" /></a>
	<!-- END xs_quick_reply -->
	</td>
	<td align="right" valign="top" style="padding-top: 5px;">{S_TOPIC_ADMIN}&nbsp;</td>
</tr>
</table>

<div id="quick_reply" style="display: none; position: relative; "><form action="<?php echo append_sid('posting.'.$phpEx); ?>" method="post" name="post" style="display: inline;">{S_HIDDEN_FIELDS}{TPL_HDR1}{CA_QR_BUTTON}{TPL_HDR2}<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
<tr> 
	<td class="row1" width="200" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Subject']; ?>:</b></span></td>
	<td class="row2" width="100%"><input type="text" name="subject" size="45" maxlength="60" style="width:98%" tabindex="2" class="post" value="" /></td>
</tr>
<tr> 
	<td class="row1" width="200" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Message_body']; ?>:<br /><img src="{T_TEMPLATE_PATH}/images/spacer.gif" width="200" height="1" border="0" alt="" /></b></span></td>
	<td class="row2" width="100%"><textarea name="message" rows="15" cols="35" style="width:98%" tabindex="3" class="post"></textarea><br />
			  <a href="javascript:void(0);" onclick="window.open('http://www.postimage.org/index.php?mode=phpbb&tpl=' + 'MorpheusXRed' + '&forumurl=' + escape(document.location.href), '_imagehost', 'resizable=yes,width=500,height=400');return false;">Add image to post</a></td>
</tr>
<tr> 
	<td class="row1" valign="top" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Options']; ?>:</b></span></td>
	<td class="row2"><span class="genmed">
	<?php 
		$user_sig = ( $userdata['user_sig'] != '' && $board_config['allow_sig'] ) ? $userdata['user_sig'] : '';
		$html_on = $board_config['allow_html'] ? $userdata['user_allowhtml'] : 1;
		$bbcode_on = $board_config['allow_bbcode'] ? $userdata['user_allowbbcode'] : 0;
		$smilies_on = $board_config['allow_smilies'] ? $userdata['user_allowsmile'] : 0;
	?>
	<?php if($board_config['allow_html']) { ?>
	<label><input type="checkbox" name="disable_html" <?php echo ($html_on ? '' : 'checked="checked"'); ?> /> <span class="genmed"><?php echo $lang['Disable_HTML_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_html" value="checked" /><?php } ?>
	<?php if($board_config['allow_bbcode']) { ?>
	<label><input type="checkbox" name="disable_bbcode" <?php echo ($bbcode_on ? '' : 'checked="checked"'); ?> /> <span class="genmed"><?php echo $lang['Disable_BBCode_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_bbcode" value="checked" /><?php } ?>
	<?php if($board_config['allow_smilies']) { ?>
	<label><input type="checkbox" name="disable_smilies" <?php echo ($smilies_on ? '' : 'checked="checked"'); ?>  /> <span class="genmed"><?php echo $lang['Disable_Smilies_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_smilies" value="checked" /><?php } ?>
	<?php if($user_sig) {  ?>
	<label><input type="checkbox" name="attach_sig" <?php echo ($userdata['user_attachsig'] ? 'checked="checked"' : ''); ?> /> <span class="genmed"><?php echo $lang['Attach_signature']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="attach_sig" value="" /><?php } ?>
	<label><input type="checkbox" name="notify" <?php echo ($userdata['user_notify'] ? 'checked="checked"' : ''); ?> /> <span class="genmed"><?php echo $lang['Notify']; ?></span></label><br />
	</span></td>
</tr>
<tr> 
	<td class="catBottom" colspan="2" align="center" height="25"> <input type="hidden" name="mode" value="reply" /><input type="hidden" name="t" value="<?php echo $topic_id; ?>" /><input type="submit" accesskey="s" tabindex="6" name="post" class="mainoption" value="<?php echo $lang['Submit']; ?>" />&nbsp;<input type="submit" tabindex="5" name="preview" class="mainoption" value="<?php echo $lang['Preview']; ?>" /></td>
</tr>
</table>{TPL_FTR}</form></div>


{TPL_CONTENT_BOTTOMNAV1}<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" class="navbar-links"><a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a></td>
	<td align="right" class="navbar-text">{CURRENT_TIME}</td>
</tr>
</table>{TP

Posted: Mon Dec 04, 2006 4:58 pm
by Brf
Jackanape wrote: Big_Master, did you run your SQL queries? It could be as simple as that...?


No it couldnt be. There are no currencies added by default, and this line is looking for one called "user_cash". Therefore he added a user_cash at one point, and it is no longer in the user table. Therfore either the user table or the cash table must have be restored.

Posted: Mon Dec 04, 2006 5:48 pm
by big_master
I found out were to put the "<br />{postrow.CASH}" in MorpheusXRed.
It had to go in the viewtopic_post_left.tpl were as subsilver it was to go in the viewtopic_body.tpl

It seems to be working like a charm now.

Posted: Mon Dec 04, 2006 6:21 pm
by Scriptmaster10
Scriptmaster10 wrote: Yes {CASH} has been placed where it should go (below interests) in profile_view_body.


Anyone?

Posted: Mon Dec 04, 2006 8:31 pm
by alextee_2000
sorry if this question has been answed.
seem i cant search for result.

please look at screen shot:
Image

i use this cash mod in english version is nothing problem.
but when i try to install in my chinese version,it come problem.

problem:
value disappear in view topic
frist currency display fine
but second currency disapper!
it only show up the name of currency!

anyone can solve this problem?
please assume the name is English.
because i just change the name from lang_main
i think it should not the problem to cause the value disappear....


Please Help

Posted: Mon Dec 04, 2006 9:01 pm
by Brf
Are both of your currencies set to award in that forum? If a currency is not set "On" for that forum in the Cash Forums page, its value will not be shown in that forum.

Posted: Tue Dec 05, 2006 8:13 am
by felguard
I have CashMod223a installed, everything's fine and stuff except for one thing.

When somone makes a topic/post they get 2 points for it, but if they delete the topic/post, they still keep the 2 points for posting it. How do you make it so that if they delete the post/topic, the 2 points will also be taken away from it?

Posted: Tue Dec 05, 2006 11:35 am
by Scriptmaster10
Scriptmaster10 wrote:
Scriptmaster10 wrote:Yes {CASH} has been placed where it should go (below interests) in profile_view_body.


Anyone?


Ok Im being ignored.

Posted: Tue Dec 05, 2006 12:18 pm
by Brf
It is tough to help you when you have not given any information about your site... and why do you have a link in your footer that goes to a non-existant site?

Do you have your cash set to show in usercp on the cash settings screen?

Posted: Tue Dec 05, 2006 12:22 pm
by Brf
felguard wrote: I have CashMod223a installed, everything's fine and stuff except for one thing.

When somone makes a topic/post they get 2 points for it, but if they delete the topic/post, they still keep the 2 points for posting it. How do you make it so that if they delete the post/topic, the 2 points will also be taken away from it?


Sorry I do not have that problem with my forum.
I just tested it.

Do you have the proper edits in includes/functions_post.php?

Posted: Tue Dec 05, 2006 6:39 pm
by alextee_2000
Brf wrote: Are both of your currencies set to award in that forum? If a currency is not set "On" for that forum in the Cash Forums page, its value will not be shown in that forum.


thank for the reply
i will try on it:)
later if still cant show out, i will request again
thank