Page 3 of 3

Posted: Tue Nov 04, 2003 10:52 am
by Jamy
There is something weird in my viewtopic_body.tpl file I use the view topic tpl file from the eDonkey style made by subBlue design

in that tpl file it says

Code: Select all

<td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: 
            {postrow.POST_DATE}<span class="gen">&</span>& &{L_POST_SUBJECT}: 
            {postrow.POST_SUBJECT}</span></td>
          <td valign="top" nowrap>{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} 
            {postrow.IP_IMG}</td>
But in all the other styles it says just what your instructions say to look for

Code: Select all

				<td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&</span>& &{L_POST_SUBJECT}: {postrow.POST_SUBJECT}</span></td>
				<td valign="top" nowrap="nowrap">{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td>
can I take it from subSilver and use it or do I need to get another style ? this is a cool mod sorry for thinking it was not compatable for 2.0.6

Posted: Tue Nov 25, 2003 4:43 pm
by Red_5
This updated mod (for 2.0.6) has been resubmitted to the mod database and is now awaiting validation.

;-)

Posted: Wed Nov 26, 2003 1:37 am
by Jamy
I tried this once again and the tables would not instal :( I also have another question when you quote someone does it also say in reply to ?

Posted: Wed Nov 26, 2003 9:55 am
by Red_5
How are you trying to modify the tables; by hand or by using the PHP script?

What error's are you getting?

Posted: Wed Nov 26, 2003 8:37 pm
by Jamy
I'm using the php script you sent in the pakage, I don't rember them right off the top of my head. oh well maybe it wasent ment to be, but since I've supported senghong 79's mod and have given him ideas for his next version I'd feel guility if I did use yours now. ALAS can you ever forgive me ?! :)

Posted: Thu Nov 27, 2003 3:56 pm
by Red_5
All you need to do is paste the following after {postrow.POST_SUBJECT} in the template code you have:

Code: Select all

<br />
					{postrow.L_IN_REPLY_TO} {postrow.U_VIEW_POST}</span>
;-)

Posted: Thu Dec 18, 2003 4:18 am
by tonileung
Hello Red_5

Any ideas on how to reply without quote?

Thanks again!

Posted: Thu Dec 18, 2003 10:06 am
by Red_5
Not yet, but it's something I want to look in to when I next have some time. ;-)

Posted: Thu Dec 18, 2003 6:16 pm
by Red_5
It has been brought to my attention that there is a minor bug in the code for this mod.

BUG:
Everytime someone edits a post, their post count goes up by 1 and so does the count of topics posted on the index page.

FIX:
The problem occurs in the following section of the mod (the line in bold):
#
#-----[ FIND ]------------------------------------------
#

submit_post($mode, $post_data, $return_message, $return_meta, $forum_id, $topic_id, $post_id, $poll_id, $topic_type, $bbcode_on, $html_on, $smilies_on, $attach_sig, $bbcode_uid, str_replace("\'", "''", $username), str_replace("\'", "''", $subject), str_replace("\'", "''", $message), str_replace("\'", "''", $poll_title), $poll_options, $poll_length);

#
#-----[ REPLACE WITH ]------------------------------------------
#

if ( $mode == 'reply_post' )
{
submit_post_in_reply_to($mode, $post_data, $return_message, $return_meta, $forum_id, $topic_id, $post_id, $poll_id, $topic_type, $bbcode_on, $html_on, $smilies_on, $attach_sig, $bbcode_uid, str_replace("\'", "''", $username), str_replace("\'", "''", $subject), str_replace("\'", "''", $message), str_replace("\'", "''", $poll_title), $poll_options, $poll_length);
}
else
{
submit_post($mode, $post_data, $return_message, $return_meta, $forum_id, $topic_id, $post_id, $poll_id, $topic_type, $bbcode_on, $html_on, $smilies_on, $attach_sig, $bbcode_uid, str_replace("\'", "''", $username), str_replace("\'", "''", $subject), str_replace("\'", "''", $message), str_replace("\'", "''", $poll_title), $poll_options, $poll_length);
}
$mode = 'reply';


To fix this problem on existing installations, simply delete the line in blue bold (above), and then apply the following:

Code: Select all

# 
#-----[ FIND ]------------------------------------------
#
$user_id = ( $mode == 'reply' || $mode == 'newtopic' ) ? $userdata['user_id'] : $post_data['poster_id'];

#
#-----[ REPLACE WITH ]------------------------------------------
#
$user_id = ( $mode == 'reply' || $mode == 'reply_post' || $mode == 'newtopic' ) ? $userdata['user_id'] : $post_data['poster_id'];
The ZIP files containing this mod have been updated with this change, so new installations should be bug free (I hope). ;-)

Sorry for the inconvenience! :-(

Posted: Sat Apr 16, 2005 4:31 pm
by jh0nny
Red_5 wrote: No problem. Glad to help. ;-)

New Links?

Posted: Tue Sep 12, 2006 1:39 am
by TopDawg
The links for this mod do not seem to be working, and it's just what I've been looking for... Is it available somewhere else?
:(

Edit: Or if you know of a MOD somewhere (trust me, I've looked, lol) that would do the same thing, it would be greatly appreciated.

Thanks everyone!!

Posted: Wed Sep 13, 2006 2:11 am
by TopDawg
Hey. Sorry to bump, but I was just wondering if anyone knew where I can find this mod or one that does the same thing.

I've tried searching through the DB, etc. :oops:

Sorry if I'm being a pain...

Re: New Links?

Posted: Sun Jul 20, 2008 11:16 am
by Red_5
TopDawg wrote:The links for this mod do not seem to be working, and it's just what I've been looking for... Is it available somewhere else?
:(
I've now updated the links to the original mods: http://www.phpbb.com/community/viewtopi ... 6&t=101634

Please note that this mod is no longer supported by the author. If you wish to update this mod for phpBB 3.x, please feel free.