Page 8 of 10

Re: Critical error

Posted: Sun Apr 17, 2005 7:35 pm
by Froggie89
bbus3r wrote: Could not perform improperly formed COPY command.
includes/em_addon_functions.php.txt to includes/em_addon_functions.php

Same thing happens to me.
So, what does that mean exactly? How does one fix that problem? Sorry, but most of this stuff is totally over my head and I'm just plodding my way through as best I can, but any help would be much appreciated...

Posted: Mon Apr 18, 2005 7:13 am
by Mere-Mortal
It means the modder muddled up ;)

What I sometimes find myself doing is having to edit the .MOD file accordingly so EasyMOD will read it correctly. I haven't come accross any problems with EM, but I do find it is only as good as the modder himself. If there's errors, EM is useless until resolved.

Try opening the .MOD file and (backup first) locate the section of code you are struggling with. Perform the task manually and then delete the code from the file. Sometimes you might need to manually copy individual files to their correct lcoation.

I tell you another thing to watch out for. Sometimes the mod will request a "FIND" which is successful, and will then request another "FIND" for a section of text it has already gone past. As with notepad, it just doesn't like it, and will reach the end of the document. Therefore you might need to play around with some.

Best solution is to go for the EM Comliant Mods, which are obvbious by the Logo next to the entry in ACP.

Also take into cosideration the over the course of new phpBB versions, the code will change. For this reason, a Mod for 2.0.x might not work for 2.0.13 unless you specifically ammend the outstanding details.

Re: Critical error

Posted: Mon Apr 18, 2005 8:24 am
by Protopia
Froggie89 wrote:
bbus3r wrote:Could not perform improperly formed COPY command.
includes/em_addon_functions.php.txt to includes/em_addon_functions.php

Same thing happens to me.
So, what does that mean exactly? How does one fix that problem? Sorry, but most of this stuff is totally over my head and I'm just plodding my way through as best I can, but any help would be much appreciated...


1. It appears from the error message that Froggie89 and bbus3r are having problems when trying to install EasyMod itself.

2. The error message suggests to me that the em_addon_functions.php.txt file has not been uploaded to the correct place.

I hope this helps.

Protopia

Re: Critical error

Posted: Tue Apr 19, 2005 3:05 pm
by Keva
Froggie89 wrote:
bbus3r wrote:Could not perform improperly formed COPY command.
includes/em_addon_functions.php.txt to includes/em_addon_functions.php

Same thing happens to me.
So, what does that mean exactly? How does one fix that problem? Sorry, but most of this stuff is totally over my head and I'm just plodding my way through as best I can, but any help would be much appreciated...


i get that too

Posted: Tue Apr 19, 2005 6:28 pm
by bonelifer
The copy command seems to be because they formated it this way:

Code: Select all

includes/em_addon_functions.php.txt to includes/em_addon_functions.php
and it should be formated this way:

Code: Select all

copy includes/em_addon_functions.php.txt to includes/em_addon_functions.php

Yay!

Posted: Tue Apr 19, 2005 9:35 pm
by Froggie89
Thanks so much for your help guys, I have it all figured out and installed now! :D

Posted: Wed Apr 20, 2005 11:52 pm
by crappytheclown
when i go to the ACP, the menu on the left is not there (this is rite after i installed the uninstaller), adn it says
Parse error: parse error, unexpected T_BOOLEAN_OR in /home/ctcforum/public_html/phpbb/admin/admin_easymod.php on line 1295

on taht line is where i added || ($mode == 'uninstall') adn im sure i did it correctly; is there a bug or something??

Re: Found Fix, Please Sticky

Posted: Sat May 07, 2005 6:36 pm
by TheLeprachaun
tbartold wrote:
Javve wrote:templates/subSilver/admin/mod_history.tpl

I tried the fix and it failed .. it was to open up this file and find

<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

Delete the extra space between 5%" class to make it look like

<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

If you do a search for 5% you will only find the first line unless you do a find next to find this line. Meaning.. there are two lines with 5% that have an extra space between the 5% and class (td width="5%" class="{)

You need to delete the extra space on BOTH lines. I tested and it worked fine for me. I have only been messing with the PHP lines for two weeks so if I can do it, anyone can do it. Thanks you to the people that posted about the extra space, it led me to find there are two lines with an extra space. The uninstall mod was the first mod I installed after easymod, so the extra space is either from the creation of the board, or easymod being installed. Either way an easy fix.


It seems like you're not taking the EasyMOD philosophy to heart (never REPLACE and always use the least text needed to FIND). I changed my version of the mod to be insensitive to this "space" problem.

Why not change it to:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/admin/mod_history.tpl
#
#-----[ FIND ]------------------------------------------
#
details
#
#-----[ IN-LINE FIND ]------------------------------------------
#
details
#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
<form method="post" action="{S_ACTION}"><input type="hidden" name="mode" value="uninstall"><input type="hidden" name="mod_id" value="{install.MOD_ID}"><input type="hidden" name="install_file" value="{install.MOD_FILE}"><input type="hidden" name="install_path" value="{install.MOD_PATH}"><input type="hidden" name="password" value="{install.EM_PASS}"><input type="submit" name="post" class="mainoption" value="{L_UNINST}" /></form>
Just my 2 cents worth.

BTW: this also includes the fixes for the missing text on the button, and the missing password problems that I was having.


thanks a lot,you fixed it :wink:

Posted: Sun Jul 10, 2005 7:55 pm
by Nekaid
Ummm, is there any other place I can get this mod? The download is no more. I think they took it off the site. I'd really like to have this mod.

Posted: Thu Jul 14, 2005 5:24 pm
by kashifns
Nekaid wrote: Ummm, is there any other place I can get this mod? The download is no more. I think they took it off the site. I'd really like to have this mod.


Same here. I am looking for this MOD but no luck at the moment. Anyone please let me know from where to get the MOD.

Posted: Sat Jul 16, 2005 12:36 am
by Manshu
I also need this mod :D

Posted: Sat Jul 16, 2005 7:19 am
by -=Azrael=-
Link has been updated...

*EDITED*

(link is gone again)...

Posted: Sat Jul 16, 2005 9:46 pm
by kashifns
-=Azrael=- wrote: Link has been updated...

*EDITED*

(link is gone again)...


If you are able to download it then let me know and I will give you some space to upload this so others can download that as well Or let us know when it will be available again. :(

Posted: Mon Jul 18, 2005 5:21 am
by masterchief07
I need this mod fast because some stupid mod that I tried to install on my forum, Log Actions, wont let anyone edit their posts. So I need a link quickly.

Thanks. :D

Posted: Thu Jul 21, 2005 2:39 pm
by ChALkeR
what about sql? does it undo sql commands?