[Beta] EasyMOD Add-on

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
GMaths
Registered User
Posts: 11
Joined: Tue Aug 05, 2003 10:17 pm

Post by GMaths » Fri Aug 22, 2003 9:11 pm

GPHemsley wrote: Well, I've taken the liberty of updating this MOD.

It should be compatible with 0.0.10 when it is released (seeing as how I worked with the pre-release version when updating this MOD) and it fixes the wrong comment being shown in templates.

@JuniorZ: The reason was because the substr() that you did not take into account the \n at the end of the filename.

Click Here to Download EasyMOD Uninstaller 1.2.1

Is it capable of désinstaller itself?

lemontea
Registered User
Posts: 13
Joined: Sun Aug 17, 2003 6:53 am
Location: HongKong

Post by lemontea » Sat Aug 23, 2003 1:13 am

Now,you may learn that computer is actually quite stupid sometimes...
#
#-----[ FIND ]------------------------------------------
#
<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

Easymod should say can't find on this step,that's because the file try to make the layout clear by having an unneeded space.It has 2 spaces instead of 1 space between
<td width="5%"
and
class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>
therefore,just either delete that space in the board file or add one more spacing in the install file and it should goes without problem.
aznkoz wrote: Installation Failed
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ.

Critical Error

FIND FAILED: In file [templates/subSilver/admin/mod_history.tpl] could not find:

<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

MOD script line #203


Wonder what happen, I have fail to install it. Could it be because I have added log actions mod before this to cause it to not working :( . Oh boy, some work to do .
Yours faithfully,
lemontea

lemontea
Registered User
Posts: 13
Joined: Sun Aug 17, 2003 6:53 am
Location: HongKong

Post by lemontea » Sat Aug 23, 2003 1:14 am

Note:The file that has 2 spaces is the file being edited,NOT the install file.So it's the fault of the old author of phpbb board,huh?
Yours faithfully,
lemontea

Cyberwizzard
Registered User
Posts: 4
Joined: Sat Aug 23, 2003 12:59 am

Post by Cyberwizzard » Sat Aug 23, 2003 1:29 am

Perhaps I missed it but what happens if 2 mods try to modify the exact same code? What will the uninstaller do, will it revert to the state before the 2nd mod was installed or will it abandon any modifications and just revert to the original file?

User avatar
Jaeboy
Registered User
Posts: 446
Joined: Fri Oct 18, 2002 4:42 pm
Location: HkG SAR
Contact:

Post by Jaeboy » Sat Oct 18, 2003 3:44 pm

ahem... me no comprende espanol! Is it spanish? LOL Where to download?

I only see a link for ""There is no 'patch' for stupidity." - SQLSecurity.com"
A personal blog :: My Blog | lalaland

sticki
Registered User
Posts: 4
Joined: Thu Dec 18, 2003 2:12 pm

Post by sticki » Thu Dec 18, 2003 2:16 pm

hey, i got a problem with this addon...everytime try to uninstall a mod, it says:

Code: Select all

Critical Error:
Function Trace: main[1]->modio_prep[2]

FTP ERROR: login failed
can somebody please give me a hint? i checked my passes and login data, it´s all correct...

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Thu Dec 18, 2003 3:05 pm

That sounds like a problem with EasyMOD itself, not this little addon proggie. You should post your question in the EM forum over at http://area51.phpbb.com.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Dagon
Registered User
Posts: 422
Joined: Tue Jun 03, 2003 8:59 pm

Post by Dagon » Fri Dec 19, 2003 2:34 am

This may be a far out idea, but we know a couple of things here...

1) EasyMOD keeps a history of the changes that are made and the files for doing each mod still exist in our mod directory.

2) A backup is made at the time each mod is applied.

Sooo... Why not have the uninstaller restore the backup for for the mod we are uninstalling, THEN have the uninstaller check through all mods that were applied after the mod we are uninstalling was installed and REAPPLY any changes that need to be made for these.

pepitonet
Registered User
Posts: 106
Joined: Thu May 22, 2003 10:43 pm
Contact:

Post by pepitonet » Fri Dec 19, 2003 3:08 am

aznkoz wrote: Installation Failed
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ.

Critical Error

FIND FAILED: In file [templates/subSilver/admin/mod_history.tpl] could not find:

<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

MOD script line #203


Wonder what happen, I have fail to install it. Could it be because I have added log actions mod before this to cause it to not working :( . Oh boy, some work to do .


if you check your lines the one on the install and the one of themod_history.tpl ,you will find there is one space differnce therefore making the whole screw up .fix that and you shouldbe set to go,i had the same problem and that was the cause
<don't know why people do that>

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Fri Dec 19, 2003 3:22 am

Uhh.... you are replying to something from August. And it was off-topic back then too. This is for an addon proggie to EM by JuniorZ. It's not for EM specific questions.

Thanks,
-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
xkevinx
Registered User
Posts: 132
Joined: Tue Nov 05, 2002 8:45 pm
Location: California
Contact:

Post by xkevinx » Tue Dec 30, 2003 8:16 pm

Dagon wrote: This may be a far out idea, but we know a couple of things here...

1) EasyMOD keeps a history of the changes that are made and the files for doing each mod still exist in our mod directory.

2) A backup is made at the time each mod is applied.

Sooo... Why not have the uninstaller restore the backup for for the mod we are uninstalling, THEN have the uninstaller check through all mods that were applied after the mod we are uninstalling was installed and REAPPLY any changes that need to be made for these.


lol wow thats confusing lol let me read that again to see ifi get it
Do you Believe?

FrancoCataldo
Registered User
Posts: 19
Joined: Sun Dec 07, 2003 2:21 pm

Post by FrancoCataldo » Thu Feb 05, 2004 10:06 pm

Does this work with .11a as I need to uninstall flags mod?

iotc247
Registered User
Posts: 414
Joined: Wed Feb 11, 2004 5:22 pm
Location: Florida
Contact:

Post by iotc247 » Mon Feb 16, 2004 9:30 pm

Why not just have the thing reverse the install file? So it does that then replaces the new install file with the old one and uninstalls.

echoleigh
Registered User
Posts: 12
Joined: Mon Jan 20, 2003 12:58 pm

Post by echoleigh » Mon Mar 08, 2004 7:22 pm

lemontea wrote: Now,you may learn that computer is actually quite stupid sometimes...
#
#-----[ FIND ]------------------------------------------
#
<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

Easymod should say can't find on this step,that's because the file try to make the layout clear by having an unneeded space.It has 2 spaces instead of 1 space between
<td width="5%"
and
class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>
therefore,just either delete that space in the board file or add one more spacing in the install file and it should goes without problem.
aznkoz wrote:Installation Failed
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ.

Critical Error

FIND FAILED: In file [templates/subSilver/admin/mod_history.tpl] could not find:

<td width="5%" class="{install.ROW_CLASS}" align="center"><span class="gensmall">details</span></td>

MOD script line #203


Wonder what happen, I have fail to install it. Could it be because I have added log actions mod before this to cause it to not working :( . Oh boy, some work to do .


How do I fix this? I need to uninstall a MOD ..
TIA!

Space Penguin
Registered User
Posts: 152
Joined: Mon Jul 28, 2003 6:57 am
Location: Somewhere Posts: 99999999

Post by Space Penguin » Mon Mar 08, 2004 8:41 pm

Easiest way would be to uninstall it manually, humans can guesstimate things, make comparisons eg. one difference between subSilver and FI subSilver is SS uses:
catbottom

whereas FISS uses:
bottom.

A human would see this differnce and realise the line is really the same, a computer can't. Chances are another mod has changed the code, either that or easy mod is being picky it does that from time to time, and then the only solution is to download the error file, find the line, check the syntax and copy and paste the code directly from the file into the install.txt and while you're there it'd be quicker to do it manually.
Space Penguin, Large as life and twice as ugly.

Locked

Return to “[2.0.x] MODs in Development”