[MOD DB] 2.0.6 to 2.0.4 : Categories hierarchy v 2.0.4

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
[cR@zY]Null
Registered User
Posts: 160
Joined: Sun Aug 10, 2003 1:23 pm

Post by [cR@zY]Null »

Hi,

I want different moderators for the subforums. Is this possible? So the moderators on the main forum are normal users on the subforum and the moderators on the sub forum are normal users on the main forum..

Thx
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Yes of course :) : auth are still on each forums.
[cR@zY]Null
Registered User
Posts: 160
Joined: Sun Aug 10, 2003 1:23 pm

Post by [cR@zY]Null »

True but the moderator colors aren't... I believe

So a moderator on the main forum is green, will also be green on the sub forum.... correct me if I am wrong... (I mean the color of the person self not the legancy color of the board)
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

True : colors of the viewonline list is not contextual, but it isn't the purpose of this mod to handle the content of the view online displays to change the colors used to display the username :).
[cR@zY]Null
Registered User
Posts: 160
Joined: Sun Aug 10, 2003 1:23 pm

Post by [cR@zY]Null »

Okay, but than I will get questions like: he that guys has a moderator color but isn't one on this subforum how come etc etc... or is there a "fix" for this?

ps. quick replying dude :)
ps2 is there a demo?
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

The answer will be the same : the way the view online is displayed isn't linked to the context in phpBB, so it isn't a bug of the mod but a lack of phpBB, and from there, you aren't asking for a fix for this mod but for a new feature for phpBB. As this mod doesn't deal with handling this domain, you have to ask in the dedicated forum which in this case will be the mod request one :).

The demo board is linked on the first post of this topic :).
[cR@zY]Null
Registered User
Posts: 160
Joined: Sun Aug 10, 2003 1:23 pm

Post by [cR@zY]Null »

Okay thx anyway, thought maybe you had some spare time to make this nice extra thingy ;)
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

This is not the first time I consider it ;).
[cR@zY]Null
Registered User
Posts: 160
Joined: Sun Aug 10, 2003 1:23 pm

Post by [cR@zY]Null »

Please do :) I for one would rely want something like this :)
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Upgrade of this mod to v 2.0.3 : it includes now the lang_settings tool and the last version of mods_settings.

The subforums link has been added to the forums attached to index, and the next/prec link on viewtopic shows now the good topic title.
oangia
Registered User
Posts: 153
Joined: Mon May 13, 2002 11:25 pm

Post by oangia »

does not function right ...you know on original phpbb on right side of Board Index you'll see this option like the one i circle ..
Image
when you click on that little tiny icon .. it will lead you to VERY LAST REPLY of that post... but with this subcat mod .. it doesnt function right .. when i click on that icon .. it only lead me to the last Page of that posted instead lead me to very END repli "bottom of that posted"
.. how can i fix this please give me some advice . thanks
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

It drives you to the last unread post when orange, and to the last post in the topic when not visible in the page when white : this works in the exact same way in categories hierarchy. The topic title link at the same place works also in this way.
User avatar
Haywood Jahelpme
Registered User
Posts: 475
Joined: Wed Oct 23, 2002 9:16 am
Location: San Diego
Contact:

Post by Haywood Jahelpme »

OK, I just installed this very large ( 8O ) mod and everything is working great except when I go to change the name of the test forum I made. I get and error:

Code: Select all

Couldn't update forum information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax near '/-- fin mod : categories hierarchy ---------------------------------------------' at line 4

UPDATE phpbb_forums SET forum_name = 'Test sub forum', cat_id = 7, forum_desc = 'testing sub forums only', forum_status = 0, prune_enable = 0, forum_link='', forum_link_internal=0, forum_link_hit_count=0, main_type = 'c' //-- fin mod : categories hierarchy ---------------------------------------------------------------- WHERE forum_id = 31

Line : 857
File : /home/httpd/vhosts/******.com/httpdocs/phpBB2/admin/admin_forums.php


There are a couple other little things I am not sure where to go to fix:

1) when I am viewing a forum it looks like this:

Site Index ->
&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp:: Catagory Name ::
-> ..::Forum Name::..

All on different lines... And the Category Name is centered and the other two are left-justified (aligned on the left). I am not sure where to fix that, but it looks like some extra <tr> have been added... Click here to see what I mean...

2) How do I create sub-categories or attach a forum to another forum. I don't see where that is done... I have a Configuration + section in the ACP, but there is nothing about doing that there...

[edit] nevermind, I see the additional category field now when looking at Forum Management...
* smacks head against wall...[/edit]

3) Any alternate images for those not using sub-silver? The site is using Smart Dark, so maybe just tweak those folder icons? What is the diff between the ones you made and the default folder_big.gif? I just took the folder_big.gif and renamed it cat_folder_big.gif and uploaded over yours...

Otherwise, this is a very kewl mod and I think the site's users will appreciate it once we get it all ironed out. Thanks!
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

All plain commands [AFTER, ADD], [BEFORE, ADD], [REPLACE WITH] are refering to the whole previous [FIND], all in-lines commands [IN-LINE AFTER, ADD], [IN-LINE BEFORE, ADD], [IN-LINE REPLACE WITH] are referring to the previous [IN-LINE FIND] command. Here you have just mixed the both.
User avatar
Haywood Jahelpme
Registered User
Posts: 475
Joined: Wed Oct 23, 2002 9:16 am
Location: San Diego
Contact:

Post by Haywood Jahelpme »

any idea on which file to start in? admin_forums.php? Line 4 on that file is like the middle of the header....
Locked

Return to “[2.0.x] MODs in Development”