[RC] NewsSync 1.5.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
qnx
Registered User
Posts: 69
Joined: Fri Mar 28, 2003 6:03 am

Post by qnx » Thu Sep 25, 2003 11:18 pm

lc_phix wrote: Im currently uploading 7.0 to my website and should have it up and running today. I will try it again with the instructions given and see what i can do, if i have any problems i will post them here with exactly what i did to install it.


Any updates?
lc_phix wrote: Does anyone have any suggestions for a nuke installation?


nuke? I am using newssync with postnuke without a problem.

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Newsync RC1 now available

Post by wineknow » Mon Sep 29, 2003 2:28 am

hopefully the final build before release.
docs still will be updated but the code is getting pretty close.
see first post in topic for detail.
-k

DanielT
Former Team Member
Posts: 3324
Joined: Tue Aug 27, 2002 10:55 am
Contact:

Post by DanielT » Mon Sep 29, 2003 7:48 am


lc_phix
Registered User
Posts: 3
Joined: Fri Sep 12, 2003 8:33 pm
Contact:

Updated

Post by lc_phix » Mon Sep 29, 2003 2:32 pm

Ok, so i updated my site to have a 7.0 version , http://www.lancoalition.com/lc , of php nuke installed and im still getting the same error i was getting when i had 6.5 and 6.9 installed http://www.lancoalition.com. When i goto forums admin and goto newssync and install i receive the following error:

Code: Select all

Warning: main(./../includes/functions_selects.php): failed to open stream: No such file or directory in /home/lancoali/public_html/lc/modules/Forums/admin/admin_newssync_install.php on line 47

Warning: main(): Failed opening './../includes/functions_selects.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lancoali/public_html/lc/modules/Forums/admin/admin_newssync_install.php on line 47
Here is a run down of what i did to stall this:
Changed newssync_config.php files to these settings
$newsSync_rootdir = "www.lancoalition.com/lc/modules/Forums/newssync/";
$phpbb_root_path = "www.lancoalition.com/lc/modules/Forums/";
$newsSync_datadir = "www.lancoalition.com/lc/modules/Forums/newssync/data";
$newsSync_enable_phpnuke_mod = true;


moded admin files to admin, templates to templates folder. Moved inc, language, go-newssync file, newssync.php and newssync_config.php files to a folder named newssync under the forums folder in the phpnuke modules directory.

Does anyone have any clues to as why im receiving this error, am i missing something where im putting a directory or files?

Thanks for any help you can give.
[LC] Phix

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Re: Updated

Post by wineknow » Mon Sep 29, 2003 3:07 pm

lc_phix wrote: Ok, so i updated my site to have a 7.0 version , http://www.lancoalition.com/lc , of php nuke installed and im still getting the same error i was getting when i had 6.5 and 6.9 installed http://www.lancoalition.com. When i goto forums admin and goto newssync and install i receive the following error:

Code: Select all

Warning: main(./../includes/functions_selects.php): failed to open stream: No such file or directory in /home/lancoali/public_html/lc/modules/Forums/admin/admin_newssync_install.php on line 47

Warning: main(): Failed opening './../includes/functions_selects.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lancoali/public_html/lc/modules/Forums/admin/admin_newssync_install.php on line 47
Here is a run down of what i did to stall this:
Changed newssync_config.php files to these settings
$newsSync_rootdir = "www.lancoalition.com/lc/modules/Forums/newssync/";
$phpbb_root_path = "www.lancoalition.com/lc/modules/Forums/";
$newsSync_datadir = "www.lancoalition.com/lc/modules/Forums/newssync/data";
$newsSync_enable_phpnuke_mod = true;


$phpbb_root_path = "/home/lancoali/public_html/lc/modules/Forums/";
$newsSync_rootdir = "/home/lancoali/public_html/lc/modules/Forums/newssync"
$newsSync_datadir = "/home/lancoali/public_html/lc/modules/Forums/newssync/data"

looking for actual path not web path...
this should help...
-k

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

newssync rc2 posted

Post by wineknow » Mon Sep 29, 2003 3:09 pm

-- removed the "within-beta" upgrade scripts
-- seperate tar file for these upgrade scripts
- see first post in this topic
-k

Dslserver
Registered User
Posts: 6
Joined: Tue Sep 30, 2003 1:13 am
Contact:

Post by Dslserver » Tue Sep 30, 2003 1:22 am

Great mod :D working fine win/linux on phpbb but there is no way to install this on phpnuke 6.5/6.9/7.0

Code: Select all

Warning: main(./../includes/functions_selects.php): failed to open stream: No such file or directory in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47

Warning: main(): Failed opening './../includes/functions_selects.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47
Something is wrong with newssync_config.php , I didnt have time to look closer what iswrong but I do not think so if anyone install current version on phpnuke. phpbb version is working fine I setup testing site here http://www.dslserver.biz

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow » Tue Sep 30, 2003 1:40 am

i will do some more testing on phpnuke.
give me a couple of days...
-k
Dslserver wrote: Great mod :D working fine win/linux on phpbb but there is no way to install this on phpnuke 6.5/6.9/7.0

Code: Select all

Warning: main(./../includes/functions_selects.php): failed to open stream: No such file or directory in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47

Warning: main(): Failed opening './../includes/functions_selects.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47
Something is wrong with newssync_config.php , I didnt have time to look closer what iswrong but I do not think so if anyone install current version on phpnuke. phpbb version is working fine I setup testing site here http://www.dslserver.biz

McLR
Registered User
Posts: 95
Joined: Thu Aug 21, 2003 12:51 pm

Post by McLR » Tue Sep 30, 2003 6:44 am

can you give a screenshot ?

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow » Tue Sep 30, 2003 1:18 pm

McLR wrote: can you give a screenshot ?


I will put some screenshots together for the admin side.
For the end result see www.wineknow.com/forums

-k

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow » Tue Sep 30, 2003 2:15 pm

Dslserver wrote: Great mod :D working fine win/linux on phpbb but there is no way to install this on phpnuke 6.5/6.9/7.0

Code: Select all

Warning: main(./../includes/functions_selects.php): failed to open stream: No such file or directory in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47

Warning: main(): Failed opening './../includes/functions_selects.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/domain/public_html/modules/Forums/admin/admin_newssync_install.php on line 47
Something is wrong with newssync_config.php , I didnt have time to look closer what iswrong but I do not think so if anyone install current version on phpnuke. phpbb version is working fine I setup testing site here http://www.dslserver.biz


it is not newssync_config.php but, the install does not work in RC2 for phpNuke. I have a fix but I want to make sure I do I clean install test before releasing RC3. I also want to make sure the fix does not break anything else!

Should have RC3 available in a day or two.
-k

User avatar
anor
Registered User
Posts: 48
Joined: Mon Apr 29, 2002 11:18 pm
Location: The Netherlands

Post by anor » Tue Sep 30, 2003 3:05 pm

It's not the fault of the mod, becuase phpnuke has moved the includes folder, instead of being in html/modules/Forums (which is the standard location of the forum in phpnuke) the includes folder stands in html, there for instead of ./../ be fore the functions it needs to be ../../../ sorry for this post about phpnuke i know your feeling about it (general phpbb folks).I dunno if the mod works with phpnuke but it bet it does :P Great job.

McLR
Registered User
Posts: 95
Joined: Thu Aug 21, 2003 12:51 pm

Post by McLR » Tue Sep 30, 2003 5:53 pm

wineknow wrote:
McLR wrote:can you give a screenshot ?


I will put some screenshots together for the admin side.
For the end result see www.wineknow.com/forums

-k

but what exactly ?
the index.php ? or what ?
"home" ?

P71
Registered User
Posts: 16
Joined: Tue Aug 26, 2003 9:06 am

phpBB in only option available only

Post by P71 » Wed Oct 01, 2003 3:01 pm

A've just installed the RC2 version and found the following bug(?):

Independently the syncronization setting, the Newssync Management console reports "phpBB in only (one-way). Is this a known limitation or am I misconfigured something?
Id like to set "phpBB out only".
:?:

wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Re: phpBB in only option available only

Post by wineknow » Wed Oct 01, 2003 4:08 pm

P71 wrote: A've just installed the RC2 version and found the following bug(?):

Independently the syncronization setting, the Newssync Management console reports "phpBB in only (one-way). Is this a known limitation or am I misconfigured something?
Id like to set "phpBB out only".
:?:


you need to edit your syncronization [NewsSync/Management/Edit] and set it to two way. (it defaults to one-way)

-k

Post Reply

Return to “[2.0.x] MODs in Development”