[MOD DB] 2.0.6-2.0.4 : Topic calendar v 1.0.1

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
rucanunes
Registered User
Posts: 56
Joined: Fri Sep 05, 2003 2:36 pm
Location: Portugal
Contact:

Post by rucanunes » Tue Oct 28, 2003 1:05 pm

I did it! I did it!! :D
Thanks a lot!

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Thu Oct 30, 2003 6:14 am

And comes the time of releasing it :).

Changelog:
  • 2003-10-30 - Version 1.0.0
  • fix a bug on DST date change in scheduler
  • fix the -1 issue in preview post
  • cut off softer the message in the overview event window
  • add the lang settings tool
  • upgrade the mods settings tool

g-funk
Registered User
Posts: 34
Joined: Tue Sep 09, 2003 5:58 pm

Post by g-funk » Thu Oct 30, 2003 4:13 pm

Hi

The file templates/subSilver/calendar_box.tpl that is included in the zip does not have the changes that are done in the upgrade.txt file.

Cya
G-Funk

g-funk
Registered User
Posts: 34
Joined: Tue Sep 09, 2003 5:58 pm

Post by g-funk » Thu Oct 30, 2003 4:34 pm

Hi Again

The overflow to the Right and to the bottom at the same time is not working.
The days still do not evenly spread over the whole size for Opera like described in a previus post (sqashing problem) .
Here are the links to the way i solved these problems.
Sqashing problem
Overflow problem

Byte
G-Funk

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Thu Oct 30, 2003 11:46 pm

The definition of the width of the child has been removed. As the inside window height is not available with IE with this code, I prefered let the code working with Mozilla and Netscape, which haven't this problem. Adding the code shared causes an hide of a part of the window with both which doesn't exist without (as the size is well return by those navigators). I prefer also let this for a next version, more advanced regarding this javascript code :).

Thanks for the report about the calendar_box.tpl

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Tue Nov 04, 2003 5:30 pm

A typo in includes/functions_topics_list.php prevents to see the topics as marked when you have used the link "Mark all topics read" at the top of a forum.

Here is the fix :

Code: Select all

#
#-----[ OPEN ]------------------------------------------------
#
includes/functions_topics_list.php
#
#-----[ FIND ]------------------------------------------------
#
 *	version			: 1.1.8 - 28/09/2003
#
#-----[ REPLACE WITH ]---------------------------------------- 
#
 *	version			: 1.1.9 - 04/11/2003
#
#-----[ FIND ]------------------------------------------------
#
		$force_type_display	= false;
#
#-----[ AFTER, ADD ]------------------------------------------
#
		$forum_id			= $topic_rowset[$i]['forum_id'];
#
#-----[ SAVE/CLOSE ALL FILES ]--------------------------------
#
# EoM
Here are the mod involved : if you have many of them, you have to apply the fix only one time :
- Announces Suite,
- Last topic from,
- Simply merge threads,
- Profile Control Panel,
- Split topic type,
- Topic calendar

florky
Registered User
Posts: 29
Joined: Mon Sep 15, 2003 2:45 pm
Location: Belgium [FR]

Post by florky » Wed Nov 05, 2003 6:42 pm

Hi,
After some problem i had with mycalendar+ and minical, I totally desinstalled both, and installed the latest version of topicalendar, all is working except for minical.
Minical on the portal didn't reflect events, minical didn't use anymore the arrows used before for mycalendar, and minical had a problem displaying the date.
I have January 1970, when I click the right arrow, I have december 2003, if i click back, january 1970 and if i click once more to the left I have october 2003, so seems to have a problem displaying the current months/date.
Please Help
PS : I use Phpbb206, minical 1.1.11, profile cp2.0, posticons, topicalendar + patch of the previous post

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Wed Nov 05, 2003 7:30 pm

I think you have to activate in the mini-cal constants the one done to mention the calendar you are using. I haven't yet the code on my eyes, but it sounds something like that.

User avatar
Dio2
Registered User
Posts: 94
Joined: Sun Jun 15, 2003 5:02 pm

Post by Dio2 » Thu Nov 06, 2003 12:34 am

florky, try removing the search items in the mini cal instructions and from the MOD-topic_calendar-extension_for_minical.txt. for mini cal in Ptirhiik version I think there is issues with the way mini cal searches for events that causes the problem with this calendar - for the arrows you can either add them back or just strip the img code out of the mini_cal_body.tpl.

This is how I got it working some what together :D

maddcow
Registered User
Posts: 8
Joined: Sat Oct 25, 2003 10:32 pm

Post by maddcow » Thu Nov 06, 2003 4:14 am

I installed this calendar mod and all was working well.... until I noticed this after making a reply to a post:

above header:
Warning: odbc_exec(): SQL error: [Microsoft][ODBC SQL Server Driver][SQL Server]Column 't.topic_first_post_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause., SQL state 37000 in SQLExecDirect in C:\xxx\PhPForum\phpBB2\db\mssql-odbc.php on line 117

Warning: Cannot modify header information - headers already sent by (output started at C:\xxx\PhPForum\phpBB2\db\mssql-odbc.php:117) in C:\xxx\PhPForum\phpBB2\includes\page_header.php on line 481

Warning: Cannot modify header information - headers already sent by (output started at C:\xxx\PhPForum\phpBB2\db\mssql-odbc.php:117) in C:\xxx\PhPForum\phpBB2\includes\page_header.php on line 483

Warning: Cannot modify header information - headers already sent by (output started at C:\xxx\PhPForum\phpBB2\db\mssql-odbc.php:117) in C:\xxx\PhPForum\phpBB2\includes\page_header.php on line 484




and this in the main window:
Could not obtain topic information

DEBUG MODE

SQL Error : 37000 [Microsoft][ODBC SQL Server Driver][SQL Server]Column 't.topic_first_post_id' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, t.topic_first_post_id, t.topic_calendar_time, t.topic_calendar_duration, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments, COUNT(p2.post_id) AS prev_posts FROM phpbb_topics t, phpbb_forums f, phpbb_posts p, phpbb_posts p2 WHERE p.post_id = 50 AND t.topic_id = p.topic_id AND p2.topic_id = p.topic_id AND p2.post_id <= 50 AND f.forum_id = t.forum_id GROUP BY p.post_id, t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments ORDER BY p.post_id ASC

Line : 160
File : C:\xxx\PhPForum\phpBB2\viewtopic.php




Note: the "xxx" is just me covering up my directory on the C: drive that no one needs to see.


Anyone have an idea of why this is happening?

graficalicus
Registered User
Posts: 1
Joined: Wed Nov 05, 2003 6:32 pm
Location: nc, us

excellent MOD!

Post by graficalicus » Thu Nov 06, 2003 4:23 am

no problems with installing, SQL adjustments, etc - all was right there in the package - thanks :wink:

A question, though - I'd like the weeks to run from Sunday ~ Saturday (instead of Monday ~ Sunday) - is this easy to change?

Thumbs up for a great MOD, nonetheless, and thx in advance for any help with changing the weeks.... :lol:

EDIT: DUH!! ...and there it was, right in the configuration screen...

:oops: :oops: :oops: :oops:

(I like this one even better now!)
<mike>
--------------------------------
Image
--------------------------------

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Thu Nov 06, 2003 5:24 am

> madcow : you have to add the fields added in the select list also in the group by list : this should solve the issue you encounter.

maddcow
Registered User
Posts: 8
Joined: Sat Oct 25, 2003 10:32 pm

Post by maddcow » Thu Nov 06, 2003 5:25 pm

8O


ermmmmm, can you explain that as if I was a complete idiot?

because..... I am.

maddcow
Registered User
Posts: 8
Joined: Sat Oct 25, 2003 10:32 pm

Post by maddcow » Thu Nov 06, 2003 6:02 pm

nevermind.... the idiot has his moments.

t.topic_first_post_id, t.topic_calendar_time, t.topic_calendar_duration,

were in the select string but not the group by. I put these three in the exact same place of the Group BY string and all is copacetic now.


Thanks dude.

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Thu Nov 06, 2003 7:02 pm

;)

Locked

Return to “[2.0.x] MODs in Development”