[MOD DB][2.0.6-2.0.4] Profile Control Panel v 2.0.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
thehellwitu
Registered User
Posts: 51
Joined: Sat Oct 25, 2003 1:56 am
Location: Florida
Contact:

Post by thehellwitu »

Can i use the changed files instead of changing all the files myself or not because i just isntalled (Uploaded files and the changed files and did the db stuff) and im getting this error

Code: Select all

Warning: main(././includes/functions_mods_settings.php): failed to open stream: No such file or directory in /home/upka/public_html/forums/includes/mods_settings/mod_profile_control_panel.php on line 28

Warning: main(): Failed opening '././includes/functions_mods_settings.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/upka/public_html/forums/includes/mods_settings/mod_profile_control_panel.php on line 28

Fatal error: Call to undefined function: init_board_config() in /home/upka/public_html/forums/includes/mods_settings/mod_profile_control_panel.php on line 105

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix »

Have you uploaded the file includes/functions_mods_settings.php ?
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

thehellwitu
Registered User
Posts: 51
Joined: Sat Oct 25, 2003 1:56 am
Location: Florida
Contact:

Post by thehellwitu »

I uploaded everything in the mod pack and in the changed files

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Be sure to follow the mod install description : the modified files are not the full mod.

User avatar
Hater
Registered User
Posts: 570
Joined: Tue May 06, 2003 8:56 pm
Location: Wisconsin
Contact:

Post by Hater »

Question..

In viewtopic.tpl is the no_buddy_ignore switch necessary, or is there a way to incorporate that with the attachment mod?

<!-- BEGIN switch_no_buddy_ignore -->
code in here removed
<!-- END switch_no_buddy_ignore -->

The reason I ask is that switch for some reason causes incompatibility with the attachment mod.

Now I know from reading on your demo forum that you are against the attachment MOD, and for a good, understandable reason.

But for those of us that feel the ability to attach files outweighs the chance someone will explore a loophole of that feature, can you help me figure out an alternative?

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

The switch no_buddy_ignore is required. You have so to add it under the appropriate condition into your attachement functions.

Foulplay
Registered User
Posts: 118
Joined: Tue Oct 14, 2003 8:43 am
Location: S E UK
Contact:

Fatal Error

Post by Foulplay »

I've run the SQL queries and changed all the files, now when I go into the forum and click on a thread I get the following:

Fatal error: Call to undefined function: mods_settings_get_lang() in /homepages/16/****/****/****/PHP_BB/profilcp/def/def_userfuncs.php on line 246

Any ideas anyone?

Thanks,

FP

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

You didn't upload at their good place some files probably. Please follow the mod instructions.

Foulplay
Registered User
Posts: 118
Joined: Tue Oct 14, 2003 8:43 am
Location: S E UK
Contact:

?

Post by Foulplay »

Ptirhiik - RPGnet-fr wrote: You didn't upload at their good place some files probably. Please follow the mod instructions.


Not sure what you mean.
I think I followed the mod instructions precisely.

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

I mean if you have tried to upload directly entire mod dirs to your ftp without taking care where each files has to be copied, you have upload some of them into a wrong directory.

Foulplay
Registered User
Posts: 118
Joined: Tue Oct 14, 2003 8:43 am
Location: S E UK
Contact:

Same error

Post by Foulplay »

Ptirhiik - RPGnet-fr wrote: I mean if you have tried to upload directly entire mod dirs to your ftp without taking care where each files has to be copied, you have upload some of them into a wrong directory.


I've been through it all over again. I'm sure I'm putting all the files in the right place, but I'm still getting the same error message.

Anything else I should try?

Thanks,

FP

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Verify so all your modifications, comparing with the modified files pack. Start with functions.php

Foulplay
Registered User
Posts: 118
Joined: Tue Oct 14, 2003 8:43 am
Location: S E UK
Contact:

sorry, again I'm not sure what you mean.

Post by Foulplay »

Please explain.

Thanks.

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

8O What do you not understand ?

Foulplay
Registered User
Posts: 118
Joined: Tue Oct 14, 2003 8:43 am
Location: S E UK
Contact:

-

Post by Foulplay »

Are you saying go back through includes/functions.php and check the modifications I have made are correct according to the instructions?

Locked

Return to “[2.0.x] MODs in Development”