[BETA] Medal System MOD [ Latest: 0.4.6 ]

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

MrDSL wrote:
songdove wrote:
MrDSL wrote:I have actually gotten the profile section working with PCP but the topics section doesn't work right (this can be fixed by just hacking around PCP). You can see a demo of it here

username/pass

tester/tester


I have the view topics thing working just fine, it points to the pcp too all on its own.

Gremlinn thanks so much. Now for another question, and this may sound really dumb. . . MrDSL you said to add the two lang files whereever I want them. Um. . . what pages can they be added to?


Did you hack around PCP to do this?


What 2 lang files? Was this from another topic?


No, for some reason, the viewtopic tpl link for the medals just went to the pcp all on its own. However the pcp isn't showing the medals yet. The lang entries I was talking about are in the thread gremmlin shared above. They're not files, they're calls I think. I believe they are to put put someplace in the pcp where-ever I want them to show up. I just wanted to know where to put them.

$lang['profilcp_public_medals_shortcut'] = 'User Medals';
$lang['profilcp_medals_pagetitle'] = 'Medals';

where do I put these? I uploaded the two pcp medal files in your zip from that thread, now I have to add these lang entries. Where do I put them?

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

Flint101: I would have to say that you have a typo or more appropriatly, an omission. I would guess that you left out a closing } or " or ' You may even have added a $ somewhere. I bet you have 1310 lines in the file.

laisvai: Even though there are still somethings the author wants to do and maybe a couple things to finish, the mod works very well the way it is (save the couple of fixes mentioned in this topic). But, yes. Author, please don't forget about this awesome mod!

MrDSL
Registered User
Posts: 283
Joined: Thu Jul 15, 2004 1:52 am
Contact:

Post by MrDSL »

You can put them 2 lang key entries in

language/lang_english/lang_extend_pcp_addons.php

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

Gremlinn wrote: But, yes. Author, please don't forget about this awesome mod!

It's really good seeing people gain lots of interest in this MOD and had made adaptation to this MOD in various forms. Although I'm officially having summer break, but still has loads of things to do in uni. I'll try my best to release an update in this holiday before school starts again in Oct.

Anyway regarding PCP and Medal MOD, if anyone is interested in making an adaptation based on this MOD, you are welcome to do so and release it as long as my name remained as the primary author. e.g.

Code: Select all

## MOD Author: AbelaJohnB < abela@phpbb.com > (John B. Abela) http://www.JohnAbela.Com/
## MOD Author, Secondary: typicalgeek  < me@typicalgeek.com > (N/A)  http://www.typicalgeek.com
## MOD Author, Secondary: netclectic < adrian@notclectic.com > (Adrian Cockburn) http://www.netclectic.com
Thanks for all the support.

~Mac

MrDSL
Registered User
Posts: 283
Joined: Thu Jul 15, 2004 1:52 am
Contact:

Post by MrDSL »

ycl6 wrote:
Gremlinn wrote:But, yes. Author, please don't forget about this awesome mod!

It's really good seeing people gain lots of interest in this MOD and had made adaptation to this MOD in various forms. Although I'm officially having summer break, but still has loads of things to do in uni. I'll try my best to release an update in this holiday before school starts again in Oct.

Anyway regarding PCP and Medal MOD, if anyone is interested in making an adaptation based on this MOD, you are welcome to do so and release it as long as my name remained as the primary author. e.g.

Code: Select all

## MOD Author: AbelaJohnB < abela@phpbb.com > (John B. Abela) http://www.JohnAbela.Com/
## MOD Author, Secondary: typicalgeek  < me@typicalgeek.com > (N/A)  http://www.typicalgeek.com
## MOD Author, Secondary: netclectic < adrian@notclectic.com > (Adrian *beep*) http://www.netclectic.com
Thanks for all the support.

~Mac



Would you be able to help me with something regarding the code for PCP real quick? I have the medal images working fine but it displays all images. For example lets say I have a topic with 4 replys and all of them 4 people have 1 image each. The first post will be 1 image then the next post below will be my image and then his. Then the 3rd post will be the first 2 images from the people above and then his and so on.

Its like it doesn't know that each image belongs to a certain username..I'm not sure what I am doing wrong..

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

MrDSL wrote: Would you be able to help me with something regarding the code for PCP real quick? I have the medal images working fine but it displays all images. For example lets say I have a topic with 4 replys and all of them 4 people have 1 image each. The first post will be 1 image then the next post below will be my image and then his. Then the 3rd post will be the first 2 images from the people above and then his and so on.

Its like it doesn't know that each image belongs to a certain username..I'm not sure what I am doing wrong..

I've never used PCP before, so I'm not sure how it handles the viewtopic codes, might be some bugs somewhere in a loop so that images aren't displayed for each poster correctly

~Mac

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

MrDSL wrote: Would you be able to help me with something regarding the code for PCP real quick? I have the medal images working fine but it displays all images. For example lets say I have a topic with 4 replys and all of them 4 people have 1 image each. The first post will be 1 image then the next post below will be my image and then his. Then the 3rd post will be the first 2 images from the people above and then his and so on.

Its like it doesn't know that each image belongs to a certain username..I'm not sure what I am doing wrong..


I saw that and I corrected that on my end. Mind you, it was a loooong time ago. Let me see if I can find out what I did.

Ice Dead
Registered User
Posts: 5
Joined: Sun Jan 16, 2005 10:48 am

Post by Ice Dead »

laisvai wrote:
BrooklynFUNK wrote:After I put 'admin_medal.php' and 'admin_medal_cfg.php' in Admin folder, I get blank left frame in admin CP.

It's the same for IE and for Firefox: left frame of Admin CP is blank.

Sorry people, but I really want this mod on my forum! Again, any ideas???


Same problem, with this error:

Fatal error: Cannot redeclare get_info() in /home/laisvai/public_html/phpBB2/admin/admin_forums.php on line 71

it comes when i copy admin_medal.php file :?




Open ==> admin/admin_medal.php

Find

Code: Select all

function get_info($mode, $id)
Replaced it with this code

Code: Select all

"function get_info($mode, $id)";
Find

Code: Select all

function get_list($mode, $id, $select)
Replaced it with this code

Code: Select all

"function get_list($mode, $id, $select)";
Find

Code: Select all

function renumber_order($mode, $cat = 0)
Replaced it with this code

Code: Select all

"function renumber_order($mode, $cat = 0)";
Best Regards
Ice Dead

but I have an oter problem

Code: Select all

Wrong mode for generating select list

DEBUG MODE

Line : 87
File : /home/bacchus/users/icedead/icedead.iphpbb.de/www/admin/admin_medal.php

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

Some other MOD is using the same function name.

To fix the problem, simply replace the function name and all occurance of get_info related to Medal MOD to a new name of your own choice.

~Mac

songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

MrDSL wrote: You can put them 2 lang key entries in

language/lang_english/lang_extend_pcp_addons.php


Thanks, but I think something is still missing. I have a thin cell line where "medals" should be in the addons tabs in the pcp.

The files are uploaded, the lang calls are in the file above now. But something is missing for that add on page to display.

MrDSL
Registered User
Posts: 283
Joined: Thu Jul 15, 2004 1:52 am
Contact:

Post by MrDSL »

Gremlinn wrote:
MrDSL wrote: Would you be able to help me with something regarding the code for PCP real quick? I have the medal images working fine but it displays all images. For example lets say I have a topic with 4 replys and all of them 4 people have 1 image each. The first post will be 1 image then the next post below will be my image and then his. Then the 3rd post will be the first 2 images from the people above and then his and so on.

Its like it doesn't know that each image belongs to a certain username..I'm not sure what I am doing wrong..


I saw that and I corrected that on my end. Mind you, it was a loooong time ago. Let me see if I can find out what I did.



The medals displaying on your left panel in the viewtopic section are they being displayed because you just bypassed PCP and put the {postrow.medals.etc} next to {postrow.AUTHOR_PANEL} or did you actually create a function to display it inside PCP? If its the latter all I would need to see is your pcp_output_medals function or whatever you named it in def_userfuncs_custom.php and I could figure out the rest.

The function has to be in def_userfuncs_something.php..Much appreciated..

User avatar
laisvai
Registered User
Posts: 69
Joined: Sun Mar 20, 2005 7:33 pm
Location: lithuania
Contact:

Post by laisvai »

Ice Dead wrote: DEBUG MODE

Line : 87
File : /home/bacchus/users/icedead/icedead.iphpbb.de/www/admin/admin_medal.php[/code]


Thank's for advice, but now i'm getting this error too :?

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

MrDSL wrote:
Gremlinn wrote:
MrDSL wrote: Would you be able to help me with something regarding the code for PCP real quick? I have the medal images working fine but it displays all images. For example lets say I have a topic with 4 replys and all of them 4 people have 1 image each. The first post will be 1 image then the next post below will be my image and then his. Then the 3rd post will be the first 2 images from the people above and then his and so on.

Its like it doesn't know that each image belongs to a certain username..I'm not sure what I am doing wrong..


I saw that and I corrected that on my end. Mind you, it was a loooong time ago. Let me see if I can find out what I did.



The medals displaying on your left panel in the viewtopic section are they being displayed because you just bypassed PCP and put the {postrow.medals.etc} next to {postrow.AUTHOR_PANEL} or did you actually create a function to display it inside PCP? If its the latter all I would need to see is your pcp_output_medals function or whatever you named it in def_userfuncs_custom.php and I could figure out the rest.

The function has to be in def_userfuncs_something.php..Much appreciated..


I would have to say no to your last statement. And, I don't remember what I did to get the posts corrected.

Also, I am now a little curious about the def_userfunction thing. I am working on getting my forum upgraded to the latest CH (and all mods) once the new PCP is out, I will look into using that function if it is still there with the new version. If I figure out how I corrected the strange medals in viewtopic thing, I will let you know.

Sgt_Sack
Registered User
Posts: 3
Joined: Fri Jul 15, 2005 7:38 am

Medal Control Panel

Post by Sgt_Sack »

Hi Guys,

First of all, I would like to say, I love all the work you do. I have found many tools and fixes for bugs here. You are an amazing group of people. Keep up the good work.

Ok, now to my question...
I have a PHPNUKE site and I am trying to get the Medals mod to work correctly. I have found and fixed many issues related to Nuke and I understand this mod was designed for PHPBB so I dont know if you can help but I have to ask.

I have everything working using version 2.2.2. Many things that need attention when using nuke. Im not sure of all the fixes but I feel I am fairly literate in PHP so I was able to fix most of them. My issue is I can not access the Medal Control Panel from medals.php. I have a list (one right now, since it isnt working proper) of medals in the Forums. The link just takes me to the main site page. I made myself the moderator of a medal and I am trying to add people to the Users List who deserve that medal. I have the Medal Name, Description, Medal List and Medal Moderator (me) displayed the way it should. I have loaded every version and unloaded, testing out different versions of this mod. 2.2.2 uses the security features I like to to use.

How can I fix the Medal Control Panel link to gain access to the control panel? I would like to add users but can't. I get this error at the top of the page...

Code: Select all

	
Warning: Missing argument 3 for session_pagestart() in /home/XXXXX/public_html/includes/sessions.php on line 233
Info:
PHPNuke 7.6
PHPBB Version 2.0.10

Website used:
http://groundzeroservers.com

(PM me if you want total access to site)

Thanks and I really hope I can get this to work, My clan is looking forward to earning medals.

Sgt Sack

songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

MrDSL wrote: You can put them 2 lang key entries in

language/lang_english/lang_extend_pcp_addons.php


Sorry for taking so long to reply, I added those keys to the addon lang file, but I only get a horizontal line where the medals tab title should be. Is there another place where the tab title should be put?

Post Reply

Return to “[2.0.x] MODs in Development”