[BETA] Medal System MOD [ Latest: 0.4.6 ]

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

shirleycaat: If you only have two columns, then remove the third value from the SQL statement.

Code: Select all

INSERT INTO `phpbb_config` 
VALUES ( 

'allow_medal_display', '0'
) 

ycl6: Check back a few pages, I posted about the categories problem there (if you haven't all ready taken care of it).

Noddegamra
Registered User
Posts: 28
Joined: Fri Mar 04, 2005 4:50 pm
Location: UK
Contact:

Post by Noddegamra »

is 2.1.0 still the recommended version to use? Or is 2.2.2 ok now?

mundopoesia
Registered User
Posts: 20
Joined: Sat Dec 25, 2004 5:24 pm
Contact:

problem with {S_UNMEDAL_USERLIST_SELECT}

Post by mundopoesia »

I'm having a problem with {S_UNMEDAL_USERLIST_SELECT} on medalcp_body.tpl

It doesn't show up...

:cry:

archangel1981
Registered User
Posts: 5
Joined: Tue Nov 23, 2004 8:23 pm

Post by archangel1981 »

Wrong mode for generating select list

DEBUG MODE

Line : 87
File : admin_medal.php

I have done this

INSERT INTO `phpbb_config`
VALUES (

'allow_medal_display', '0'
)

But still get the error when i go to CP and click medal admin managment

I have read through the 30 pages of this topic and nothing has helped.... If someone can explain the remedy for this problem i would most appreciate it

thx

docita
Registered User
Posts: 1
Joined: Mon Oct 18, 2004 12:03 am

Post by docita »

i need help...

Image


Image


Image

RookMate
Registered User
Posts: 9
Joined: Sat Jul 23, 2005 7:11 pm

Post by RookMate »

ugh! is this mod worth it??

i have it installed successfully,...almost.

everything works fine (after working out many bugs) except for one i cant quite fix.

in viewprofile,..it shows # of medals,...and displays medals images,..all good. there is a button that is 1) spelled wrong (deatils) and 2) doesnt work. i have scanned all relative files as much as i can and found nothing that would correct this issue. when i click this mispelled button,...it does nothing,..no error,just nothing.

in /includes/user_cp_viewprofile there are 2 places where 'Medal details' code is entered but,..it seems to be accurate.

can someone please tell me how to correct this,..or at least correct the spelling of the dumb button lol. thank you

RookMate
Registered User
Posts: 9
Joined: Sat Jul 23, 2005 7:11 pm

Post by RookMate »

:oops: :oops: ok so im stupid,..i discovered i never copied the toggle.js file to templates dir.

its always the little things.

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

RookMate wrote: ugh! is this mod worth it??

can someone please tell me how to correct this,..or at least correct the spelling of the dumb button lol. thank you
RookMate wrote: :oops: :oops: ok so im stupid,..i discovered i never copied the toggle.js file to templates dir.

its always the little things.

Well, then be a little more polite when you report the problems, people do make stupid mistakes :roll:

~Mac

songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

Noddegamra wrote: is 2.1.0 still the recommended version to use? Or is 2.2.2 ok now?


Does 2.2.2 integrate better with PCP now? I still only have a horizontal line in the Addons tab where the medals are supposed to show up. Otherwise, I'm still using the earlier version without much hassle.

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

songdove wrote:
Noddegamra wrote:is 2.1.0 still the recommended version to use? Or is 2.2.2 ok now?


Does 2.2.2 integrate better with PCP now? I still only have a horizontal line in the Addons tab where the medals are supposed to show up. Otherwise, I'm still using the earlier version without much hassle.

I probably won't get this MOD compatible with P.C.P because I never used P.C.P before.

~Mac

songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

Would there be another way to show medal award reasons than the basic phpbb2 profile? I'm using PCP for a number of reasons and as a result can't revert back to the basic profile system, but I do like the medal system. Could the reason become a javascript popup maybe, so when people mouse over a medal on someone's name either in the medal screen or in viewtopic, that the popup shows the reason why the person earned it?

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

songdove wrote: Could the reason become a javascript popup maybe, so when people mouse over a medal on someone's name either in the medal screen or in viewtopic, that the popup shows the reason why the person earned it?

That is probably do-able.

~Mac

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

New testing version (2.2.3) is now available.

Note: I haven't test the upgrade script with EM yet, but it should be compatible.

~Mac

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

songdove wrote: Would there be another way to show medal award reasons than the basic phpbb2 profile? I'm using PCP for a number of reasons and as a result can't revert back to the basic profile system, but I do like the medal system. Could the reason become a javascript popup maybe, so when people mouse over a medal on someone's name either in the medal screen or in viewtopic, that the popup shows the reason why the person earned it?


Check out previous posts. There are a few that talk about this mod with PCP. It will work just fine with a little work.

songdove
Registered User
Posts: 199
Joined: Wed Jun 22, 2005 4:07 pm

Post by songdove »

I've already found and uploaded the two files that are mentioned earlier in this thread, and put lang keys where I thought they should go, but I'm missing something still. Due to the horizontal line, I obviously did part of it right, but just have to finish it now. I'm not sure what I did wrong in the mod not showing in PCP, because I thought I'd followed earlier directions in this thread.

Post Reply

Return to “[2.0.x] MODs in Development”