[BETA] Medal System MOD [ Latest: 0.4.6 ]

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
[ITAK]Colossus
Registered User
Posts: 3
Joined: Fri Apr 06, 2007 9:45 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by [ITAK]Colossus »

Hi,
we have installed the mod on our forum but we see the medals information between the members nickname and the avatar (higher than the avatar).
We whould like to see it under the avatar.
As it is in the example in the /extra directory in the download file.
Could u give us support?
Should we change the value assigned to 'medal_display_order'?
Thanks a lot!

Wingzfan
Registered User
Posts: 441
Joined: Wed Jan 25, 2006 4:55 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by Wingzfan »

I cant tell you excatly what to do if you want to post your "viewtopic.tpl" or if you know html just move th etable to where you want it.

[ITAK]Colossus
Registered User
Posts: 3
Joined: Fri Apr 06, 2007 9:45 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by [ITAK]Colossus »

This is it.
Too long to post in the message.....
I'll put it zipped and in TXT format.
Hope i'm not doing something wrong posting il all here.

Thx for any help given.
Last edited by [ITAK]Colossus on Sat Apr 07, 2007 12:50 pm, edited 1 time in total.

Wingzfan
Registered User
Posts: 441
Joined: Wed Jan 25, 2006 4:55 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by Wingzfan »

Sorry been painting and I just saw this. I need the tpl file in your styles folder. The zip you loaded for me is the php file.

niru
Registered User
Posts: 18
Joined: Sun Mar 25, 2007 4:34 am

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by niru »

niru wrote:
Wingzfan wrote:
shu8man wrote: I got mine working, but it only displays one medal in the forum topic. Any suggestions?

Same issue for me too!

I had installed Medal System! Its working fine!
But Only one medal is showing in the Viretopic page even if the user is having 3 medals!
I had changed the number of rows to 2 and also to 3!
But still no effect!!
Check this post!

He is having 3 Medals! But only one is showing in view topic page! :(
(In my Medal Configuration page, I changed number of columns to 2)

Please help me to fix the issue!

What does your "rows" selection say? Does it say 1x1 or 1x something else. The 2nd number is your columns so you need to change that number. If you want 1 row with 10 medals you would put 1x10

Example


I'm using 1x2 for my Medal Configuration!
But still showing only one medal even if te member have 3 medals! :(


Anybody please help me to fix the issue!!

[ITAK]Colossus
Registered User
Posts: 3
Joined: Fri Apr 06, 2007 9:45 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by [ITAK]Colossus »

THX we have managed on our own working on the tpl file !
Good work and hf!

ECfuzzy
Registered User
Posts: 1
Joined: Sun Apr 22, 2007 8:39 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by ECfuzzy »

Ok I have been triing to install Mod Version: 0.4.6 of this on my gaming communities site for abit now - hell ran out of ideas :(.
SQL Error : 1146 Table 'ezRain.medal_cat' doesn't exist
SELECT cat_id, cat_title, cat_order FROM medal_cat ORDER BY cat_order

Line : 804
File : admin_medal.php


#1. We use a theme(camo) and not templet(subsilver), do I dis-regard changing templet and just change THEME files?
Files To Edit: 12
## templates/subSilver/viewtopic_body.tpl -----> themes/AOG_camo/forums/viewtopic_body.tpl
## templates/subSilver/profile_view_body.tpl --> themes/AOG_camo/forums/profile_view_body.tpl
## templates/subSilver/overall_header.tpl ------> themes/AOG_camo/forums/overall_header.tpl
## templates/subSilver/subSilver.cfg ------------> themes/AOG_camo/forums/forums.cfg
##
## Included Files: 17 (+ 24 images)
## root/templates/subSilver/medals_body.tpl ------------------------> root/themes/AOG_camo/...
## root/templates/subSilver/medalcp_body.tpl -----------------------> root/themes/AOG_camo/...
## root/templates/subSilver/medalcp_edit_body.tpl -----------------> root/themes/AOG_camo/...
## root/templates/subSilver/images/icon_mini_medal.gif ----------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medal_config_body.tpl ---------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medal_delete_body.tpl ---------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medals_edit_body.tpl ----------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medals_editcat_body.tpl ------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medals_list_body.tpl -----------> root/themes/AOG_camo/...
## root/templates/subSilver/admin/medals_moderator_body.tpl --> root/themes/AOG_camo/...
## root/medals/*.gif
##


#2. Also our site uses nuke, is this compatable?

Un-altered SQL
#
# Table structure for table `nuke_bbconfig`
#

DROP TABLE IF EXISTS `nuke_bbconfig`;
CREATE TABLE IF NOT EXISTS `nuke_bbconfig` (
`config_name` varchar(255) NOT NULL default '',
`config_value` varchar(255) NOT NULL default '',
PRIMARY KEY (`config_name`)
) ;

#
# Dumping data for table `nuke_bbconfig`
#

INSERT INTO `nuke_bbconfig` VALUES ('config_id', '1');
INSERT INTO `nuke_bbconfig` VALUES ('board_disable', '0');
INSERT INTO `nuke_bbconfig` VALUES ('sitename', 'My Site');
INSERT INTO `nuke_bbconfig` VALUES ('site_desc', '');


I would alter medal mods prefix-SQL to?
Altered SQL
DROP TABLE IF EXISTS `nuke_medal`;
CREATE TABLE IF NOT EXISTS `nuke_medal` (
`medal_id` mediumint(8) UNSIGNED NOT NULL auto_increment,
`cat_id` mediumint(8) UNSIGNED NOT NULL default '1',
`medal_name` varchar(40) NOT NULL,
`medal_description` varchar(255) NOT NULL,
`medal_image` varchar(40) NULL,
PRIMARY KEY (`medal_id`)
);

DROP TABLE IF EXISTS `nuke_medal_user`;
CREATE TABLE IF NOT EXISTS `nuke_medal_user` (
`issue_id` mediumint(8) UNSIGNED NOT NULL auto_increment,
`medal_id` mediumint(8) UNSIGNED NOT NULL,
`user_id` mediumint(8) UNSIGNED NOT NULL,
`issue_reason` varchar(255) NOT NULL,
`issue_time` int(11) NOT NULL,
PRIMARY KEY (`issue_id`)
);

DROP TABLE IF EXISTS `nuke_medal_mod`;
CREATE TABLE IF NOT EXISTS `nuke_medal_mod` (
`mod_id` mediumint(8) UNSIGNED NOT NULL auto_increment,
`medal_id` mediumint(8) UNSIGNED NOT NULL,
`user_id` mediumint(8) UNSIGNED NOT NULL,
PRIMARY KEY (`mod_id`)
);

DROP TABLE IF EXISTS `nuke_medal_cat`;
CREATE TABLE IF NOT EXISTS `nuke_medal_cat` (
`cat_id` mediumint(8) UNSIGNED NOT NULL auto_increment,
`cat_title` varchar(100) NOT NULL,
`cat_order` mediumint(8) UNSIGNED NOT NULL default '0',
PRIMARY KEY (`cat_id`),
KEY `cat_order` (`cat_order`)
);

INSERT INTO `nuke_bbconfig` VALUES ('allow_medal_dispaly', '1');
INSERT INTO `nuke_bbconfig` VALUES ('medal_display_row', '1');
INSERT INTO `nuke_bbconfig` VALUES ('medal_display_col', '1');
INSERT INTO `nuke_bbconfig` VALUES ('medal_display_width', '25');
INSERT INTO `nuke_bbconfig` VALUES ('medal_display_height', '60');
INSERT INTO `nuke_bbconfig` VALUES ('medal_display_order', '');


I have tried 7 different versions - I need a fresh pair of eyes to look at this. Thanks for any help you can provide - i would love to get this mod working on site, as I have seen it on other sites "IT ROCKS".

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by ycl6 »

I remember there's at least one Nuke version of this MOD

This MOD doesn't work with Nuke (by default), and I can't give support for Nuke users since I don't use it. The best would be to seek help from Nuke support sites.

~Mac

niru
Registered User
Posts: 18
Joined: Sun Mar 25, 2007 4:34 am

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by niru »

niru wrote:
niru wrote:
Wingzfan wrote:
shu8man wrote: I got mine working, but it only displays one medal in the forum topic. Any suggestions?

Same issue for me too!

I had installed Medal System! Its working fine!
But Only one medal is showing in the Viretopic page even if the user is having 3 medals!
I had changed the number of rows to 2 and also to 3!
But still no effect!!
Check this post!

He is having 3 Medals! But only one is showing in view topic page! :(
(In my Medal Configuration page, I changed number of columns to 2)

Please help me to fix the issue!

What does your "rows" selection say? Does it say 1x1 or 1x something else. The 2nd number is your columns so you need to change that number. If you want 1 row with 10 medals you would put 1x10

Example


I'm using 1x2 for my Medal Configuration!
But still showing only one medal even if te member have 3 medals! :(


Anybody please help me to fix the issue!!


Any updates friend???

User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by Gremlinn »

Did you put the medals into different groups? Unless ycl6 updated the last version, there was an issue with it skipping every other group.

If I remember correctly, double check your viewtopic.php and the viewtopic_body.tpl files. I haven't touched this mod in a long time and it's installed onto CH.

murdo
Registered User
Posts: 10
Joined: Mon Dec 05, 2005 4:00 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by murdo »

Does anyone know where I can find the Nuke version of this mod?

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by ycl6 »

murdo wrote:Does anyone know where I can find the Nuke version of this mod?
Try Nuke support sites ;)

~Mac

SocomNutzClan
Registered User
Posts: 39
Joined: Fri Mar 02, 2007 11:05 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by SocomNutzClan »

I really want to implement this MOD, however I am unfamiliar with some of the steps. I would be willing to pay someone $10 paypal to implement this for me.

The forums I want to implement it onto is here;

http://www.nationalsocomleague.com/foru ... /index.php

It is still the main templete, and it uses the phpbbplus default install, which comes with alot of other mods installed.

You can reach me at Dez@socomnutzclan.com or AIM DezSocomNutz Thanks

SocomNutzClan
Registered User
Posts: 39
Joined: Fri Mar 02, 2007 11:05 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by SocomNutzClan »

Nevermind, I think I figured it out.

SocomNutzClan
Registered User
Posts: 39
Joined: Fri Mar 02, 2007 11:05 pm

Re: [BETA] Medal System MOD [ Latest: 0.4.6 ]

Post by SocomNutzClan »

Alright I do not get any errors, and the functionality seems to be working, but the medals do not display in the view topic. All I get is a ": " in everyones profile on the view topic. Not sure where that came from, or how to correct it?

Code: Select all

<span class="postdetails">{postrow.POSTER_RANK}<br />
{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />
{postrow.POSTER_AGE}<br />
{postrow.POSTER_JOINED}<br />
{postrow.POSTER_POSTS}<br />
{postrow.POSTER_FROM}<br />
{postrow.POSTER_MEDAL_COUNT}<br />
        <!-- BEGIN medal -->
        <table border="0" cellspacing="0" cellpadding="5">
                <!-- BEGIN medal_row -->
                <tr align="left" valign="middle">
                        <!-- BEGIN medal_col -->
                        <td><img src="{postrow.medal.medal_row.medal_col.MEDAL_IMAGE}" border="0" alt="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" title="{postrow.medal.medal_row.medal_col.MEDAL_NAME} {postrow.medal.medal_row.medal_col.MEDAL_COUNT}" {postrow.medal.medal_row.medal_col.MEDAL_WIDTH} {postrow.medal.medal_row.medal_col.MEDAL_HEIGHT} /></td>
                     <!-- END medal_col -->
                </tr>
                <!-- END medal_row -->
        </table>
        <!-- END medal -->
<!-- BEGIN author_profile -->
{postrow.author_profile.AUTHOR_VAL}<br /><!-- END author_profile -->
</span>
And on members profile the first pictured is exaggerated and stretched out.
http://www.nationalsocomleague.com/foru ... rofile&u=3

Please see link for the the stretch problem. Thanks

Post Reply

Return to “[2.0.x] MODs in Development”