[BETA] Quick Reply For phpBB 2.0.6

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
slaamp
Registered User
Posts: 29
Joined: Thu Feb 27, 2003 9:59 am
Location: here

Post by slaamp »

I don't have a viewtopic.php file in my forum? What do I do?

lol :lol: Are you sure you are using phpbb ???
:mrgreen:
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

viewtopic.php is like the 2-6 last phpbb file
Whos missing up my sig?
uberwald
Registered User
Posts: 10
Joined: Mon Jan 19, 2004 3:20 am
Contact:

Post by uberwald »

Just a question of curiosity -- why was this never approved and added to the MOD database? I see it in use on several boards that I check, and would like to add it to my own, once I'm sure that it's stable for the latest version.
pss121
Registered User
Posts: 9
Joined: Sat Mar 01, 2003 8:36 pm

Post by pss121 »

I have been using this mod for a long time under 2.0.6. I just updated my phpBB installation to 2.0.10 and re-applied this mod. Everything looks great after the changes, however, when I attempt to post the message I get the following error:

"No post mode specified".

Any ideas what would cause that? Any suggestions for a fix?

Thanks,

Paul
Darrenm
Registered User
Posts: 52
Joined: Tue Sep 14, 2004 2:43 pm

Post by Darrenm »

Wondering if anyone can help me with hopefully a basic request.

I have installed the mod using easymod on 2.10 PHPBB and it works fine using subsilver. My default board style is Morpheus and even though easymod said it had updated the Morpheus files quick reply isnt available on Morpheus, only subsilver.

Which files do i need to edit and what do I need to put in them? As you can guess Im a bit new at this.

Thanks
stu15
Registered User
Posts: 1283
Joined: Sat Mar 15, 2003 1:46 am
Location: New Zealand
Contact:

Post by stu15 »

Hello Darrenm :)
Darrenm wrote: My default board style is Morpheus and even though easymod said it had updated the Morpheus files quick reply isnt available on Morpheus, only subsilver.

Which files do i need to edit and what do I need to put in them?


Have a read of the Quick_Reply_MOD_1.0.0.txt file then fellow where is say about these files:

templates/Morpheus/viewtopic_body.tpl
templates/Morpheus/Morpheus.cfg

Note: where is says /subSilver/ in the text file means the style you are using

then one you have edited those two files, just upload them to the same place as you have download them from e.g. /templates/Morpheus/

Hope this helps :), if not post back here
A Registered User > I maybe wrong...So please correct him :) || My Forum - Stu's phpBB Helpdesk
Darrenm
Registered User
Posts: 52
Joined: Tue Sep 14, 2004 2:43 pm

Post by Darrenm »

Thanks for the help.

So if i understand correctly I look at the Quick_Reply_MOD_1.0.0.txt, find the part where it says subSilver and replace that text with Morpheus? Then upload the mod again and reinstall using Easymod?
stu15
Registered User
Posts: 1283
Joined: Sat Mar 15, 2003 1:46 am
Location: New Zealand
Contact:

Post by stu15 »

Darrenm wrote: So if i understand correctly I look at the Quick_Reply_MOD_1.0.0.txt, find the part where it says subSilver and replace that text with Morpheus? Then upload the mod again and reinstall using Easymod?


Ok, I got you confused there, sorry :oops: , I will try & explain better :)

What you need to do is read the Quick_Reply_MOD_1.0.0.txt file then where it says for example:

Code: Select all

# 
#-----[ OPEN ]------------------------------------------ 
# 
templates/yourtemplet/viewtopic_body.tpl 

# 
#-----[ FIND ]------------------------------------------------ 
# 
{S_TOPIC_ADMIN}</td> 

# 
#-----[ AFTER, ADD ]------------------------------------------ 
# 

<!-- BEGIN quick_reply --> 
     </tr> 
</table> 

<table width='100%' cellspacing='2' border='0' align='center'> 
  <tr> 
   <td valign='top' align='left'> 
     <form name='quick_reply' action='{quick_reply.U_QUICK_REPLY}' method='post'> 
     <!-- END quick_reply --> 
      <!-- BEGIN switch_username_field --> 
      <span class='gensmall'><b>{L_USERNAME}</b></span><br /> 
      <span class='genmed'><input type='text' class='post' tabindex='1' name='username' size='25' maxlength='25' value='' /></span><br /> 
      <!-- END switch_username_field --> 
      <!-- BEGIN quick_reply --> 
      <textarea name="message" rows="7" cols="35" wrap="virtual" style="width:425px" class="post" onclick="{if(document.quick_reply.message.value=='{L_QUICK_REPLY_TOPIC}') document.quick_reply.message.value=''}">{L_QUICK_REPLY_TOPIC}</textarea><br /> 
      {quick_reply.S_HIDDEN_FORM} 
      <input type='image' src='{quick_reply.QUICK_REPLY_IMG}' border='0' alt="{quick_reply.L_QUICK_REPLY_TOPIC}" onClick="if(document.quick_reply.message.value == '{quick_reply.L_QUICK_REPLY_TOPIC}' || document.quick_reply.message.value == ''){ alert('{quick_reply.L_EMPTY_MESSAGE}'); return false;}else{ return true;}" /> 
      </form> 
 </td> 
   <!-- END quick_reply --> 

#
You do what it says to do

Also you might what to have a read of this Visit phpBB!

Then one you have done that just re upload the two temple files back to the same folder as you download them from & then the mod will show up

Hope this help :)
A Registered User > I maybe wrong...So please correct him :) || My Forum - Stu's phpBB Helpdesk
Darrenm
Registered User
Posts: 52
Joined: Tue Sep 14, 2004 2:43 pm

Post by Darrenm »

ah, so i have to go through and make the alterations shown in the .txt file to the morpheus files myself?

didnt think it was that long-winded.

thanks!
Visit phpBB!


(i'm already here at www.phpbb.com :oops: )
Darrenm
Registered User
Posts: 52
Joined: Tue Sep 14, 2004 2:43 pm

Post by Darrenm »

thank you for the help. all is sorted now.

i put the quick reply code into the /Morpheus/viewtopic_body.tpl file and the quick reply was there thank you.

My problem was originally I was using notepad to edit the file and it doesnt recognise the line breaks correctly so had to use Dreamweaver code editor to see the files right.

once the files were structured correctly I could see what I was doing and inserted the code ok.

I didnt realise that Morpheus has its own quick reply with XS though so I installed XS and with the 2 quick replies it looked a bit messy so I stuck with the XS Morpheus quick reply.

But I know now how to mess about with the templates to get what I want.

Cheers.
eltim
Registered User
Posts: 23
Joined: Sat Jul 20, 2002 3:05 pm

Post by eltim »

i tried installing quick reply to my board, and i did all the steps and changed all the files, and came out with 2 problems.

1) everytime i edit the lang_main.php file and place this:
// Start add - Quick Reply Mod
$lang['Quick_Reply'] = 'Quick Reply';
// End add - Quick Reply Mod


at the end to:
//
// That's all, Folks!
// -------------------------------------------------
// Start add - Quick Reply Mod
$lang['Quick_Reply'] = 'Quick Reply';
// End add - Quick Reply Mod
?>


that change makes all the words on the main index of my board disappear. ei. who's online, date and time, view new posts, etc.

and also, i'm trying to install this into the Aeolus style, and i ran into another problem as well.

it says to open view_topic_body.tpl and find this:
<table width="100%" cellspacing="2" border="0" align="center">
<tr>
<td width="40%" valign="top" nowrap="nowrap" align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />
&nbsp;<br />
{S_TOPIC_ADMIN}</td>
<td align="right" valign="top" nowrap="nowrap">{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
</tr>
</table>


and replace with this:
<br />
<table width="100%" cellspacing="2" border="0" align="center">
<tr>
<td align="left" nowrap="nowrap">{QUICK_REPLY_BODY}</td>
<td align="right" valign="top" nowrap="nowrap">{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
</tr>
<tr>
<td width="40%" align="left" valign="top" nowrap="nowrap" colspan="2"><span class="gensmall">{S_WATCH_TOPIC}</span><br />&nbsp;<br />{S_TOPIC_ADMIN}</td>
</tr>
</table>


but in the Aeolus template file, there is no part that includes that table html that the subsilver view_topic_body.tpl file has.


any help with this would be much appreciated. i know it's possible to do this because my friend has it on his board with the same style, and he shut it done and we're getting everyone to sign up at my board.

thanks in advance.
countz
Registered User
Posts: 65
Joined: Fri Jul 09, 2004 7:07 pm

Post by countz »

i've got a problem :\
in fact when i push alt-s i want to send the post...
but how can i do this?!

thanx :)
ik_wolverine6
Registered User
Posts: 62
Joined: Sat Feb 14, 2004 7:42 am
Location: Guelph, Ontario, Canada
Contact:

Post by ik_wolverine6 »

I currently use smartor's quick reply mod, it looks great, and works even better, but I do like some of the features of this modification, so will this be upgraded to 2.0.10 anytime soon ?
TMB
Registered User
Posts: 474
Joined: Sat Sep 18, 2004 8:07 am

Post by TMB »

I've just added the quick reply box to our board, which uses the subPortal template. Unfortunately, it has messed up the page, pushing the message text off to the right, widening the page and adding a horizontal scroll bar at the bottom. It looks 'orrible.

This is a shame. The admins are very fond of subPortal, but the members must have their quick reply box.

Does anyone have a mod to fix this? There's room for everything.... I think the permissions tables just need moving a bit, but I'm new to this phpBB malarkey, and I have absolutely no idea how to go about doing this. :oops:
User avatar
tojan
Registered User
Posts: 24
Joined: Sat Aug 07, 2004 2:41 am

Post by tojan »

This is great mod, but very simple comparing to the one that Im using right now

Take a look at this: http://www.ewiza.com/forum/about54.html


You can find it here: http://phpbb.pl/download.php?d=4

Don't worry, instructions are in english:
Web Hosting Deal- comparison of the web hosting offers | Cute | praca
Post Reply

Return to “[2.0.x] MODs in Development”