[ABD] Profile Control Panel

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
260
60%
Very Good
81
19%
Good
43
10%
Fair
9
2%
Poor
41
9%
 
Total votes: 434

stardotstar
Registered User
Posts: 70
Joined: Fri Aug 01, 2003 2:07 am
Location: Brisbane, Australia
Contact:

Post by stardotstar » Fri Aug 26, 2005 1:34 am

Riamus, thanks for your confirmation of what is happening on your site. I take it from your meaning that you are not using the Adv PM system by Ptiirik. It does not work on his board either so I guess it is something to do with that mod. This is helpful to narrow it down without having to do lots of remodding.

BTW to others, sorry I do not use CH or activity mods (so not much help I'm afraid) but I found that I had to add PCP very early on in my build and was only able to get everything working well by doing it without EM - since that was the only way I could really know what was going where - and from that I was able to track down most hassels. Overall it is working very well on my board and I love the customisation it allws.
\x!\\_

Ultimatum
Registered User
Posts: 24
Joined: Fri Jan 07, 2005 4:51 pm

Post by Ultimatum » Fri Aug 26, 2005 5:59 am

the names left don't show up anymore, and the post don't show up also (by topic review they are but by viewtopic etc.. not)

the rest of the script seems to work perfectly, only that the names don't show up, can some1 help me....

btw where can I change the colors showing on my index for board founder etc.. I haven't found that..

Whitta
Registered User
Posts: 35
Joined: Sat Jan 15, 2005 10:21 pm

Post by Whitta » Fri Aug 26, 2005 7:41 am

Okay, I've got a small problem. The webhosting servicer I use limits the length of certain file names. Some of the files included in this mod have names that are too long to be hosted.

So, what I need is a suggestion of what to do. I'm thinking I should host them under a different name, but then I'd have to go and find any references to those files and change them, right? If this is the case, here are the files that are too long:

/main/templates/subSilver/admin/pcp_userfields_edit_sqldef_body.tpl
/main/mod-mods_settings/MOD-mods_settings-users_choices.txt
/main/language/lang_english/lang_extend_profile_control_panel.php
/main/tools/tools_groules_buddy_list_to_pcp.php


What files refer to these files in the mod?


If there's an easier way to do this, please let me know.


Any help would be appreciated.

Ultimatum
Registered User
Posts: 24
Joined: Fri Jan 07, 2005 4:51 pm

Post by Ultimatum » Fri Aug 26, 2005 10:20 am

Whitta wrote: Okay, I've got a small problem. The webhosting servicer I use limits the length of certain file names. Some of the files included in this mod have names that are too long to be hosted.

So, what I need is a suggestion of what to do. I'm thinking I should host them under a different name, but then I'd have to go and find any references to those files and change them, right? If this is the case, here are the files that are too long:

/main/templates/subSilver/admin/pcp_userfields_edit_sqldef_body.tpl
/main/mod-mods_settings/MOD-mods_settings-users_choices.txt
/main/language/lang_english/lang_extend_profile_control_panel.php
/main/tools/tools_groules_buddy_list_to_pcp.php


What files refer to these files in the mod?


If there's an easier way to do this, please let me know.


Any help would be appreciated.


yeah, there's a easier way, change host..

Whitta
Registered User
Posts: 35
Joined: Sat Jan 15, 2005 10:21 pm

Post by Whitta » Fri Aug 26, 2005 2:01 pm

Yeah, that's not really an option.

ly.grech
Registered User
Posts: 3
Joined: Sat Aug 06, 2005 4:24 am

Post by ly.grech » Sat Aug 27, 2005 10:34 am

Hi,

Before I go any further I just want to tell you I have limited web knowledge, someone else has helped us get the forum up and ruuning, but we know what our needs are and ask the following question of this Mod.

Currently we have prospective members sending additional profile information to prospective members to our forum.

Was wondering if this Mod would be suitable in being able to add fields for questions to be asked from registered member in addition to normal profile info.
This would then save us time on haveing to send seperate emails requesting additional information that the current format does not have.
Ow must add: a lot of these fields need to be Admin see only, not for other users to see.

Thanks for your time and responce

Lyn

crash3903
Registered User
Posts: 30
Joined: Fri Aug 26, 2005 3:59 pm

parse error

Post by crash3903 » Sun Aug 28, 2005 4:17 pm

Guys

I have installed this mod and the first time i run it at the front end i get this
Parse error: parse error, expecting `'{'' in /mywebhost/path/to/site/httpdocs/forum/includes/functions.php on line 890


Line 890 is here
//-- mod : profile cp ------------------------------------------------------------------------------
// here we added
// , $start_field='start'
//-- modify
function generate_pagination($base_url, $num_items, $per_page, $start_item, $add_prevnext_text = TRUE), $start_field='start'; //-- fin mod : profile cp


What is missing?

This is I think throwing an error regarding the session headers

Thanks

Mark

IgnorantNewGuy
Registered User
Posts: 452
Joined: Thu Jul 14, 2005 9:27 pm

Missing Text

Post by IgnorantNewGuy » Sun Aug 28, 2005 4:34 pm

EDIT: I located the place where this text is found:
Line 59 of templates/subSilver/index_body

<td class="row1" align="left"><span class="gensmall">{TOTAL_USERS_ONLINE} &nbsp; [ ] &nbsp; [ {L_WHOSONLINE_ADMIN} ] &nbsp; [ {L_WHOSONLINE_MOD} ] &nbsp; [ ]<br />{RECORD_USERS}<br />{LOGGED_IN_USER_LIST}</span></td>

What I need is to find out what the actual text is that goes into the [ ] above for both Board Founder and User.

In the "Who is Online" table at the bottom of the main page, I am now missing the text: [ Board Founder ] [ Administrator ] [ Moderator ] [ User ]. Where did it go?? What file is this script found in? I have all my PCP files in a location where I can import the script, if only I can find it. Interestingly, the problem exists on both of my boards, but in different forms of the problem. On the test.carp... board I see [ Administrator ] [ Moderator ], but on the main board I only show this: [ ] [ ].

I did do some work on a few files that I'll list at the bottom after the following template.

URL: http://www.test.carphighalumni.com/index.php and http://www.carphighalumni.com/reunited/index.php
Template(s) used: SubSilver
Any and all MODs:
  • PCP
    Extended PM Notification
    Forum Permissions
    Admin Links
    Admin Userlist
    Time Zone
    Referral Plus (installed and then uninstalled)
Do you use a port of phpBB: Config shows 80
Version of phpBB: 2.0.17
Version of PHP: I think 4? Whatever the very latest is. The boards are only a few weeks old and I downloaded straight from phpBB.com
Which database server and version: Not sure. Linux (not MS)
Host: IXWeb Hosting
Did someone install this for you/who: No
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: No
Have you searched for your problem: Yes
If so, what terms did you try: Just searched for "boardfounder," which I remember was there from previous work on this sort of thing.
State the nature of your problem: See above
Do you have a test account for us: NewUser1 on test.carp... board (pword: newuser)

I made a change yesterday that might be responsible for this. I added "Welcome to our Newest Member: " to the main page, I believe by altering lang_english/lang_main and templates/subsilver/index_body. You can see the result at the links.

Thx,
Scott 8)
Last edited by IgnorantNewGuy on Sun Aug 28, 2005 7:37 pm, edited 1 time in total.

crash3903
Registered User
Posts: 30
Joined: Fri Aug 26, 2005 3:59 pm

ooops!

Post by crash3903 » Sun Aug 28, 2005 4:45 pm

//-- mod : profile cp ------------------------------------------------------------------------------
// here we added
// , $start_field='start'
//-- modify
function generate_pagination($base_url, $num_items, $per_page, $start_item, $add_prevnext_text = TRUE), $start_field='start'; //-- fin mod : profile cp


I didn't put the text in red behind the closing bracket and for some reason added a >>> ; <<<

Thanks for anyone replying

Does this awsome mod work with country flags?

Regards

Mark

User avatar
rokroka
Registered User
Posts: 42
Joined: Tue Jul 26, 2005 2:34 am
Contact:

the most difficult mod i have ever faced...

Post by rokroka » Sun Aug 28, 2005 7:22 pm

Disclaimer: This MOD has not been Validated by the MOD Team. The MOD has been tested for functionality only. For more information see this topic. However, the author has proven to be trustworthy.


either something is wrong here or im an idiot ok first i posted about the lack of incompatability and have since dubbed this mod: "The Forum Crash MOD" i have installed this mod over 6 times using 3 versions of phpbb, i have doe it manually, also using ezmod and not to sh*t on your mod but it does not work between the mod itself and the cache over 200edits hours of scripting to no avail. whats really going on?

on every instance even on a freshly installed board it crashes, all blank pages, im sure there is nothing wrong with my ability to install a mod but i cant believe the writer of this mod after the time it must have taken to create i have not heard anything from anyone regarding a fix but i NEED THIS MOD!
judging from all the posts here about pcp it is probably one of the best mods for phpbb but i cant see it so if im wrong forgive me but it just does not work id like to see a forum where it does...show and prove because all i see is blank pages but it is ezmod compatable in the least...
HOLLA BACK

IgnorantNewGuy
Registered User
Posts: 452
Joined: Thu Jul 14, 2005 9:27 pm

It Worked For Me

Post by IgnorantNewGuy » Sun Aug 28, 2005 7:33 pm

id like to see a forum where it does...show and prove because all i see is blank pages but it is ezmod compatable in the least

Check it out here: http://www.test.carphighalumni.com/index.php

Sign in as "NewUser1" w/password newuser. Click on the "Profile" link at the top and look around. I installed it as my first MOD after easyMOD and easyMOD installed it just fine.

Scott 8)

User avatar
rokroka
Registered User
Posts: 42
Joined: Tue Jul 26, 2005 2:34 am
Contact:

Post by rokroka » Sun Aug 28, 2005 7:39 pm

Quote:
id like to see a forum where it does...show and prove because all i see is blank pages but it is ezmod compatable in the least

Check it out here: http://www.test.carphighalumni.com/index.php

Sign in as "NewUser1" w/password newuser. Click on the "Profile" link at the top and look around. I installed it as my first MOD after easyMOD and easyMOD installed it just fine.

Scott


i dont see anything relative to PCP there?

IgnorantNewGuy
Registered User
Posts: 452
Joined: Thu Jul 14, 2005 9:27 pm

Post by IgnorantNewGuy » Sun Aug 28, 2005 8:14 pm

Sorry about that. Looks like I've screwed something up with another MOD I installed/uninstalled. You can see it in action here:

http://carphighalumni.com/reunited/index.php
Sign in as CarpNative w/password carpnative. This password will work until 5 pm California time.

Click on CarpNative and you will be taken into PCP.

Scott 8)

User avatar
rokroka
Registered User
Posts: 42
Joined: Tue Jul 26, 2005 2:34 am
Contact:

Post by rokroka » Sun Aug 28, 2005 8:47 pm

ok a rule of thumb! it looks great...got it on the 7th try fist thing should be noted this mod must be done only after a fresh install!

it is ezmod compatable but the sql tables must be done manually and i find no help for the cache?

oh well finally got it now to put cat hier on top and hee what happens

User avatar
oab2
Registered User
Posts: 20
Joined: Fri Feb 27, 2004 11:21 pm

Edit Maps and Classes

Post by oab2 » Mon Aug 29, 2005 3:29 am

I have a question with the Map setup.

I want to make it so realname is required for registation. Also I want it to be unchangable once a person is registered. The board that I am making requires to have real names. Also I want it so the admin can change the realname like he can change a username. So I want realname to act like username in regard to being required and unchangeable by the user.

How do I do this?
Signing off...
Image

Locked

Return to “[2.0.x] MODs in Development”