[ABD] Profile Control Panel

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
260
60%
Very Good
81
19%
Good
43
10%
Fair
9
2%
Poor
41
9%
 
Total votes: 434

tlavery
Registered User
Posts: 59
Joined: Wed Jun 01, 2005 8:25 pm

Post by tlavery »

Gremlinn wrote: tlavery: It will work. We recommend trying it in a development environment, do not modify you live board until you try it out first.


Thanks......do you think it is possible to make a copy of the phpbb files as they are now and a copy of my database and have complete copy of the board on my web site? That way I can check it before going "live". Thanks for your suggestions you might have on how to do that!!
Chuck Young
Registered User
Posts: 11
Joined: Fri Jun 24, 2005 8:13 pm

phpBB 2.0.16 Register problem after install - "Enable V

Post by Chuck Young »

I have 2.0.16 running with the option to "Enable Visual Confirmatin" for new registrants. After Easymod installation (with manual SQL changes copied & pasted), new registrants don't see the six-character confirmation string. It shows up with a heading of "Control Picture" and 8 broken link symbols. The links point to:

http://reseda-west.com/phpBB2/profile_pic.php?l=0
through
http://reseda-west.com/phpBB2/profile_pic.php?l=7

For now, I'm disabling the checkbox for "Enable Visual Confirmation", but I'd like it to work. Any help much appreciated!
Chuck Young
Registered User
Posts: 11
Joined: Fri Jun 24, 2005 8:13 pm

Re: phpBB 2.0.16 Register problem after install - "Enab

Post by Chuck Young »

Quick follow-up:
After changing the administration pane so that visual confirmation is NOT required, the registration page still shows "Control Picture" entry with broken links!
Thanks!

--Chuck
Chuck Young
Registered User
Posts: 11
Joined: Fri Jun 24, 2005 8:13 pm

Re: phpBB 2.0.16 Register problem after install - "Enab

Post by Chuck Young »

OK, got a little more: I was switching the old flag under standard Configuration, which doesn't seem to matter anymore. Switching off the flag under the System tab of Configuration+ gets rid of the control image.

--Chuck
phpBB n00b
Registered User
Posts: 2
Joined: Thu Jun 30, 2005 5:19 am

Error Installing PCP

Post by phpBB n00b »

I just installed the PCP Mod.. all was going well, until it tried to parse the SQL table "rank_title".. I changed it manually and finished installing.. when I go back to the forum index, I see this:

*************************************************************
General Error

Could not obtain buddys information.

DEBUG MODE

SQL Error : 1146 Table 'forum.phpbb_buddy' doesn't exist

SELECT * FROM phpbb_buddy WHERE user_id=2 and buddy_id in (2)

Line : 216
File : page_header.php
*************************************************************

Any ideas on what could have caused this?
tlavery
Registered User
Posts: 59
Joined: Wed Jun 01, 2005 8:25 pm

Post by tlavery »

tlavery wrote:
Gremlinn wrote:tlavery: It will work. We recommend trying it in a development environment, do not modify you live board until you try it out first.


Thanks......do you think it is possible to make a copy of the phpbb files as they are now and a copy of my database and have complete copy of the board on my web site? That way I can check it before going "live". Thanks for your suggestions you might have on how to do that!!


OK I got the "ghost board" all ready. I am going to give this mod a try. Wish me luck! ;)

OMG this thing is HUGE! I am too tired to try this tonight...LOLOL Can this be installed with easymod? Thanks a million!
User avatar
Gremlinn
Registered User
Posts: 2133
Joined: Mon Aug 04, 2003 12:13 am
Location: Rochester, NY
Name: Nathan

Post by Gremlinn »

tlavery: Yes, if you haven't already tried it. Just copy the everything (files and DB) to a different system. I run Xampp (www.apachefriends.org) as my development environment. However, be sure to use phpmyadmin or other database sql tool and change some settings in the config table. Especially those that reference the web address. Also, don't forget to change the config.php to reference your development database and not your live one.

Also, you can use easymod. But, if it can't find a line, you will need to modify the mod's install txt file so that it can find it. Then try again.
phpBB n00b
Registered User
Posts: 2
Joined: Thu Jun 30, 2005 5:19 am

SQL Parsing error

Post by phpBB n00b »

I reinstalled phpBB and re-added the forum database entry via MyPHPAdmin, I've reinstalled EasyMOD and attempted to reinstall the PCP Mod when during the 2nd Step in the process, I received this error:

************************************************************

SQL PROCESSING ERROR:
No SQL alterations will be performed. However, you may skip SQL processing, continue installing the MOD, and deal with the SQL manually

The following error occured:

FATAL ERROR: Unable to parse SQL statement;


ALTER TABLE phpbb_ranks CHANGE rank_title rank_title VARCHAR(255) NOT NULL

************************************************************

Would this also cause the problem with the index page error? If so.. how can I correct this?
Riamus
Registered User
Posts: 886
Joined: Tue Jun 21, 2005 7:40 pm

CHANGE

Post by Riamus »

Easymod doesn't appear to support the CHANGE command. I just commented that line out, ran it through Easymod, and then went in and entered that command into my SQL table and it worked just fine.
Kakkoii Translation Team
格好いい 翻訳
Riamus
Registered User
Posts: 886
Joined: Tue Jun 21, 2005 7:40 pm

Questions

Post by Riamus »

A couple questions...

1) I'm still wondering about the question I asked at the bottom of page 155 (probably missed by people because it's at the bottom of the page).

2) Where can you edit the "Board Founder" title to name it something else? Also, where can you change the color of it and the person/people who are that title?
Kakkoii Translation Team
格好いい 翻訳
pavabe
Registered User
Posts: 48
Joined: Wed Dec 29, 2004 1:37 pm

Post by pavabe »

Hi I have a little problem with this mod.

Everything is working correctly, but I can't send PM's with attachments anymore. (and yes I have look into the ACP)
Before I installed this mod there was no problem.

I'm using the Attachment Mod version 2.3.13

thanks in advandge
pavabe
Registered User
Posts: 48
Joined: Wed Dec 29, 2004 1:37 pm

Re: Error Installing PCP

Post by pavabe »

phpBB n00b wrote: I just installed the PCP Mod.. all was going well, until it tried to parse the SQL table "rank_title".. I changed it manually and finished installing.. when I go back to the forum index, I see this:

*************************************************************
General Error

Could not obtain buddys information.

DEBUG MODE

SQL Error : 1146 Table 'forum.phpbb_buddy' doesn't exist

SELECT * FROM phpbb_buddy WHERE user_id=2 and buddy_id in (2)

Line : 216
File : page_header.php
*************************************************************

Any ideas on what could have caused this?


Log into your SQL data with phpAdmin goto the table ????.user and add the user name ANONYMOUS with ID -1 this solution works by me.

greetings
Last edited by pavabe on Sat Jul 02, 2005 10:22 am, edited 1 time in total.
mjatas
Registered User
Posts: 270
Joined: Sat Oct 16, 2004 6:43 am
Contact:

blank INDEX page

Post by mjatas »

so I decided toi install this MOD now I finished and I get blank page why?

www.speedcore.info
Why a blank page? Can anyone help me please and thanks?!
Ontario Wedding Forum
Over 500 users now online!
http://www.mystic-m.com/forum
tlavery
Registered User
Posts: 59
Joined: Wed Jun 01, 2005 8:25 pm

Post by tlavery »

Ok I Installed with easymod and got these errors:

SQL PROCESSING ERROR:
No SQL alterations will be performed. However, you may skip SQL processing, continue installing the MOD, and deal with the SQL manually

The following error occured:

FATAL ERROR: Unable to parse SQL statement;


ALTER TABLE phpbb_ranks CHANGE rank_title rank_title VARCHAR(255) NOT NULL


Then after processing the rest of the installation while skipping the SQL processing when I was done I got this error on the main MB page:

General Error

Could not obtain buddys information.

DEBUG MODE

SQL Error : 1146 Table 'dishinstallers_net_-_phpbb3.buddy' doesn't exist

SELECT * FROM buddy WHERE user_id=3 and buddy_id in (3)
Line : 216
File : page_header.php

Then I went into phpmyadmin and here are the errors that I got:

(I don't know if I tried to do the edits correctly so that may have been my problem.)

Code: Select all

ALTER TABLE phpbb_users ADD user_realname VARCHAR(25) NOT NULL;
ALTER TABLE phpbb_users ADD user_gender TINYINT(1) UNSIGNED DEFAULT '0' NOT NULL;
ALTER TABLE phpbb_users ADD user_birthday VARCHAR(8) DEFAULT '0' NOT NULL;
ALTER TABLE phpbb_users ADD user_last_birthday INT(11) UNSIGNED DEFAULT '0' NOT NULL;
ALTER TABLE phpbb_users ADD user_home_phone VARCHAR(20);
ALTER TABLE phpbb_users ADD user_home_fax VARCHAR(20);
ALTER TABLE phpbb_users ADD user_work_phone VARCHAR(20);
ALTER TABLE phpbb_users ADD user_work_fax VARCHAR(20);
ALTER TABLE phpbb_users ADD user_cellular VARCHAR(20);
ALTER TABLE phpbb_users ADD user_pager VARCHAR(20);
ALTER TABLE phpbb_users ADD user_summer_time TINYINT(1) UNSIGNED DEFAULT '0' NOT NULL;
ALTER TABLE phpbb_users ADD user_list_option VARCHAR(255);
ALTER TABLE phpbb_users ADD user_allow_email TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_allow_website TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_allow_messanger TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_allow_real TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_allow_sig TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewpm TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewwebsite TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewmessanger TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewreal TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewavatar TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewsig TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_viewimg TINYINT(1) DEFAULT '1' NOT NULL;
ALTER TABLE phpbb_users ADD user_buddy_friend_display TINYINT(1) DEFAULT '1';
ALTER TABLE phpbb_users ADD user_buddy_ignore_display TINYINT(1) DEFAULT '1';
ALTER TABLE phpbb_users ADD user_buddy_friend_of_display TINYINT(1) DEFAULT '1';
ALTER TABLE phpbb_users ADD user_buddy_ignored_by_display TINYINT(1) DEFAULT '1';
ALTER TABLE phpbb_users ADD user_watched_topics_per_page SMALLINT(3) DEFAULT '15';
ALTER TABLE phpbb_users ADD user_privmsgs_per_page SMALLINT(3) DEFAULT '5';
I copied and pasted all that into phpmyadmin and tried to apply it.....this is the error I got:

SQL-query:

ALTER TABLE phpbb_users ADD user_realname VARCHAR( 25 ) NOT NULL
MySQL said:

#1146 - Table 'dishinstallers_net_-_phpbb3.phpbb_users' doesn't exist


Then I copied and pasted this into phpmyadmin:

Code: Select all

ALTER TABLE phpbb_sessions ADD session_robot VARCHAR(32);
And here is my error:

SQL-query:

ALTER TABLE phpbb_sessions ADD session_robot VARCHAR( 32 )
MySQL said:

#1146 - Table 'dishinstallers_net_-_phpbb3.phpbb_sessions' doesn't exist

Then I copied and pasted this to phpmyadmin:

Code: Select all

ALTER TABLE phpbb_ranks CHANGE rank_title rank_title VARCHAR(255) NOT NULL;
ALTER TABLE phpbb_ranks ADD rank_max MEDIUMINT(8) NOT NULL AFTER rank_min; 
And this is my error:

SQL-query:

ALTER TABLE phpbb_ranks CHANGE rank_title rank_title VARCHAR( 255 ) NOT NULL
MySQL said:

#1146 - Table 'dishinstallers_net_-_phpbb3.phpbb_ranks' doesn't exist


Then I copied and pasted this to phpmyadmin:

Code: Select all

CREATE TABLE phpbb_buddy (
  user_id mediumint(8) NOT NULL default '0',
  buddy_id mediumint(8) NOT NULL default '0',
  buddy_ignore tinyint(1) NOT NULL default '0',
  buddy_visible tinyint(1) NOT NULL default '0',
  PRIMARY KEY  (user_id, buddy_id)
) TYPE=MyISAM;
And that one was successful!

After I tried to run the SQL I still get this error on the main MB page :

General Error

Could not obtain buddys information.

DEBUG MODE

SQL Error : 1146 Table 'dishinstallers_net_-_phpbb3.buddy' doesn't exist

SELECT * FROM buddy WHERE user_id=-1 and buddy_id in (3)

Line : 216
File : page_header.php

I did not get any errors from easymod about not being able to find any certain codes when it does it's initial check before performing the install, so maybe all the errors are related to SQL. I am not real familure with how to manually do the SQL changes, so maybe I totally screwed it up. If someone can give me some pointers I would appreciate it immensly! If I was supposed to do one line at a time I would appreciate knowing that :)

Thanks a MILLION guys!!
Last edited by tlavery on Sun Jul 03, 2005 5:13 am, edited 3 times in total.
mjatas
Registered User
Posts: 270
Joined: Sat Oct 16, 2004 6:43 am
Contact:

Post by mjatas »

you guys get errors. I only get a blank main page
www.obseti.com/phpBB2 or www.speedcore.info

:cry: :cry: :cry:
I don't know why and no one helped me yet :cry: :cry:
Ontario Wedding Forum
Over 500 users now online!
http://www.mystic-m.com/forum
Locked

Return to “[2.0.x] MODs in Development”