[DISC] Advanced Private Messages - beta 0.0.7 (on hold)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
phpika
Registered User
Posts: 890
Joined: Fri Aug 09, 2002 10:31 am
Location: UK
Contact:

Post by phpika »

Uh, I upgraded to 0.0.7, and suddenly I have a big problem with home in PCP - http://www.srg.valcato.net/pikachu/images/woops3.PNG
The Pika Club Website |pvpOnline|"I hope I didn't brain my damage" ~ Homer Simpson
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Read carefully the README.txt, especially the mention of the modification for profile.php in PCP...
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

> AI Bot : a mod hasn't to "work" with a template : you have to customize the tpl files included with the mod to fit your template if this last is too far from subSilver norms (regarding CSS essentialy).
phpika
Registered User
Posts: 890
Joined: Fri Aug 09, 2002 10:31 am
Location: UK
Contact:

Post by phpika »

What I did:
Added the SQL query
Modified profile.php (changed

Code: Select all

$submit = ( isset($HTTP_POST_VARS['submit']) || (($mode=='privmsg') && isset($HTTP_POST_VARS['post'])) );
to

Code: Select all

$submit = isset($HTTP_POST_VARS['submit']);
)
Uploaded all included files, replacing old ones. I've also tried to fix it by undoing the changes I made to profile.php to see if it'd work, but it stays the same no matter.
The Pika Club Website |pvpOnline|"I hope I didn't brain my damage" ~ Homer Simpson
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

When PCP comes with a blank page like this one, this means there is a syntax error in one file. As there is only a very few which are edited, the issue can stand in profile.php, or a file can remain in its last version. Be sure to upload all files (some ftp client use a cache and never upload :/).
phpika
Registered User
Posts: 890
Joined: Fri Aug 09, 2002 10:31 am
Location: UK
Contact:

Post by phpika »

Nope, completley deleted profile.php, got rid of it so there was no profile.php existing, then reuploaded it. No difference. All the other pages seem to work, though?
The Pika Club Website |pvpOnline|"I hope I didn't brain my damage" ~ Homer Simpson
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Same response :)
phpika
Registered User
Posts: 890
Joined: Fri Aug 09, 2002 10:31 am
Location: UK
Contact:

Post by phpika »

Sigh, I keep trying and trying and trying to no avail :( Thing is, even if I swap all the files with the ones from 0.0.6, still nothing shows. Somethings gone screwy here, it should go back to how it used to be if I changed the files.
The Pika Club Website |pvpOnline|"I hope I didn't brain my damage" ~ Homer Simpson
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

So uninstall the mod, be sure to have a working environnement, and re-install the mod from scratch. I am fairly sure you have made an error in one file modified.
esommer
Registered User
Posts: 220
Joined: Thu Sep 04, 2003 11:39 pm
Location: At my computer! Where else would I be?

Post by esommer »

Great mod! :) I like ones who like are compatible with easymod! Even though I had to do the SQL commands mannualy. It was hard work copying and pasting them into phpMyAdmin! :wink:
-A fellow phpBB User

...and a former TechTV fan before it became G4TechTV. :(
User avatar
transwarp™
Registered User
Posts: 92
Joined: Fri Jul 19, 2002 11:34 pm

Post by transwarp™ »

Still having trouble with this error inside CONFIG + inside ACP

Code: Select all

Fatal error: Call to undefined function: mods_settings_get_lang() in /home/terra-oc/public_html/DEVELOPMENT/admin/admin_board_extend.php on line 326
And the MOD itself seems not sending any PMs out - After pressing the submit button I being back at the PM posting screen without any error messages or whatever ?? -

Ok I got some script errors inside the templates, because it does not match anymore but this can't the reason for stop to send PMs ???

What are the folders

mod_settings
profilcp


for ? - Are the needed by this mod ? - I see no change with having or without having them inside -
- TERRA OCEANICA -
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

The mod is error-free, so if you have errors on your board, it is surely because you have introduced some installing the mod, or previous errors are revealed by this one (most of the time the first case is the one). All files mentioned in the install description are required until they are expressively mentioned as specific to another mod (ie PCP) or optional. I promise you I don't introduce extra stuff to make it "bigger" :).
User avatar
Dio2
Registered User
Posts: 94
Joined: Sun Jun 15, 2003 5:02 pm

Post by Dio2 »

Ptirhiik, another great MOD my users are loving it :D. One request -Please- is there a way to add who a PM is from in the email notify?
User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik »

Yep, it is only a matter of modifying the template used for pm notification (language/lang_english/email/privmsg_notify.tpl), and add the field to in the $parsed_values[] array (check at bottom of the functions_messages.php). You could also add the message and/or the title the same way :).
danb00
Registered User
Posts: 1025
Joined: Sun Dec 15, 2002 9:41 pm
Location: Inside Mod:Extreme PHPBB
Contact:

Post by danb00 »

ok right i was wondering is it possible for admins and mod's to have unlimeted messages in the inbox and so on.

while other members keep with the original configeration values
Locked

Return to “[2.0.x] MODs in Development”