[BETA] CodeCrush Log System (v.0.4.2alpha) (Dec-07)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
3Di
Former Team Member
Posts: 16155
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Post by 3Di »

I would like to give it a try.. :roll:
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
User avatar
3Di
Former Team Member
Posts: 16155
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Post by 3Di »

got this error after the installation of 3.0, on a 2.0.17 board.
thanks in advance

Code: Select all

Could not get browser count

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND logged <= AND browser LIKE '%turnitinbot%'' at line 2

SELECT count(*) AS browser_count FROM phpbb_cc_ip_log WHERE logged >= AND logged <= AND browser LIKE '%turnitinbot%'

Line : 266
File : admin_ip_stats.php
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
User avatar
badboy4ever
Registered User
Posts: 177
Joined: Sat Jun 11, 2005 2:38 pm
Location: UK

Post by badboy4ever »

Dose anyone know how long untill a new version will come out thats a bit more stable?

Image
Riamus
Registered User
Posts: 886
Joined: Tue Jun 21, 2005 7:40 pm

Post by Riamus »

3Di:

Look at the first post here:
http://www.phpbb.com/phpBB/viewtopic.ph ... &start=465

The fix at the top will fix your stats page error and another problem as well.
Kakkoii Translation Team
格好いい 翻訳
User avatar
3Di
Former Team Member
Posts: 16155
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Post by 3Di »

Riamus wrote: 3Di:

Look at the first post here:
http://www.phpbb.com/phpBB/viewtopic.ph ... &start=465

The fix at the top will fix your stats page error and another problem as well.


Thanks a bunch Riamus, i was just reading the Topic from the start looking for that, now everything seems to be working. I have now to learn some more about this MOD.

;)
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
Riamus
Registered User
Posts: 886
Joined: Tue Jun 21, 2005 7:40 pm

Post by Riamus »

Btw, the best way to find answers to a specific error message is to use the Search feature and select to view results as POSTS rather than TOPICS. Then, when you find one you think is right, click the subject link and you'll be taken right to it rather than trying to read through dozens of pages. :)
Kakkoii Translation Team
格好いい 翻訳
n1pj
Registered User
Posts: 14
Joined: Wed Sep 07, 2005 9:43 pm

Post by n1pj »

config_name varchar(255) not null primary key default ''

what am I supposed to use for default, am I just supposed to use (") in the default column. or do I have to add my own information there.


thanks
deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Post by deny »

3Di wrote:
Riamus wrote:3Di:

Look at the first post here:
http://www.phpbb.com/phpBB/viewtopic.ph ... &start=465

The fix at the top will fix your stats page error and another problem as well.


Thanks a bunch Riamus, i was just reading the Topic from the start looking for that, now everything seems to be working. I have now to learn some more about this MOD.

;)


Are the all users and all ip's listed on admin_ip.log by default or everything is empty??
Darlantan
Registered User
Posts: 369
Joined: Wed Mar 13, 2002 1:37 pm

Post by Darlantan »

n1pj wrote: config_name varchar(255) not null primary key default ''

what am I supposed to use for default, am I just supposed to use (") in the default column. or do I have to add my own information there.

off the top of my head, just use the blank ('') as default.

deny:
it's supposed to list all on initial load / default. That it doesn't for some is a bug.

I'm working on a minor update release to fix the aforementioned bugs. Which will also include a semi-automatic pruning option - hopefully something like what Riamus suggested earlier on.
n1pj
Registered User
Posts: 14
Joined: Wed Sep 07, 2005 9:43 pm

Post by n1pj »

What have I done wrong here. My board won't come up and this list of errors come up


Critical Error!
message_die() was called multiple times.
Error #1
Couldn't get IP Log Excludes information

Line : 126
File : /home/techniqu/public_html/bulletin/includes/cc_mod.php
SQL : SELECT * FROM cc_ip_exc WHERE (username = 'removed' AND ip IN ('***.***.***.*','***.***.***.*','209.113.*.*','209.*.*.*','*.*.*.*')) OR (username = '*' AND ip IN ('***.***.***.2','***.***.159.*','***.113.*.*','***.*.*.*','*.*.*.*')) LIMIT 1
Error #2
Couldn't get IP Log Excludes information

Line : 126
File : /home/techniqu/public_html/bulletin/includes/cc_mod.php
SQL : SELECT * FROM cc_ip_exc WHERE (username = 'removed' AND ip IN ('***.***.***.*','***.***.***.*','***.113.*.*','***.*.*.*','*.*.*.*')) OR (username = '*' AND ip IN ('***.113.***.*','***.113.***.*','209.***.*.*','209.*.*.*','*.*.*.*')) LIMIT 1
Please, contact the webmaster. Thank you.


any help would be greatly apreciated thanks

Okay I fixed that problem but I have a new one

Could not get browser count

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND logged <= AND browser LIKE '%inktomi%'' at line 2

SELECT count(*) AS browser_count FROM cc_ip_log WHERE logged >= AND logged <= AND browser LIKE '%inktomi%'

Line : 266
File : admin_ip_stats.php



What the heck does that mean.

I am running MySQL 4.0.16

thanks
User avatar
badboy4ever
Registered User
Posts: 177
Joined: Sat Jun 11, 2005 2:38 pm
Location: UK

Post by badboy4ever »

okay i aint great at mysql but when it says you have a error in your syntax it normaly means that you missed out a . or somthing

Image
n1pj
Registered User
Posts: 14
Joined: Wed Sep 07, 2005 9:43 pm

Post by n1pj »

badboy4ever wrote: okay i aint great at mysql but when it says you have a error in your syntax it normaly means that you missed out a . or somthing


I know a lot less than you do, I am just learing SQL now.

I didn't edit this file. It is still the fresh file from installing the ip program. Unless it is looking at another file somewhere else and logging it under this file at line 266
User avatar
badboy4ever
Registered User
Posts: 177
Joined: Sat Jun 11, 2005 2:38 pm
Location: UK

Post by badboy4ever »

So you did a fresh install of the mod?

Image
n1pj
Registered User
Posts: 14
Joined: Wed Sep 07, 2005 9:43 pm

Post by n1pj »

badboy4ever wrote: So you did a fresh install of the mod?


Yes, but now I have a new problem, under the mod config that points to the mssql database it says do not change this. Default it blank. I tried changing it to phpbb like in my database thinking that would work and now all those screens don't work. Do you know how I can change that field back to normal (blank) again.


thanks

This is the new error I get

Could not get config

DEBUG MODE

SQL Error : 1146 Table 'techniqu_p_bb1.phpbbcc_ip_config' doesn't exist

SELECT config_name, config_value FROM phpbbcc_ip_config

Line : 83
File : functions_ccip.php

Ok I was able to reset the database and fix that problem. Now I just have this error remaining.

General Error
Could not get browser count

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND logged <= AND browser LIKE '%turnitinbot%'' at line 2

SELECT count(*) AS browser_count FROM phpbbcc_ip_log WHERE logged >= AND logged <= AND browser LIKE '%turnitinbot%'

Line : 266
File : admin_ip_stats.php


The program also doesn't capture ip adresses yet. I think it has something to do with this error but I don't know.

Any help would be appreciated

Thanks
Darlantan
Registered User
Posts: 369
Joined: Wed Mar 13, 2002 1:37 pm

Post by Darlantan »

hehe, it says "do not change" cause it means trouble if you get it wrong. ;)

as for the browser count error, it's a bug that affects some users. Will be fixed in the upcoming minor version. Could verywell be the same bug causing it not to log anything.
Post Reply

Return to “[2.0.x] MODs in Development”