Page 15 of 16

Posted: Tue Aug 29, 2006 3:20 am
by zuker
it doen't give me points when i post, but everything seems to be right installed :idea: :?:

Restrictions on donating points

Posted: Thu Sep 07, 2006 5:37 am
by jaggie_c
Hi Robbie....

I just installed phpbb. It looks great. I have also installed your points mod with easymod. It went well. I am planning to go through the php scripts to understand the code, which may take a long time for my dumb head before I start modifying stuff myself.

Since you have already mastered phpbb, can I trouble you for a small modification in your points system?.

1. Only thread owner (who posts the message first in that thread) shall be able to donate points - Can phpbb distinguish the thread owner from rest of the users in that thread?
2. Number of points given to each post and to each user in that thread are to be limited. This number is to be configurable in admin panel.

How much of effort would it be for you to do me this favor?.

Thanks a billion in advance,
Jaggie

Posted: Mon Sep 18, 2006 6:59 pm
by The_Juke
I am a program just not a PHP programer. Everything has been going pretty well with our boards and I have been able to install MODS without much troube. The points mod was the last one I installed and now I am getting this error with the our WebLog when users are not loged in.

I also get a Username already exists when a guest agrees to the terms and click the 13 or older link.

Code: Select all

Error querying to find user weblog friends information

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

SELECT * FROM phpbb_weblog_friends WHERE friend_id =

Line : 859
File : functions_weblog.php

Can anyone help?

Posted: Sun Sep 24, 2006 8:53 pm
by gamerxgirl
LSshock wrote: what if i want to add a field to the registration form, saying refferer: and when they fill in the username this user gets 100 points for reffering a new member?
is this hard to do :)?


What would be the point of that if if you could just use the Refferals Plus mod that does that already?

Posted: Fri Nov 17, 2006 4:55 am
by thoffland
I just installed the mod and it's great!

I've created a usergroup to administer points for my board, and the administrators are unable to do so. Is there a trick to getting it to work?

In the space that says:
Authorized Groups
Enter ids of groups who are authorized to access the points control panel, one id per line.

I've added the usergroup, but it's a no go. I've also tried adding the usernames... still nothing.

What could I be missing?

Posted: Sun Nov 19, 2006 5:14 am
by TheHackMan
Right now I am at this step
#
#-----[ FIND ]------------------------------------------
#

global $userdata, $user_ip;

#
#-----[ IN-LINE FIND ]------------------------------------------
#

$user_ip

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#

, $post_info

#

in the includes/functions_post.php document
When I went looking in there the
global $userdata, $user_ip;
line of code appears one three separate occasions and I am not sure where to add the needed part of code at =/

Posted: Sun Nov 19, 2006 5:27 am
by thoffland
TheHackMan wrote: in the includes/functions_post.php document
When I went looking in there the
global $userdata, $user_ip;
line of code appears one three separate occasions and I am not sure where to add the needed part of code at =/


I added it here and it worked for me:

Code: Select all

// Post a new topic/reply/poll or edit existing post/poll
//
function submit_post($mode, &$post_data, &$message, &$meta, &$forum_id, &$topic_id, &$post_id, &$poll_id, &$topic_type, &$bbcode_on, &$html_on, &$smilies_on, &$attach_sig, &$bbcode_uid, $post_username, $post_subject, $post_message, $poll_title, &$poll_options, &$poll_length)
{
	global $board_config, $lang, $db, $phpbb_root_path, $phpEx;
	global $userdata, $user_ip, $post_info;

	include($phpbb_root_path . 'includes/functions_search.'.$phpEx);

	$current_time = time();

	if ($mode == 'newtopic' || $mode == 'reply' || $mode == 'editpost') 
	{
		//
		// Flood control
		//
	

Posted: Sun Dec 03, 2006 12:48 am
by mathassam
when i'm done with uploaded all files to the right dicorety the pointscp there is something wrong i made a screenshot look>>>
http://img294.imageshack.us/my.php?imag ... oosff9.png

can you help me out what problem this is?

Posted: Thu Dec 07, 2006 6:23 pm
by K34nu
Hey,
Im getting this error when installing with Easy mod:
Critical Error

FIND FAILED: In file [language/lang_english/lang_main.php] could not find:

//
// That's all, Folks!
// -------------------------------------------------


I know exactly what it means (Not hard too see) But all I don't know is...

Is if
//
// That's all, Folks!
// -------------------------------------------------

Is RIGHT at the end of that script? Because if so, I have no problem editing it and adding that in so the script will work.

I need a reply ASAP!
Thanks for reading this!!

-Keanu
p.s. (I know this is a novice question.. Sorry)

Posted: Fri Dec 08, 2006 3:48 pm
by mathassam
I'm missing the language i installed it but the tekst aint showing up..

Posted: Fri Dec 08, 2006 5:20 pm
by yongkian
K34nu wrote: Hey,
Im getting this error when installing with Easy mod:
Critical Error

FIND FAILED: In file [language/lang_english/lang_main.php] could not find:

//
// That's all, Folks!
// -------------------------------------------------


I know exactly what it means (Not hard too see) But all I don't know is...

Is if
//
// That's all, Folks!
// -------------------------------------------------

Is RIGHT at the end of that script? Because if so, I have no problem editing it and adding that in so the script will work.

I need a reply ASAP!
Thanks for reading this!!

-Keanu
p.s. (I know this is a novice question.. Sorry)


I think it is...most of the times is install at the bottom :D

Posted: Fri Dec 22, 2006 12:36 pm
by goranbaxy
I have installed last version of this mod (2.0.9), and I relay like it, I laike that I can enable/disable each forum, but the problem is if I set some forum to to not receive points for posts, I rely dont get points for postings, witch is great, but the problem is if I delete post, points are taken from me, and that is not good.

P.S. sorry for bad English, I hope you understand the problem
EDIT: also can I give some points to member when he register to a forum?

Posted: Sat Dec 30, 2006 5:13 am
by andhraboyz
I have modified all the things and when i am installing the mod,i got these errors.can anyone help me in solving this.

Database type :: mysql
phpBB version :: 2.0.20

Updating database schema & data
Progress :: ............. Done
Result :: Some queries failed, the statements and errors are listing below

Error :: Duplicate column name 'points_disabled'
SQL :: ALTER TABLE phpbb_forums ADD points_disabled TINYINT(1) NOT NULL AFTER prune_enable


Error :: Duplicate column name 'user_notify_donation'
SQL :: ALTER TABLE phpbb_users ADD user_notify_donation TINYINT(1) NOT NULL AFTER user_notify_pm


Error :: Duplicate column name 'user_points'
SQL :: ALTER TABLE phpbb_users ADD user_points INT NOT NULL


Error :: Duplicate column name 'admin_allow_points'
SQL :: ALTER TABLE phpbb_users ADD admin_allow_points TINYINT(1) DEFAULT '1' NOT NULL


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_reply', '1')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_topic', '2')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_page', '1')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_post', '1')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES('points_browse', '1')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_donate', '1')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_name', 'Points')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_user_group_auth_ids', '')


Error :: Column count doesn't match value count at row 1
SQL :: INSERT INTO phpbb_config VALUES ('points_system_version', '2.1.1')

Posted: Sun Dec 31, 2006 5:15 am
by onicdesigns
I am having a hard time finding the "Shop" that this mod works with. Would someone be so kind as to post the link to the shop for me. I have found several, but don't know which one it does work with.

Posted: Tue Jan 02, 2007 12:46 pm
by Zarath
As long as it uses user_points in the phpbb_users table... see my signature. :)