[Submitted] Recycle Bin Mod v1.0.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

Shof515 wrote: Is there a way to add a bin button to the Moderator Control Panel
As requested, here we go :)


New version is 0.9.2

- Updated bin.php
- Added bin selection in modcp (recycle all topics from one forum to the bin forum in one click)
- Added Mark/Unmark all feature
- Confirmed on phpBB 2.0.10

Version 0.9.1
- Fixed an error in subSilver.cfg in instructions


How to update:
files that have changed
- bin.php (replace your old bin.php with the new file)
- lang_main.php

Code: Select all

#
#-----[ FIND ]----------------------------
#
$lang['Bin_disabled'] = 'Bin has been disabled';
#
#-----[ AFTER, ADD ]-------------------------------------
#
$lang['Bin_recycle'] = 'Recycle';
new files and parts
- modcp.php
- modcp_body.tpl

Read install.txt for new parts in modcp.php and modcp_body.tpl


Let me know if you encounter any problem with the new version to release version 1.0.0 :wink:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

'L_SELECT' => $lang['Select'], can be found more then once,which one do i put the code in?
Whos missing up my sig?
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

OK :)
i updated install.txt (no number version changed)
just find

Code: Select all

			'L_LASTPOST' => $lang['Last_Post'], 
			'L_SELECT' => $lang['Select'], 
:roll:
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

Ahh ok,so i did put it in the right place after i just gues it,and when i move a topic to the bin using the mod cp,this is what happens:
http://www.shof515.com/trash/problem.gif
If i delete a post,then i have no problems as seen in this shot:
http://www.shof515.com/trash/correct.gif
Whos missing up my sig?
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

very strange
i'm just testing it and it works on my demo board

You can register and submit to this group
-> http://perso.edeign.com/kooky/groupcp.php?g=67
Then post new topic and use ModCP to recycle it
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
Shof515
Registered User
Posts: 1169
Joined: Wed Mar 19, 2003 4:36 am

Post by Shof515 »

Either i am tired(11:30pm) or just plain stupid but i was missing this:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
modcp.php

#
#-----[ FIND ]------------------------------------------
#
$confirm = ( $HTTP_POST_VARS['confirm'] ) ? TRUE : 0;
#
#-----[ AFTER, ADD ]------------------------------------------
#
// Start add - Bin Mod
$confirm_recycle = TRUE;
// End add - Bin Mod
Whos missing up my sig?
wd2004
Registered User
Posts: 2
Joined: Tue Sep 07, 2004 5:41 am

Post by wd2004 »

Great Mod! No problems installing and it works great! Thank you. :D
ldma
Registered User
Posts: 30
Joined: Thu Jul 22, 2004 9:59 am

Post by ldma »

Link to mod has not been working for about 2 weeks now...has it been posted anywhere else?
User avatar
stickerboy
Former Team Member
Posts: 7349
Joined: Mon Mar 29, 2004 2:27 pm
Location: Airdrie, UK (127.0.0.1)
Name: Kenny Cameron
Contact:

Post by stickerboy »

I got it to work fine :?
Famitsu, just installed this on my new forums. was version 0.91, but i just this minute updated to 0.92.
No errors at all, but when I try to recycle from the modcp, it just seems to refresh the page.

The normal bin icon works. i did upload the new bin.php and have done the modifications. what could be wrong? think i've missed something :oops:
I'm a web-designing code-decrypting tech-support musician
|| Twitter || Flickr || phpBB Snippets ||
Formerly known as cherokee red
~ TwiSteD ~
Registered User
Posts: 115
Joined: Sun Jun 27, 2004 4:03 am
Location: here
Contact:

Post by ~ TwiSteD ~ »

ldma wrote: Link to mod has not been working for about 2 weeks now...has it been posted anywhere else?


Same here, everytime i try to go to the download site, it wants me to download viewtopic.php :?
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

~ TwiSteD ~ wrote:
ldma wrote:Link to mod has not been working for about 2 weeks now...has it been posted anywhere else?


Same here, everytime i try to go to the download site, it wants me to download viewtopic.php :?
lol do not do right click and "save as" :lol:
just follow dowload link and read the topic...there is a box with download link (working)
board might be down, currently my host encountered few troubles

Version 1.0.0 will be release soon since no bugs were found
will be submitted here and on phpBB Hacks to have more links available



@ cherokee red
First be sure you replaced your old bin.php with new bin.php
header is: $Id: bin.php,v 1.01 2004/09/08 02:39:04 kooky Exp $
Then are you set a value for Bin forum in your AdminCP?

Where did you have this problem? in viewtopic or in modcp page?
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
User avatar
stickerboy
Former Team Member
Posts: 7349
Joined: Mon Mar 29, 2004 2:27 pm
Location: Airdrie, UK (127.0.0.1)
Name: Kenny Cameron
Contact:

Post by stickerboy »

yeah, it is the correct BIN.php file.
and it's only on modcp.php that's the problem.
the icon in viewtopic works fine :?
I'm a web-designing code-decrypting tech-support musician
|| Twitter || Flickr || phpBB Snippets ||
Formerly known as cherokee red
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

OK, therefore there is something wrong in your modcp.php
i tested this on my demo board, i have confirmation message for topics recycled

Check your file with new instructions (maybe code added in a wrong place) or send me yours, i will take a look
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
User avatar
Galixte de EzCom
Registered User
Posts: 1090
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Post by Galixte de EzCom »

Hi,

the download's link of Bin Mod is corrupt.

Are you an alternative link please ?

In thanking you :wink:
Famitsu
Registered User
Posts: 774
Joined: Mon Aug 25, 2003 7:59 pm
Location: Account disabled -> see my signature to contact me
Contact:

Post by Famitsu »

Hi download link works, i unzipped file: status OK
try a new time



New version is 1.0.0

- Final version (no change)
Don't PM me, i won't answer anymore

My Contibs: Online-Offline-Hidden | Email Confirmation
The TRI FORCE (Username Color | User Level | ModeratorCP)
...

My new/current account: contact me here
Locked

Return to “[2.0.x] MODs in Development”