[DISC] Activity Mod Plus (Newest Release: v1.1.0)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
A.I. BOT
Registered User
Posts: 1848
Joined: Thu Apr 17, 2003 11:43 pm
Location: Newfoundland, Canada
Contact:

Post by A.I. BOT »

Yeah i click that and nothing happens...i had to do the sql kinda manually but i dident do it all :( pwwees can i have plain text sql :)

thanks
User avatar
aUsTiN-Inc
Registered User
Posts: 929
Joined: Fri Apr 16, 2004 10:31 am
Location: Georgia
Contact:

Post by aUsTiN-Inc »

I dont have one to give, last time i tried giving one people were using it on fresh installs & upgrades, messing up their boards & blaming me because the sql that was named Install.sql not Upgrade.sql messed up their games tables.

I will have to look @ the admin_in_un.php and make one from that if one needs made.
¤ phpBB Security ¤ Blend Portal Creator ¤
¤ Activity Mod Plus Creator «« 2004 phpBBHacks "Hack" Of The Year ¤
¤ Activity Mod Plus Home ¤ 2004 phpBBHacks "Hack" Author Of The Year ¤
My mods are never done, always in update status!
megablastadmin
Registered User
Posts: 193
Joined: Tue Aug 31, 2004 9:53 am
Contact:

Post by megablastadmin »

any solution please :cry: :cry: :cry:
megablastadmin wrote: hi
thanks for the reply
the earlier problem got solved
now i face this :(
while viewing a topic,,
I saw this link in there
"Hall of Fame Member"
and when i clicked on it
i got this
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 15 bytes) in /var/www/free.fr/a/0/zohaib/forum/db/mysql4.php on line 235


Please help.
Thanks again
:cry: :cry: :cry:
Whitta
Registered User
Posts: 35
Joined: Sat Jan 15, 2005 10:21 pm

Post by Whitta »

Could not delete oldest privmsgs text (inbox)

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1107103753, 'a46bd452' , 1, 1, 1)' at line 3

INSERT INTO phpbb_privmsgs (privmsgs_type, privmsgs_subject, privmsgs_from_userid, privmsgs_to_userid, privmsgs_date, privmsgs_ip, privmsgs_enable_html, privmsgs_enable_bbcode, privmsgs_enable_smilies) VALUES ( 1 , 'Trophy Lost!' , 2, , 1107103753, 'a46bd452' , 1, 1, 1)

Line : 206
File : /home/teamvtkc/public_html/forums/includes/functions_amod_plus.php


My fun little error. Happens when I get a new highscore.
User avatar
aUsTiN-Inc
Registered User
Posts: 929
Joined: Fri Apr 16, 2004 10:31 am
Location: Georgia
Contact:

Post by aUsTiN-Inc »

Megablast, that is a server side issue, try contacting your host & see what they say.

The prv msg error is a hit & miss one that i am aware of. For now, turn off prv msging in the Xtras panel on trophy loss. It will keep you from getting the error.
¤ phpBB Security ¤ Blend Portal Creator ¤
¤ Activity Mod Plus Creator «« 2004 phpBBHacks "Hack" Of The Year ¤
¤ Activity Mod Plus Home ¤ 2004 phpBBHacks "Hack" Author Of The Year ¤
My mods are never done, always in update status!
megablastadmin
Registered User
Posts: 193
Joined: Tue Aug 31, 2004 9:53 am
Contact:

Post by megablastadmin »

Thanks mate for the reply.
I will surely contact the host and see what they say and then get back to u if needed

Thanks again
blazzinbird
Registered User
Posts: 2
Joined: Thu Feb 03, 2005 12:53 pm

Post by blazzinbird »

im having probs with the coding thisis what i get when i go to my forum now

function UpdateTrophyStats() { global $db, $table_prefix; $q = "UPDATE ". USERS_TABLE ." SET user_trophies = '0' WHERE user_trophies <> '0'"; $r = $db -> sql_query($q); $q = "SELECT player FROM ". $table_prefix ."ina_top_scores GROUP BY player"; $r = $db -> sql_query($q); while($row = $db -> sql_fetchrow($r)) { $who = $row['player']; $q1 = "SELECT COUNT(*) AS trophies FROM ". $table_prefix ."ina_top_scores WHERE player = '$who' GROUP BY player"; $r1 = $db -> sql_query($q1); $row = $db -> sql_fetchrow($r1); $total_trophies = $row['trophies']; $q2 = "UPDATE ". USERS_TABLE ." SET user_trophies = '$total_trophies' WHERE user_id = '$who'"; $r2 = $db -> sql_query($q2); } return; } function CheckGamesDeletion() { global $db, $table_prefix, $board_config; $q = "SELECT config_value FROM ". CONFIG_TABLE ." WHERE config_name = 'current_ina_date'"; $r = $db -> sql_query($q); $row = $db -> sql_fetchrow($r); $next_deletion = $row['config_value']; $explode_it = explode("-", $next_deletion); $d_month = $explode_it[1]; $t_date = date("Y-m-d"); $x_date = explode("-", $t_date); $c_month = $x_date[1]; if($d_month == $c_month){ } else { if($board_config['ina_delete'] == "1") { $q = "TRUNCATE ". iNA_SCORES .""; $r = $db -> sql_query($q); $q = "TRUNCATE ". $table_prefix ."ina_trophy_comments"; $r = $db -> sql_query($q); $q = "UPDATE ". CONFIG_TABLE ." SET config_value = '$t_date' WHERE config_name = 'current_ina_date'"; $r = $db -> sql_query($q); } } return; }
Parse error: parse error, unexpected T_ELSE in /home/silcc1/public_html/forum/includes/page_header.php on line 161

well it says line 161 i cant find anything here is a link to my code for that page if you can help ill be so happy
http://www.silcc.com:2082/frontend/x/fi ... header.php

i need help real bad
User avatar
aUsTiN-Inc
Registered User
Posts: 929
Joined: Fri Apr 16, 2004 10:31 am
Location: Georgia
Contact:

Post by aUsTiN-Inc »

I answered your PM blazzin.
¤ phpBB Security ¤ Blend Portal Creator ¤
¤ Activity Mod Plus Creator «« 2004 phpBBHacks "Hack" Of The Year ¤
¤ Activity Mod Plus Home ¤ 2004 phpBBHacks "Hack" Author Of The Year ¤
My mods are never done, always in update status!
User avatar
TPCpro
Registered User
Posts: 69
Joined: Sat Jul 31, 2004 11:27 pm
Contact:

Post by TPCpro »

aUsTiN-Inc wrote: Please have a read of the .9 change log, that is in there.

http://phpbb-amod.com/viewtopic.php?t=1264


I tried http://phpbb-amod.com/viewtopic.php?t=1264 and http://phpbb-amod.com/about1264.html (Both file changes for 1.0.9) and when I go to both of them is keeps wanting what looks like refresh. It just stalls, then after a couple minutes I will get a SQL error. That topic is the only one I can't access.
FREE and PAID hosting as well as a comunity forum, pictures, games, and SO MUCH MORE!
http://liquidbluex.net
DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Post by DivErTido »

Whitta wrote:
Could not delete oldest privmsgs text (inbox)

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1107103753, 'a46bd452' , 1, 1, 1)' at line 3

INSERT INTO phpbb_privmsgs (privmsgs_type, privmsgs_subject, privmsgs_from_userid, privmsgs_to_userid, privmsgs_date, privmsgs_ip, privmsgs_enable_html, privmsgs_enable_bbcode, privmsgs_enable_smilies) VALUES ( 1 , 'Trophy Lost!' , 2, , 1107103753, 'a46bd452' , 1, 1, 1)

Line : 206
File : /home/teamvtkc/public_html/forums/includes/functions_amod_plus.php


My fun little error. Happens when I get a new highscore.


I have same problem and I think what is causing that.
The problem begins since I have instaled this mod.
install.txt Config Secure wrote: REQUIREMENTS:
In order for this mod to work you must have access to your WEB ROOT.(the directory before your "public_html" folder.)
EX:
config.php_here/public_html/phpbb2/


and I have checked install.txt of Activity mod and says this:
install.txt Activity wrote: Definitions:
##
## Root: Folder your config.php is located


Any sugestion to resolve this?
I need Config Secure Mod because I´ve been hacked twice this week. :roll:
User avatar
aUsTiN-Inc
Registered User
Posts: 929
Joined: Fri Apr 16, 2004 10:31 am
Location: Georgia
Contact:

Post by aUsTiN-Inc »

This mod wont open security problems. And if you need added seucrity, try phpBB Security.

Anyhow, to rid the error for now, turn OFF PM's for trophy loss.
¤ phpBB Security ¤ Blend Portal Creator ¤
¤ Activity Mod Plus Creator «« 2004 phpBBHacks "Hack" Of The Year ¤
¤ Activity Mod Plus Home ¤ 2004 phpBBHacks "Hack" Author Of The Year ¤
My mods are never done, always in update status!
DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Post by DivErTido »

aUsTiN-Inc wrote: This mod wont open security problems. And if you need added seucrity, try phpBB Security.

Anyhow, to rid the error for now, turn OFF PM's for trophy loss.


Where can I found phpBB Security? :wink: It works on a 2.0.4 version? :oops:
I turn PM's for trophy loss OFF and error dont appear anymore. But, all games and games scores disappear.
The list of games is empty... strange...
Are you sure that this mod dont bring problems to activity mod?

Whitta, have you installed this mod?
megablastadmin
Registered User
Posts: 193
Joined: Tue Aug 31, 2004 9:53 am
Contact:

Post by megablastadmin »

u can find this mod here

http://phpbb-tweaks.com/downloads.php?mode=sub&cid=916

and it dont create problem with activity mod

check my site
get link from my signature
i have both installed
and no prob at all there
User avatar
aUsTiN-Inc
Registered User
Posts: 929
Joined: Fri Apr 16, 2004 10:31 am
Location: Georgia
Contact:

Post by aUsTiN-Inc »

No, there should be no conflicts with the 'Config Secure' hack. Altho it is a pointless one, as all you're doing is moving it from 1 pre-defined folder into another. So rather senseless, but no conflicts should arise either way as none of the amod files call to config.php directly.

Also, disabling the PM will not cause things to disappear. Make sure all the games are still in the database. Also make sure all the games are not disabled (hidden from users).
¤ phpBB Security ¤ Blend Portal Creator ¤
¤ Activity Mod Plus Creator «« 2004 phpBBHacks "Hack" Of The Year ¤
¤ Activity Mod Plus Home ¤ 2004 phpBBHacks "Hack" Author Of The Year ¤
My mods are never done, always in update status!
DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Post by DivErTido »

Tks guys!
aUsTiN-Inc, I restarted all scores and now is all ok! :wink:
I dont know what happened!
Locked

Return to “[2.0.x] MODs in Development”