[Beta] Paypal IPN GROUP Subscription MOD [1.1.3]

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
BarrieUK
Registered User
Posts: 167
Joined: Wed Aug 21, 2002 3:25 pm
Contact:

Post by BarrieUK » Wed Jul 13, 2005 6:03 am

OK, deepest apologies. It would appear I have been wasting your time. There is nothing at all wrong with the permissions screen. If the forum permissions are all set to anything other than private, nothing will show up in the group permissions or user permissions.

As I have never bothered with the permissions before, on the forum I run now, I assumed the screen would be populated, as it was with another forum I run, which is all private.

I am very sorry, I feel a complete idiot.

Many thanks for your help.

ge0man
Registered User
Posts: 27
Joined: Sun Jun 05, 2005 2:39 am

Post by ge0man » Mon Aug 01, 2005 4:52 am

for some reason when I go to manually add a user to one of the paying usergroups.. it adds them then when they log in, it takes them out of the group? But if I add an ADMIN to teh group, it keeps them in the group. Any idea?

Americas Reject
Registered User
Posts: 126
Joined: Thu Jan 13, 2005 3:24 am

Post by Americas Reject » Mon Aug 01, 2005 5:25 am

HI, I am having trouble updating the info in the forum config. I am getting no errors, it just wont update.

sandodo
Registered User
Posts: 278
Joined: Mon Jul 19, 2004 7:13 am
Location: 11111111
Contact:

Post by sandodo » Tue Aug 02, 2005 2:19 am

ge0man wrote: for some reason when I go to manually add a user to one of the paying usergroups.. it adds them then when they log in, it takes them out of the group? But if I add an ADMIN to teh group, it keeps them in the group. Any idea?


if you want to add a user to that group manually, you should go to acp -> user admin -> subscription, update his membership and expiration date.

If you add him through groupcp.php, since his expiration date is not updated, then he will be removed when he login.
My site - based on PHPBB
http://www.singapurate.com

sandodo
Registered User
Posts: 278
Joined: Mon Jul 19, 2004 7:13 am
Location: 11111111
Contact:

Post by sandodo » Tue Aug 02, 2005 2:20 am

Americas Reject wrote: HI, I am having trouble updating the info in the forum config. I am getting no errors, it just wont update.


this mod doesnot change anything related to forum configuration.
My site - based on PHPBB
http://www.singapurate.com

Americas Reject
Registered User
Posts: 126
Joined: Thu Jan 13, 2005 3:24 am

Post by Americas Reject » Tue Aug 02, 2005 4:47 am

sandodo wrote:
Americas Reject wrote:HI, I am having trouble updating the info in the forum config. I am getting no errors, it just wont update.


this mod doesnot change anything related to forum configuration.


no genral config, the things you need to update, paypal address.

sandodo
Registered User
Posts: 278
Joined: Mon Jul 19, 2004 7:13 am
Location: 11111111
Contact:

Post by sandodo » Fri Aug 05, 2005 1:26 am

Maybe you installed a MOD that conflicts with my mod, you can manually set that value via phpmyadmin. It is in phpbb_config table, paypal_b_address
My site - based on PHPBB
http://www.singapurate.com

User avatar
plumeriawd
Registered User
Posts: 57
Joined: Mon Aug 29, 2005 7:30 pm
Location: Treasure Coast
Name: Elke Hinze
Contact:

Where to set paypal email?

Post by plumeriawd » Sat Sep 03, 2005 2:31 am

Where in the admin is the setting for the paypal email address to use? I can't find it to save my life.

Thanks!

megablastadmin
Registered User
Posts: 193
Joined: Tue Aug 31, 2004 9:53 am
Contact:

Post by megablastadmin » Sat Sep 03, 2005 6:54 am

that setting is in the CONFIGURATION under the GENERAL ADMIN head..


Thanks

User avatar
plumeriawd
Registered User
Posts: 57
Joined: Mon Aug 29, 2005 7:30 pm
Location: Treasure Coast
Name: Elke Hinze
Contact:

Post by plumeriawd » Sat Sep 03, 2005 7:42 am

I thought that's where it was. I figured out my problem. Last night, I had to copy some old template files over and I overwrote the changes I had made to the board_config_body.tpl.

crownroyal
I've Been Banned!
Posts: 187
Joined: Fri Mar 18, 2005 12:35 am

Can someone please create a TOTAL for the [b]ipn log[/b] in

Post by crownroyal » Sun Oct 02, 2005 6:35 am

Can someone please create a TOTAL for the ipn log in the subscription mod 1.0.3. Just to show a total of $ money at the bottom of the column ?

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Sun Oct 02, 2005 8:36 am

Hello,

Could you please change your MODs version number as outlined in MOD Development forum rules section 2. Your MOD as being in development requires a development version number as stated in the phpBB versioning scheme.

For example if your MOD is currently displaying v1.0.0, you can change it to 0.1.0 or 1.1.0, depending on your feelings of it's development status. Even minor version numbers (y of x.y.z) are reserved for release versions. If you believe your MOD is of a quality that deserves a release version, please do not hesitate to submit your MOD to the phpBB.com MODDB (MOD release database) for validation pending release.

Thank you,
The phpBB MOD Team

sat0ri
Registered User
Posts: 4
Joined: Fri Oct 07, 2005 4:00 pm

Post by sat0ri » Tue Oct 25, 2005 1:53 am

Great project sandodo, the group-based IPN idea is much appreciated!

Any chance of a rundown on the current, and remaining bugs in this mod?

I'm doing a big move from another forum software, and now would be the right time to build something like this in.

Cheers.

bcs10
Registered User
Posts: 1525
Joined: Mon Jul 14, 2003 4:45 am
Location: Chicago, IL

Post by bcs10 » Tue Dec 13, 2005 4:15 am

does this work with 2.0.18
/DD

User avatar
okada1314
Registered User
Posts: 209
Joined: Sat Oct 29, 2005 10:51 am

Post by okada1314 » Tue Dec 13, 2005 4:27 am

sorry
the download is dead!!! :cry:

Post Reply

Return to “[2.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 23 guests