[MODDB]Categories hierarchy - sub-forums v2.1.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
javispedro
Registered User
Posts: 58
Joined: Thu Apr 22, 2004 7:34 pm

Post by javispedro » Wed Jan 05, 2005 5:32 pm

I have two related questions
-Is there an easy way to check if a forum_id is subforum of other_forum_id? Does CH mod do this in a place I can see it?
-How can I enhace who is online panel (the one on index.php) so I can view also who is online in the subforum from current forum_id?

ludedude
Registered User
Posts: 229
Joined: Fri Dec 12, 2003 9:24 pm
Location: Nova Scotia, Canada

Post by ludedude » Wed Jan 05, 2005 5:45 pm

I'll all fixed up with the registered users group now...whew! Many thanks to Hater for his help last night, it was greatly appreciated. I screwed my database up somewhere along the lines of installing/creating this MOd on a new 2.0.11 install but pulling my modded DB into it.

I still have some issues to fix up...but they're more cosmetic/preference orientated now.

I changed the laguage file...so now it reads "restricted access" but still the posts show 0 posts 0 views.....how do I get those to display the actuals

Is there a way to have the "view next topic" not be forum specific, but pull in all forums that have unread messages?

I have moved the:

View unread posts
View your posts
View unanswered posts

to the overall header...and put:
View unread posts

into the bottom of viewtopic:

View previous topic :: View next topic
Watch this topic for replies
Add To Favorites
View unread posts

This was in repsonse to users on how they would like to log in and "catch" up on threads. Now they can select the view unread...read the first one...when they finish reading they're at the bottom of the page...the new keep unread is right there...so they're redireted back to select the next one.

Can the view next topic be changed so it pulls up the next unread thread regardless of what forum it's in?
Ptirhiik - RPGnet-fr wrote: > ludelude : what have you got in the config table for the group_* entries as config_value ? (use phpMyadmin to see the content).

White Dust
Registered User
Posts: 396
Joined: Thu Mar 07, 2002 10:51 pm
Location: Sigel: The City of Doors

Post by White Dust » Wed Jan 05, 2005 7:18 pm

Hater wrote: However, logically speaking it does not make sense to remove the category name, since this entire modification revolves around the ability to have sub categories and sub forums. Removing a category from the tree could potentially hinder navigation for your users that are looking only to view a specific category. The crumb trail is meant to be a logical track of how deep you are into a website. Removing a step means you've broken the logical navigation, and although I respect your preferences and opinions, I believe that from a users perspective the category should remain.


Wel, ehm, I see your point, but I dont see the category is a step, more like a general discription of the forums.

But I wil check it :)

User avatar
Hater
Registered User
Posts: 570
Joined: Tue May 06, 2003 8:56 pm
Location: Wisconsin
Contact:

Post by Hater » Wed Jan 05, 2005 7:21 pm

Oh I get it. Not being able to see the post and topic data is based on the permissions of the forum. Basically what would work better is if you could hide the forum entirely if you don't want them to be able to access that forum. I think that what is happening is exactly what should happen, if they can see the link to the forum but you do not want them to see its contents, it will return 0 and display 0. If you would rather them not have any access, don't let them see it to begin with. :D

encryption
Registered User
Posts: 392
Joined: Tue Jul 08, 2003 2:07 pm
Contact:

Post by encryption » Wed Jan 05, 2005 7:46 pm

Ptirhiik,

I have a new problem now, suddenly, some of my moderators (not all) cannot see the option to make topics into stickies..... :?

-e-

omega13a
Registered User
Posts: 88
Joined: Wed Feb 20, 2002 11:53 pm
Location: SF Bay Area
Contact:

Post by omega13a » Wed Jan 05, 2005 7:55 pm

Ptirhiik - RPGnet-fr wrote: > omega13a : why don't you attach all your forums to the root index rather than setting a category on top ? Do you plan to add other categories at the root level ?


I may at a latter date. I'm also having a similar problem on another of my message boards that does have more then one category attached to the root index.
Last edited by omega13a on Thu Jan 06, 2005 12:59 am, edited 1 time in total.
A fish without a bicycle cannot contemplate his navel.

the_bunny
Registered User
Posts: 194
Joined: Wed Oct 29, 2003 9:44 am
Location: Germany
Contact:

Post by the_bunny » Wed Jan 05, 2005 8:12 pm

@ GilGraf: thanx for ur hard work! will check out the updated package. :)
i'm, just a little bunny! please treat me well...

encryption
Registered User
Posts: 392
Joined: Tue Jul 08, 2003 2:07 pm
Contact:

Post by encryption » Wed Jan 05, 2005 8:21 pm

@ Ptirhiik

this error has gotten very weird.... for some reason, seems that Members who are Moderators are also members of the REGISTERED USERS group. So the permissions of the registered users was OVER-RIDING the permissions of the moderators group.... how do I change this ?

-e-

the_bunny
Registered User
Posts: 194
Joined: Wed Oct 29, 2003 9:44 am
Location: Germany
Contact:

Post by the_bunny » Wed Jan 05, 2005 8:57 pm

@ GilGraf: the downloadlink seems to be dead... :(
The web site you have requested doesn't exist.
The associated domain name has been reserved by a GANDI customer and parked as unused.
i'm, just a little bunny! please treat me well...

the_bunny
Registered User
Posts: 194
Joined: Wed Oct 29, 2003 9:44 am
Location: Germany
Contact:

Post by the_bunny » Wed Jan 05, 2005 9:04 pm

encryption wrote: Ptirhiik,

I have a new problem now, suddenly, some of my moderators (not all) cannot see the option to make topics into stickies..... :?

-e-


same problem here. my mods can't create stickies nor announcements. :?
i'm, just a little bunny! please treat me well...

encryption
Registered User
Posts: 392
Joined: Tue Jul 08, 2003 2:07 pm
Contact:

Post by encryption » Wed Jan 05, 2005 9:13 pm

well I had to make a preset for registered users anything other than read only (in my case reply / post / vote) and then moderators could go ahead and make stickies....

though funny part is, even though moderators could not make stickies, they could still make Global Announcements :?

-e-

User avatar
IPlasma
Registered User
Posts: 101
Joined: Sun Jul 04, 2004 9:36 pm
Location: Bretagne Sud (France)

Post by IPlasma » Wed Jan 05, 2005 9:23 pm

the_bunny wrote: @ GilGraf: the downloadlink seems to be dead... :(
The web site you have requested doesn't exist.
The associated domain name has been reserved by a GANDI customer and parked as unused.


I think there is a problem with the site , i 'm used to visit this board regularly and i can't access now . The better is to try later, tomorrow i think its more than 10 pm in France

User avatar
Hater
Registered User
Posts: 570
Joined: Tue May 06, 2003 8:56 pm
Location: Wisconsin
Contact:

Post by Hater » Wed Jan 05, 2005 9:29 pm

encryption, EVERYONE on your board that is an an active, registered user, should be part of the registered users group. This is basically so that the MOD can easily distringuish inactive and NON-registered users (to be used later by other modifications, such as user-bot, etc...)

So, your admins and moderators SHOULD indeed be in the registered group as well. If they are not, they would not only NOT be registered, they can't moderate if they are not registered first. ;)

As far as the problem with them not being able to make stickies, there is a preset in the moderator auths that allows them to make them or not. Updating or exporting that preset auth will not update the moderators settings in all forums, changing a preset will turn that groups auths in every other forum to custom, since that is what they become at that point.

It is a simple matter of altering the moderator preset to include the ability to create stickies and announcements, exporting the preset, and changing the preset auths in the forums from custom to moderate for the Moderators group.

User avatar
Fant00m
Registered User
Posts: 29
Joined: Sun Jan 02, 2005 6:15 pm
Contact:

Post by Fant00m » Wed Jan 05, 2005 9:34 pm

After installing phpbb 2.0.11 and installing ezportal and easymod i tried to install CH2.1.0. Unfortunately this didn't work.

Then i read the part about ch211dev. I Thought i give it a try. So i copied all the files in in the package over my current (working) phpbb 2.0.11.

After that i tried to run /install_cat/install.php and i got the following error: :cry:
Critical Error!
message_die() was called multiple times.

--------------------------------------------------------------------------------
Error #1
SQL requests not achieved

Line : 484
File : /data/members/paid/n/m/nmis.nl/htdocs/www/forum/includes/class_config.php
SQL : SELECT config_name, config_value FROM phpbb_config WHERE config_static <> 1

--------------------------------------------------------------------------------

Error #2
Could not obtain lastvisit data from user table

Line : 78
File : /data/members/paid/n/m/nmis.nl/htdocs/www/forum/includes/sessions.php
SQL : SELECT u.*, g.* FROM phpbb_users u LEFT JOIN phpbb_groups g ON g.group_user_id = u.user_id WHERE user_id = -1

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
Please, contact the webmaster. Thank you.
--------------------------------------------------------------------------------


Please help to solve this problem. I'm really just beginning with PHP and this is too hard for me, but as you can guess our board does need the CH mod.

Thanks for your help.

White Dust
Registered User
Posts: 396
Joined: Thu Mar 07, 2002 10:51 pm
Location: Sigel: The City of Doors

Post by White Dust » Wed Jan 05, 2005 9:52 pm

Fant00m wrote: *cut*


easymod hasnt placed the SQL table. Yoell need to go in to phpmyadmin and copy/past the SQL commands in the modfile manualy.
I had the same problem ;)

Locked

Return to “[2.0.x] MODs in Development”