[ABD] Forum AI v0.2.0

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
jk1
Registered User
Posts: 103
Joined: Sun Jul 21, 2002 10:55 pm
Location: USA

2.0.4 report

Post by jk1 »

Just a note.

I had this bot running fine on a 2.0.3 board.

I downloaded the "Changed Files" version of 2.0.4, reapplied the ForumAI mod to the 4 required files and uploaded everything to my site.

Seems to be running perfectly.
zemaj
Registered User
Posts: 267
Joined: Thu Mar 07, 2002 3:58 am
Location: Australia
Contact:

Re: 2.0.4 report

Post by zemaj »

jk1 wrote: Just a note.

I had this bot running fine on a 2.0.3 board.

I downloaded the "Changed Files" version of 2.0.4, reapplied the ForumAI mod to the 4 required files and uploaded everything to my site.

Seems to be running perfectly.


Thanks.

-zemaj
Xiph3r
Registered User
Posts: 342
Joined: Sun Oct 27, 2002 8:21 pm
Location: the wired
Contact:

Post by Xiph3r »

just curious on how soon til the realase of your famous mod to work with subforums :)
henry_s
Registered User
Posts: 144
Joined: Sat May 18, 2002 7:20 pm
Location: London, UK
Contact:

Post by henry_s »

Hi,

I am using the integration with chatbox, most of the stuff in the install file was already in there (exactly the same, with the IAI stuff). I uploaded all the files, and I'm getting a load of errors on the chat-box. It's all working fine, except for these god damm errors. The BOT still responds to chat, etc, just the errors.

Code: Select all

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1499

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1596

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site148/web/sto/mods/iai/includes/iai_functions.php on line 1702
Henry
henry_s
Registered User
Posts: 144
Joined: Sat May 18, 2002 7:20 pm
Location: London, UK
Contact:

Post by henry_s »

Oh, and the address to download the zips from seems to be down.
Henry
LifeIsPain
Former Team Member
Posts: 2148
Joined: Tue Oct 01, 2002 7:04 am
Location: Way Way Behind

Post by LifeIsPain »

http://sourceforge.net/projects/iai/

Download files thanks to our friends at SourceForge

[offtopic]@SF.net we love you guys[/offtopic]
LifeIsPain - one who needs to be smackedLife is pain, highness! Anyone who says differently is selling something.
zemaj
Registered User
Posts: 267
Joined: Thu Mar 07, 2002 3:58 am
Location: Australia
Contact:

Post by zemaj »

henry_s wrote: Hi,

I am using the integration with chatbox, most of the stuff in the install file was already in there (exactly the same, with the IAI stuff). I uploaded all the files, and I'm getting a load of errors on the chat-box. It's all working fine, except for these god damm errors. The BOT still responds to chat, etc, just the errors.


Hmmm... I think there's a more recent version of the chatbox out now, so it might not work. Check the version you downloaded against the version I put on the intergration mod.

-zemaj
henry_s
Registered User
Posts: 144
Joined: Sat May 18, 2002 7:20 pm
Location: London, UK
Contact:

Post by henry_s »

hmm, your docs say install for 1.18, but I of course, would have 1.19e :roll:
Henry
The Pelican
Registered User
Posts: 2176
Joined: Tue Jun 18, 2002 9:50 am
Location: Home is where the heart is (which happens to be in the Netherlands)
Contact:

Post by The Pelican »

henry_s wrote: hmm, your docs say install for 1.18, but I of course, would have 1.19e :roll:


What am I missing here?

I thought the IAI was still on version 0.2 (like the topic titel tell's me)...
What have I missed :roll:
The Pelican :)
Knowledge Base || No PM support and no MSN or E-mail support || Asking Questions The Smart Way (and use the template)
zemaj
Registered User
Posts: 267
Joined: Thu Mar 07, 2002 3:58 am
Location: Australia
Contact:

Post by zemaj »

The Pelican wrote:
henry_s wrote:hmm, your docs say install for 1.18, but I of course, would have 1.19e :roll:


What am I missing here?

I thought the IAI was still on version 0.2 (like the topic titel tell's me)...
What have I missed :roll:


He's talking about the chatbox mod.

-zemaj
FireFalcon
Registered User
Posts: 22
Joined: Tue Sep 24, 2002 7:06 pm
Location: Germany
Contact:

Post by FireFalcon »

I have similar problems with Smartors vhatbox mod. I started a complete new 2.0.4 board from scratch with the 1.19g version of the chatbox. In my installation file there also was a lot of code already entered.
However the AI wont respond at all, neither does she at the chat page (phpbb2/leviathan/index.html) i get a error window saying:

function+build+as+empty+string

The Chatbox doesnt return any errors, it works fine except the deadness of the bot. On the forum she works like she should.
I checked the code a few times, but i cant seem to find the error, any ideas ?

little update: i'm building and running this new board locally on my machine over xitami with newest mysql and php, could this cause the problem ?
crimeSTAR
Registered User
Posts: 4
Joined: Wed Jan 22, 2003 10:02 pm
Contact:

Post by crimeSTAR »

I installed about 40-50 AIMl founds that i found on the link one of you provided. I was wondering if anyone knows what these AIML files do? Do they make a difference in the forums? Anyone know where I can find more AIMl files that are compatible with phpbb? Thanks.
The Pelican
Registered User
Posts: 2176
Joined: Tue Jun 18, 2002 9:50 am
Location: Home is where the heart is (which happens to be in the Netherlands)
Contact:

Post by The Pelican »

crimeSTAR wrote: I was wondering if anyone knows what these AIML files do?


These files give the IAI more paterns to respond to. It makes it, so to speak, more intelligent.
The Pelican :)
Knowledge Base || No PM support and no MSN or E-mail support || Asking Questions The Smart Way (and use the template)
zemaj
Registered User
Posts: 267
Joined: Thu Mar 07, 2002 3:58 am
Location: Australia
Contact:

Post by zemaj »

FireFalcon wrote: I have similar problems with Smartors vhatbox mod. I started a complete new 2.0.4 board from scratch with the 1.19g version of the chatbox. In my installation file there also was a lot of code already entered.
However the AI wont respond at all, neither does she at the chat page (phpbb2/leviathan/index.html) i get a error window saying:

function+build+as+empty+string

The Chatbox doesnt return any errors, it works fine except the deadness of the bot. On the forum she works like she should.
I checked the code a few times, but i cant seem to find the error, any ideas ?

little update: i'm building and running this new board locally on my machine over xitami with newest mysql and php, could this cause the problem ?


Post a link - I can figure it out better that way.

crimeSTAR: what The Pelican said. Also I don't know of any other extensive collection of AIML files. I believe that those 40-50 are about all your going to find anywhere. I'd be happy for someone to prove me wrong, but I've found no other files in my search - reasonable sized (i.e. more than a few entries) ones anyway.

-zemaj
crimeSTAR
Registered User
Posts: 4
Joined: Wed Jan 22, 2003 10:02 pm
Contact:

Post by crimeSTAR »

Ok, thanks for informing me. I've had the bot up and running for about two days now and it seems to be getting smarter with every post. It is having trouble replying when someone uses the "quote" tags.
Locked

Return to “[2.0.x] MODs in Development”