[ABD] WYSIWYG Rich Text Editor for Post and Private Message

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
dESiLVer
Registered User
Posts: 50
Joined: Wed May 04, 2005 9:26 pm
Location: Turkey
Contact:

Post by dESiLVer » Fri Aug 05, 2005 9:35 pm

coreissue wrote:


Mine runs clean. No issues. 2.0.17 and modded, includeing CH 2.1.0.


what is your web address ?

User avatar
Cronz
Registered User
Posts: 69
Joined: Mon Jan 10, 2005 2:06 am

Post by Cronz » Fri Aug 05, 2005 9:50 pm

nice mod

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 12:45 am

dESiLVer wrote:
coreissue wrote:


Mine runs clean. No issues. 2.0.17 and modded, includeing CH 2.1.0.


what is your web address ?

The forum is here.

http://www.christiantalkzone.net/forum/

A sample of one type of copy and paste document with some complexity to it we use is here:

http://www.christiantalkzone.net/forum/ ... php?t=1768

You can skip through the posts and see how web pages with pics and other formats in them copy over.

Plus you have a choice between HotEditor and BBCode Box editor.

Not saying HotEditor is best. But I am saying it is currently the only game in town.

Plus it does a nice organizing job of smilies, which are important on our site.

But you have to mod it in right or will not run correctly.

dESiLVer
Registered User
Posts: 50
Joined: Wed May 04, 2005 9:26 pm
Location: Turkey
Contact:

Post by dESiLVer » Sat Aug 06, 2005 3:26 pm

demo account available ? or forum for guest (reply, new topic)

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 3:36 pm

dESiLVer wrote: demo account available ? or forum for guest (reply, new topic)

Sorry, but no.

CTZ is a discussion and debate board. We have no mods or such to demo.

And allowing guest posting has only proven to allow spammers and cults to attack us. So anonymous posting just doesn't work.

Just create an account, see what you need to see, and then pm me to delete the account. No problem doing that.

Sorry. Best I can offer. :D

dESiLVer
Registered User
Posts: 50
Joined: Wed May 04, 2005 9:26 pm
Location: Turkey
Contact:

Post by dESiLVer » Sat Aug 06, 2005 5:20 pm

coreissue wrote:


Mine runs clean. No issues. 2.0.17 and modded, includeing CH 2.1.0.


coreissue your forums same css bug existent ...

http://www.christiantalkzone.net/forum/ ... =7528#7528

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 6:10 pm

I have to look in by DB to see what you posted.

Whatever it was it wasn't good for that topic.

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 6:20 pm

Here is what you tested and how HotEditor stores it.
#ed_op#DIV#ed_cl##ed_op#LINK href="style.css" type=text/css rel=stylesheet#ed_cl# #ed_op#STYLE type=text/css#ed_cl#BODY { SCROLLBAR-FACE-COLOR: #000000; SCROLLBAR-HIGHLIGHT-COLOR: #000000; SCROLLBAR-SHADOW-COLOR: darkgray; SCROLLBAR-3DLIGHT-COLOR: #000000; SCROLLBAR-ARROW-COLOR: #000000; SCROLLBAR-TRACK-COLOR: gray; SCROLLBAR-DARKSHADOW-COLOR: #000000}A:link { COLOR: darkblue; TEXT-DECORATION: none}A:visited { COLOR: #000000; TEXT-DECORATION: none}A:hover { COLOR: #000000}body, td, th { color: #000000;}table, p, td, tr{ visibility:hidden;}body { background-color: #000000; background-image: url('http://img194.imageshack.us/img194/1236 ... /DIV#ed_cl#


Yeesh! Why did you not use the Test it Here forum instead of a topic forum?

Did you test anywhere else? I have to delete that from the DB.

I will look closer at what you posted when I get it converted to html.

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 6:44 pm

I don't know how to help you.

But I put your code in a file on my server and looks identical to what came up on my site and in your pic on this topic.

So it looks to me like it is doing what it was written to do.

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 6:52 pm

One more comment.

I am not a script writer so I won't even try to analyse your script. Others can do that far better.

But I looked at the image here:

http://img194.imageshack.us/img194/1236/tech9dx.gif

It appears your script is not presenting it the way you want it to.

I am sure you are better at this than I am. Just trying to help if possible.

I will delete your membership now.

dESiLVer
Registered User
Posts: 50
Joined: Wed May 04, 2005 9:26 pm
Location: Turkey
Contact:

Post by dESiLVer » Sat Aug 06, 2005 7:38 pm

I only hoteditor css bug to be tell to want. another intention nonexistent.

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Sat Aug 06, 2005 7:54 pm

Sorry if I came across negative. Didn't mean to.

All I am saying is that it displayed exactly the same as it does if you put the script in an independent html file on the server.

It overwhelms the page with size and such.

Why? I do not know.

But I do know that scripts we copy over have css in them and they show just fine. Here is an extract from a defintion header to see if it helps make sense of any of your issues.

Code: Select all

  <link rel="stylesheet" type="text/css" href="http://media.salemwebnetwork.com/cw/crosswalk_standard.css">
  <link rel="stylesheet" type="text/css" href="http://media.salemwebnetwork.com/cw/red_letter.css">
If you ever put HotEditor on a test board again try copying in a few scripts from pages, defintions and such. Might help resolve this. Might not.

Sorry I cannot help you more. I just don't know enough. :D

celvin
Registered User
Posts: 1
Joined: Tue Aug 09, 2005 10:44 pm

Re: [BETA] WYSIWYG Rich Text Editor for Post and Private Mes

Post by celvin » Tue Aug 09, 2005 10:48 pm

eCardMax.com wrote:
##############################################
## MOD Title: WYSIWYG - Rich Text Editor 3.0 for Post and Private Message
## MOD Author: Jimbo Hong http://www.HotEditor.com
## MOD Description: Format your post or private message like you working with FrontPage
##
## MOD Version: 3.0
##
## Installation Level: Intermediate
## Installation Time: ~20 minutes
##
EVERYTHING works fine- except of:

How can I change the possible size of picture uploads?
Currently it´s 300 x 300 px and 50000 bytes.

I need more!!

Could you or anyone from here helf PLEASE!
(I cannot start the forum until than :()

THANK YOU!

coreissue
Registered User
Posts: 97
Joined: Tue Feb 24, 2004 8:27 pm
Contact:

Post by coreissue » Wed Aug 10, 2005 12:28 am

EVERYTHING works fine- except of:

How can I change the possible size of picture uploads?
Currently it´s 300 x 300 px and 50000 bytes.

I need more!!

Could you or anyone from here helf PLEASE!
(I cannot start the forum until than )

I believe it is in
richedit/show_it.php

$max_size = 50000; # bytes

ngminhtrung
Registered User
Posts: 2
Joined: Wed Aug 10, 2005 3:49 pm

Post by ngminhtrung » Mon Aug 22, 2005 1:23 pm

Tks you for this nice mod, but I have a problem when install it in my forum phpBB 2.0.17. Sorry, my English is too bad, so I can't describe what my problem is, but I had captured my forum. I hope that you can understand. Please show me how to solve it, tks avance.

Image
Click to enlarge

Locked

Return to “[2.0.x] MODs in Development”