[ABD] RSS Feed 2.2.4

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
CyberTrax
Registered User
Posts: 1
Joined: Thu Dec 08, 2005 1:37 am

Re : Memory Usage Error

Post by CyberTrax »

Code: Select all

<!-- Page generation time: 0.2753s  - Memory Usage: 1.370 Mb  - GZIP disabled -->
I keep getting this error when I try mysite/rss.php on Feed Validator I cannot add this feed to FeedReader or SharpReader.


Wonder what I can do to make it work.


Peace out

deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Post by deny »

Code: Select all

script type="text/javascript" src="./templates/select_expand_bbcodes.js"></script><script type="text/javascript"> <!-- var id = 'SXBB' + (1000 + Math.floor(Math.random() * 5000)); SXBB[id] = new _SXBB(id); SXBB[id].T['select'] = 'Select'; SXBB[id].T['expand'] = 'Expand'; SXBB[id].T['contract'] = 'Contract'; SXBB[id].writeCmd(); //--> </script> </span></td> </tr> <tr> <td class="quote"><script type="text/javascript"> <!-- SXBB[id].writeDiv(); //--> </script> ! 

If someone use quote or code on my board i got every time error by RSS feed and by validating
description should not contain script tag


.
It is mod to expand, show quote, code etc...
Can be something done to prevent that this happen?

Thanks
Geolocation of any IP address including detection of hostname,
browser, country and country code with ip address range web tool.

IP Address Locator | Email Tracking | IP Address | Check Email

alphafi
Registered User
Posts: 9
Joined: Mon Oct 17, 2005 10:19 am

Post by alphafi »

Is anyone caching the rss file?

I've set cache to true in the config file and directory the default cache/ director.

The directory has 777 permission.

The cache file rss_feed.xml is created but it's not updated after it's creation. The weird part is that the actual outup from rss.php still seems to be generated on the fly.

Any ideas?

dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

The thing is this mod only cache guests queries, so if you are logged you won't see it working.
Then, you have to define how long should the cache last in time.

As a cache file was created, I think it is working.

To test it, go guest and clear your brownsers cache on each try as the mod also checks the brownser's cache before it start to do anything (so that you'd only see you brownser's cached version if not).

++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS

alphafi
Registered User
Posts: 9
Joined: Mon Oct 17, 2005 10:19 am

Post by alphafi »

It was probably because I was logged in that didn't seem to update however now I've logged out.

I get this error:

XML Parsing Error: junk after document element
Location: http://www.mydomain.com/forum/rss.php
Line Number 2, Column 1:<b>Warning</b>: readfile() has been disabled for security reasons in <b>/home/domain/public_html/forum/rss.php</b> on line <b>168</b><br />
^

dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

alphafi wrote: It was probably because I was logged in that didn't seem to update however now I've logged out.

I get this error:

XML Parsing Error: junk after document element
Location: http://www.mydomain.com/forum/rss.php
Line Number 2, Column 1:<b>Warning</b>: readfile() has been disabled for security reasons in <b>/home/domain/public_html/forum/rss.php</b> on line <b>168</b><br />
^


Looks like your hoster does not allow you to use readfile(). So unless you manage to have enough rights to use it, disable cache, it won't work.

++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS

alphafi
Registered User
Posts: 9
Joined: Mon Oct 17, 2005 10:19 am

Post by alphafi »

It's a dedicated server.

I had a look in the cache directory and the file that's being created is owned by nobody:nobody is that right?

I'm also having another problem when not using cache. When there are new posts (i.e. when it should be updated) the RSS shows only 2-4 posts and I have to manually access rss.php and shift+reload in browser to get it back to 25 posts. Any idea why this might be happening

nilsandrey
Registered User
Posts: 7
Joined: Tue Oct 25, 2005 8:23 pm
Contact:

Approve mod & RSS

Post by nilsandrey »

Hi,
I have installed the Approve_Mod (Approve_Mod 1.0.10 Released: April 12, 2005), but when install RSS then all messages are exported, not only the approved ones. I cleary understand why this is happening, all I want to known is if there is any programmed integration between this two mods?

andrew,
Admin of http://www.vanguardia.co.cu/foros

chyduskam
Registered User
Posts: 110
Joined: Thu Oct 28, 2004 9:33 am
Location: Saint Petersburg, Russia
Contact:

Post by chyduskam »

1. Now I working about new powerful version, with CommentAPI, HTTP AM head support, Atom 1.0 and so on
Now I was change a lot of code and after short time this mod will be tested on oficial Russian support phpBB forum - phpbbguru.net.

Small fix for current version Atom 0.3->Atom 1.0. In next version it will be more correct, but that version is vaild.
atom_body.tpl

Code: Select all

<?xml version="1.0" encoding="{S_CONTENT_ENCODING}" ?>
<feed xmlns="http://www.w3.org/2005/Atom">
<!--
   This feed generated for {READER}
   More info at http://naklon.info/rss/about.htm
-->
<id>{BOARD_URL}</id>
<title>{BOARD_TITLE}</title>
<subtitle>{BOARD_DESCRIPTION}</subtitle>
<generator>{PROGRAM}</generator>
<link rel="alternate" type="text/html" href="{BOARD_URL}"/>
<link rel="self" type="text/html" href="{BOARD_URL}rss.php?atom"/>
<updated>{ATOM_BUILD_DATE}</updated>
<!-- BEGIN post_item -->
<entry>
   <title>{post_item.FORUM_NAME} :: {post_item.TOPIC_TITLE}</title>
   <link rel="alternate" type="text/html" href="{post_item.POST_URL}"/>
   <author>
      <name>{post_item.AUTHOR0}</name>
   </author>
   <id>{post_item.POST_URL}</id>
   <published>{post_item.ATOM_TIME}</published>
   <updated>{post_item.ATOM_TIME_M}</updated>
   <content type="html">{L_AUTHOR}: {post_item.AUTHOR}<br />
   {post_item.POST_SUBJECT}{L_POSTED}: {post_item.POST_TIME}<br /><br /><span class="postbody">
   {post_item.POST_TEXT}{post_item.USER_SIG}</span><br />
   </content>
</entry>
<!-- END post_item -->
</feed> 


nilsandrey
This mod doesn't support Approve_Mod now.

alphafi
a) Use key nolimit in GET string. See manual.

chyduskam
Registered User
Posts: 110
Joined: Thu Oct 28, 2004 9:33 am
Location: Saint Petersburg, Russia
Contact:

Re: Approve mod & RSS

Post by chyduskam »

nilsandrey wrote: Hi,
I have installed the Approve_Mod (Approve_Mod 1.0.10 Released: April 12, 2005),


As I see this mod not supported now, so I'll not interesting to support that mod in RSS Feed mod

simonlam
Registered User
Posts: 25
Joined: Fri Sep 16, 2005 2:19 pm

Viewing all topics by guest where guest is not allowed to

Post by simonlam »

I have been trying to get this mod to work for days and i still couldn't get it works properly. I look through the post from 1-22 and still couldn't find any solution. I use a rss reader and import the link (http://my_ip_address/phpbb/rss.php) . I log off from the browser, so I should be a guest. I set the board where guest could not view a single forum and this works in the browser. But when I use the rss reader, it published all the private forum topics without any authentication. Isn't it should be no feeds at all for guest? I type the url(http://my_ip_address/phpbb/rss.php) directly into the addresss bar and I get the feed generated for Anonymous showing everything forum and topics. But I have already prohibited the user from viewing any forum, this works in the browser. How come?

Another case is I have 2 groups of people, A and B. A users can't view B forums and vice versa. This works ok in the browser. But when I use the reader/feeder with url as above, I get all the forum topics no matter I use which user. Please help, do you know what I have done wrong or miss out something?

FYI, I use the latest phpbb, CH and this mod. I see some people said it works on their board. Thanks

User avatar
MarkDHamill
Registered User
Posts: 4022
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Post by MarkDHamill »

I created a somewhat different mod that is now out for Alpha testing, but supports RSS 0.91, RSS 1.0, RSS 2.0 and Atom 1.0 newsfeeds. It also has pretty sophisticated logic to ensure only authenticated users can see content in protected forums.

If this mod isn't suiting your needs you may want to give it a try.

http://www.phpbb.com/phpBB/viewtopic.php?t=352785

BBDS
Registered User
Posts: 19
Joined: Tue Aug 09, 2005 10:03 am

Post by BBDS »

Hi there, i have an this little error ....
does anyone knows how to fix it ???

Code: Select all

This feed does not validate.

line 1, column 1: XML parsing error: <unknown>:1:1: xml declaration not at start of external entity [help]

<?xml version="1.0" encoding="iso-8859-1" ?>

THANKS!

candysmall
Registered User
Posts: 416
Joined: Sun Sep 12, 2004 4:58 pm
Location: Boston, MA

Post by candysmall »

I don't understand the add-ons. One is to view who is linking or viewing the feed? (I think) Where do I see that info?

gunung4
Registered User
Posts: 1
Joined: Tue Jan 24, 2006 2:26 am

Post by gunung4 »

I'm new to RSS Feed & PHP..
I have 2 question:

1) How to change the link for "read more" found at the bottom of the RSS.

2) How to change the style for the headline? I do not want to display the forum title name with the headline.

Thx for any help.

Locked

Return to “[2.0.x] MODs in Development”