[BETA] Smiley management

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Peter77sx
Registered User
Posts: 3260
Joined: Wed Nov 09, 2005 2:51 pm

Post by Peter77sx »

I've pretty much never used IE 6 and just recently installed IE 7. is there a way to make the smiley box less bulky in IE7? I tried inserting toolbar=no,titlebar=no,menubar=no,location=no, with no luck... I see a statuse bar at the bottom and some kind of address bar at the top.

any suggestions?
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

Has anybody out there had this issue when trying to import a pak?
I tried to import the gears smilie pak from this site:
Couldn't add smiley 1 - gear_grin.gif to the table
Couldn't add smiley 2 - gear_grin.gif to the table
Couldn't add smiley 3 - gear_happy2.gif to the table
Couldn't add smiley 4 - gear_happy2.gif to the table
Couldn't add smiley 5 - gear_sad2.gif to the table
Couldn't add smiley 6 - gear_sad2.gif to the table
Couldn't add smiley 7 - gear_oh2.gif to the table
Couldn't add smiley 8 - gear_oh2.gif to the table
Couldn't add smiley 9 - gear_diagonal.gif to the table
Couldn't add smiley 10 - gear_huh2.gif to the table
Couldn't add smiley 11 - gear_huh2.gif to the table
Couldn't add smiley 12 - gear_cool2.gif to the table
Couldn't add smiley 13 - gear_cool2.gif to the table
Couldn't add smiley 14 - gear_lol2.gif to the table
Couldn't add smiley 15 - gear_angry.gif to the table
Couldn't add smiley 16 - gear_angry.gif to the table
Couldn't add smiley 17 - gear_tounge.gif to the table
Couldn't add smiley 18 - gear_tounge.gif to the table
Couldn't add smiley 19 - gear_oh2.gif to the table
Couldn't add smiley 20 - gear_cry2.gif to the table
Couldn't add smiley 21 - gear_evil.gif to the table
Couldn't add smiley 22 - gear_evil.gif to the table
Couldn't add smiley 23 - gear_roll.gif to the table
Couldn't add smiley 24 - gear_wink2.gif to the table
Couldn't add smiley 25 - gear_wink2.gif to the table
Couldn't add smiley 26 - gear_wink2.gif to the table
Couldn't add smiley 27 - gear_diagonal.gif to the table
Couldn't add smiley 28 - gear_huh2.gif to the table
Couldn't add smiley 29 - gear_puke.gif to the table
Couldn't add smiley 30 - gear_puke.gif to the table
Couldn't add smiley 31 - gear_nonplussed.gif to the table
Couldn't add smiley 32 - gear_nonplussed.gif to the table
Couldn't add smiley 33 - gear_nonplussed.gif to the table

All other smileys have been imported successfully.
Total smileys in PAK file : 33

You can edit the PAK file and try again into a new page, or
add the failed smileys manually.


Here's a copy/paste from the pak file:

Code: Select all

gear_grin.gif=+:Very Happy=+::D
gear_grin.gif=+:Very Happy=+::-D
gear_happy2.gif=+:Smile=+::)
gear_happy2.gif=+:Smile=+::-)
gear_sad2.gif=+:Sad=+::(
gear_sad2.gif=+:Sad=+::-(
gear_oh2.gif=+:Surprised=+::o
gear_oh2.gif=+:Surprised=+::-o
gear_diagonal.gif=+:Hrm=+::/
gear_huh2.gif=+:Confused=+::?
gear_huh2.gif=+:Confused=+::-?
gear_cool2.gif=+:Cool=+:8)
gear_cool2.gif=+:Cool=+:8-)
gear_lol2.gif=+:Laughing=+::lol:
gear_angry.gif=+:Mad=+::x
gear_angry.gif=+:Mad=+::-x
gear_tounge.gif=+:Razz=+::P
gear_tounge.gif=+:Razz=+::-P
gear_oh2.gif=+:Embarassed=+::oops:
gear_cry2.gif=+:Crying or Very sad=+::cry:
gear_evil.gif=+:Evil or Very Mad=+::evil:
gear_evil.gif=+:Twisted Evil=+::twisted:
gear_roll.gif=+:Rolling Eyes=+::roll:
gear_wink2.gif=+:Wink=+::wink:
gear_wink2.gif=+:Wink=+:;)
gear_wink2.gif=+:Wink=+:;-)
gear_diagonal.gif=+:Hrm=+::-/
gear_huh2.gif=+:Question=+::?:
gear_puke.gif=+:Yuck=+::yuck:
gear_puke.gif=+:Puke=+::puke:
gear_nonplussed.gif=+:Neutral=+::|
gear_nonplussed.gif=+:Neutral=+::-|
gear_nonplussed.gif=+:Neutral=+::neutral:
any ideas?

www.rig-talk.com
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

bump
Merlin Sythove
Registered User
Posts: 2339
Joined: Tue Mar 16, 2004 7:42 am

Post by Merlin Sythove »

No, I've never had any reports about this feature not working.
The PAK file as you pasted it here, is fine.
You should look at the code of admin/admin_smilies.php and find the error message, about line 420 where it says

Code: Select all

              $sql = "INSERT INTO " . SMILIES_TABLE . " VALUES (" . $new_smile_data . ");";
After this, add one line

Code: Select all

echo $sql . '<br />';
to inspect the SQL statement that is used, and that fails to execute. I expect either you have not defined SMILIES_TABLE (in includes/constants.php) or you have forgotten to make the whole table.
Need custom work done? Pimp My Forum!
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

Thanks, I'll double check that! I'll let you know what I find out.
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

Here's the returned code:

Code: Select all

INSERT INTO phpbb_smilies VALUES ('',':D','gear_grin.gif','Very Happy','15','1','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-D','gear_grin.gif','Very Happy','15','2','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':)','gear_happy2.gif','Smile','15','3','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-)','gear_happy2.gif','Smile','15','4','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':(','gear_sad2.gif','Sad','15','5','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-(','gear_sad2.gif','Sad','15','6','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':o','gear_oh2.gif','Surprised','15','7','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-o','gear_oh2.gif','Surprised','15','8','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':/','gear_diagonal.gif','Hrm','15','9','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':?','gear_huh2.gif','Confused','15','10','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-?','gear_huh2.gif','Confused','15','11','1','0','0');
INSERT INTO phpbb_smilies VALUES ('','8)','gear_cool2.gif','Cool','15','12','1','0','0');
INSERT INTO phpbb_smilies VALUES ('','8-)','gear_cool2.gif','Cool','15','13','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':lol:','gear_lol2.gif','Laughing','15','14','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':x','gear_angry.gif','Mad','15','15','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-x','gear_angry.gif','Mad','15','16','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':P','gear_tounge.gif','Razz','15','17','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-P','gear_tounge.gif','Razz','15','18','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':oops:','gear_oh2.gif','Embarassed','15','19','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':cry:','gear_cry2.gif','Crying or Very sad','15','20','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':evil:','gear_evil.gif','Evil or Very Mad','15','21','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':twisted:','gear_evil.gif','Twisted Evil','15','22','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':roll:','gear_roll.gif','Rolling Eyes','15','23','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':wink:','gear_wink2.gif','Wink','15','24','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',';)','gear_wink2.gif','Wink','15','25','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',';-)','gear_wink2.gif','Wink','15','26','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-/','gear_diagonal.gif','Hrm','15','27','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':?:','gear_huh2.gif','Question','15','28','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':yuck:','gear_puke.gif','Yuck','15','29','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':puke:','gear_puke.gif','Puke','15','30','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':|','gear_nonplussed.gif','Neutral','15','31','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':-|','gear_nonplussed.gif','Neutral','15','32','1','0','0');
INSERT INTO phpbb_smilies VALUES ('',':neutral:','gear_nonplussed.gif','Neutral','15','33','1','0','0');
Here's what's in my constants.php:

Code: Select all

define('SMILIES_TABLE', $table_prefix.'smilies');
Here are the tables I see in mysql:
phpbb_smilies
phpbb_smilies_bak
phpbb_smilies_pages

Should I be seeing a "phpbb_smilies_table" along with those other 3?
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

I had the "smilies order" mod installed before this one if that means anything. I'll look in to that this evening.

*edit*
I forgot I uninstalled this 2 days prior :D
*/edit*
Last edited by MitchSchaft on Wed Feb 28, 2007 11:03 pm, edited 1 time in total.
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

one last bump. I can always upload manually, but that will take hours :(.
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

Yo, I uploaded manually all last week and am good to go.

One issue I have is any group of smilies I put in "moderator" access status, the moderators cannot see. I'm the only one who can see it. Any insight on this one?
MitchSchaft
Registered User
Posts: 292
Joined: Fri Jun 06, 2003 10:22 pm
Location: exiled

Post by MitchSchaft »

bump
pixpax
Registered User
Posts: 4
Joined: Fri Nov 25, 2005 6:27 pm
Location: Denmark

STRANGE problem

Post by pixpax »

I know this problem could have its root in sheer stupidity.....I have installed the MOD, go to the ACP and get this:
Image

...all the text bits are missing!! When I press the little button, with no text in the upper left window I go to another page - and it all works! I can add smiles ect., and the text bits are there!!! And the user-end works too!!

I have searched in here for at solution, but appearantly only I do those sort of things...... :oops:

I would though LOVE to be able to have the first screen working too......please help! I have been through the altered files 5 times and can't find the problem!
flameshad0w
Registered User
Posts: 12
Joined: Sun Apr 15, 2007 10:53 pm
Location: California
Contact:

Re: [BETA] Smiley management

Post by flameshad0w »

I just installed this mod and everything works except for the different smiley pages. The default page is there, but when I click on the links to other pages, nothing happens.

Sorry if this has been asked before or if it's something really obvious...
Merlin Sythove
Registered User
Posts: 2339
Joined: Tue Mar 16, 2004 7:42 am

Re: STRANGE problem

Post by Merlin Sythove »

pixpax wrote: ...all the text bits are missing!! When I press the little button, with no text in the upper left window I go to another page - and it all works! I can add smiles ect., and the text bits are there!!!


Strange, it looks like the root path is not set properly the first time, but I don't see offhand how a second time would correct that. What happens if you don't click anything but simply refresh the page? (by clicking in the left hand panel on the Smiley management link)
Need custom work done? Pimp My Forum!
Merlin Sythove
Registered User
Posts: 2339
Joined: Tue Mar 16, 2004 7:42 am

Re: [BETA] Smiley management

Post by Merlin Sythove »

flameshad0w wrote: I just installed this mod and everything works except for the different smiley pages. The default page is there, but when I click on the links to other pages, nothing happens.


Before you click on the link, hover over it. What does the link say in your browser status line?
Need custom work done? Pimp My Forum!
flameshad0w
Registered User
Posts: 12
Joined: Sun Apr 15, 2007 10:53 pm
Location: California
Contact:

Re: [BETA] Smiley management

Post by flameshad0w »

Merlin Sythove wrote:
flameshad0w wrote: I just installed this mod and everything works except for the different smiley pages. The default page is there, but when I click on the links to other pages, nothing happens.


Before you click on the link, hover over it. What does the link say in your browser status line?

http://absoluteforum.net/posting.php?mo ... ies&page=2
I also checked the URL of the page itself before and after I clicked the link, and it does change from page=1 to page=2. When I click the link to the default page it changes back to page=1, yet nothing on the pages themselves actually changes. And yes I'm sure the two pages aren't identical. :?
Post Reply

Return to “[2.0.x] MODs in Development”