Page 67 of 74

Posted: Fri Dec 29, 2006 12:54 pm
by samhale
Hi,
How do I change the email text when on the 'Invite a Friend', so it has my own description, feature list etc.

Thanks

Posted: Sat Dec 30, 2006 5:22 pm
by MentalMaze
samhale wrote: Hi,
How do I change the email text when on the 'Invite a Friend', so it has my own description, feature list etc.

Thanks


It would be easiest to add something to the email in language/lang-english/email/rp_invite_email.tpl
Otherwise you can change it in the includes/user_rp_center.php, but be careful if you chosse this method.

Posted: Wed Jan 10, 2007 9:48 am
by mattyj33
Im not sure if this has been mentioned, it probably has, but is it possible to add an individual users referral URL in their profile...so they can copy and paste it wherever they like...good for referance. Ive seen it on vbulletin..

Posted: Fri Jan 12, 2007 11:45 am
by mattyj33
Even if somebody call tell me how to pump out the appropriate referral ID when a user is logged in, that would be a start, was thinking of putting it in th e welcome panel.

Parse error: parse error, unexpected T_STRING, expecting ')'

Posted: Thu Jan 18, 2007 4:10 pm
by wallbay1
hi this is what i got when i installed the referral plus mod

Parse error: parse error, unexpected T_STRING, expecting ')' in /home/www/realtymarketcenter.com/forum/includes/page_header.php on line 403

I am new to phpbb so i don't know what to do here is the file please tell me what should i do

____________________________________________________________
Admin ID handled in ACP for contact admin link.
'U_REWARD' => append_sid('rp_list.'.$phpEx), // start- Referral Plus
'U_REWARDS' => append_sid('rp_top_rewards.'.$phpEx),

Posted: Sat Jan 20, 2007 1:13 pm
by langeweile
is there any german language file?

Re: Parse error: parse error, unexpected T_STRING, expecting

Posted: Sat Jan 20, 2007 2:03 pm
by MentalMaze
wallbay1 wrote: hi this is what i got when i installed the referral plus mod

Parse error: parse error, unexpected T_STRING, expecting ')' in /home/www/realtymarketcenter.com/forum/includes/page_header.php on line 403

I am new to phpbb so i don't know what to do here is the file please tell me what should i do

____________________________________________________________
Admin ID handled in ACP for contact admin link.
'U_REWARD' => append_sid('rp_list.'.$phpEx), // start- Referral Plus
'U_REWARDS' => append_sid('rp_top_rewards.'.$phpEx),


Remove the "Admin ID handled in ACP for contact admin link." in the quote abovre of you entered it the way you quoted it.

langeweile wrote: is there any german language file?


Sorry there is not.

dumb noob question - what exactly is the referral link?

Posted: Mon Jan 22, 2007 5:55 pm
by tacofish
never mind figured it out

Posted: Tue Jan 30, 2007 1:33 am
by abdulbasit
Hello friends,

I am new here as well as new to phpbb too!

I get these errors while installing Referral Mod through Easy MOD. Can anyone please help me out. I will be very much thankful to you guys.

Critical Error

FIND FAILED: In file [templates/subSilver/overall_header.tpl] could not find:

<tr>
<td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</span></td>
</tr>

MOD script line #1022 :: FAQ :: Report

CRITICAL ERROR: Could not modify [templates/subSilver/overall_header.tpl]

And in 1 more file

Critical Error

FIND FAILED: In file [templates/subSilver/viewtopic_body.tpl] could not find:

<td valign="middle" nowrap="nowrap">{postrow.PROFILE_IMG}

MOD script line #1093 :: FAQ :: Report

CRITICAL ERROR: Could not modify [templates/subSilver/viewtopic_body.tpl]

Posted: Wed Jan 31, 2007 10:42 am
by abdulbasit
Is there anyone to help me please :(

Posted: Sat Feb 03, 2007 2:50 pm
by MentalMaze
abdulbasit wrote: Is there anyone to help me please :(


You should try installing it manually for the the pages mentioned. It may be that with the newest version of phpBB that a change has been made to the pages in question. I have not checked this.

The first error is the links in the header and you can put them wherever you like. The second the button in viewtopic, which you should be able to place with out to much trouble.

I will look into it as soon as I have a chance.

Posted: Sun Feb 04, 2007 11:58 am
by abdulbasit
Okay Sir, i got the help from someone and he fixed the installation file but while installing through EM it gives me these errors on Step 2

2 Warning(s) reported by the SQL Parser
Non-portable syntax option(s) "TYPE=MyISAM", ignored, statement: 1, table: "phpbb_refer_plus"
Non-portable syntax option(s) "TYPE=MyISAM", ignored, statement: 3, table: "phpbb_refer_top"

Can i continue to step 3? Will my board get some problem ?

I have never run phpmyadmin and would need your complete help so that i can install it step by step.

Hope to hear from you very soon,
Thank You,
AB

Posted: Sun Feb 04, 2007 12:50 pm
by Electra736
Try this:

Code: Select all

CREATE TABLE phpbb_refer_plus (
  rp_id mediumint(8) unsigned NOT NULL auto_increment,
  refer_id varchar(7) NOT NULL default '0',
  refer_new varchar(7) NOT NULL default '0',
  rp_time varchar(10) NOT NULL default '',
  PRIMARY KEY (rp_id)
);

INSERT INTO phpbb_refer_plus VALUES (1, 2, 2, '1115859081');

CREATE TABLE phpbb_refer_top (
  rp_id mediumint(8) unsigned NOT NULL auto_increment,
  refer_id varchar(7) NOT NULL default '0',
  refer_new varchar(7) NOT NULL default '0',
  rp_time varchar(10) NOT NULL default '',
  PRIMARY KEY (rp_id)
);
TYPE=MyISAM is not needed.

Posted: Sun Feb 04, 2007 5:46 pm
by abdulbasit
Hello Electra,

I did it and it works fine. Can you please check my forum www.funwadi.com/forum where i cannot see any link on page header for Referral Center and what the hyperlink should be for that Referral Center so that every member can click and straight it changes the URL to their user ID.

Is it possible to do in overall_header.tpl file ?

Please help me as this is the last and final step.

Thanks a lot in advance,

AbdulBasit

Posted: Wed Feb 07, 2007 9:27 pm
by Joshimitsu
I get an error on the admin pages:

"View Refferal log"

Code: Select all

Sorry, but the referral plus data could not be found

DEBUG MODE

SQL Error : 1146 Table 'joshbuck_menewsha.REFER_PLUS_TABLE' doesn't exist

SELECT rp_id, refer_id, refer_new, rp_time FROM REFER_PLUS_TABLE WHERE refer_id != '-1' ORDER BY rp_id DESC

Line : 40
File : admin_rp_log.php

And
"View reward log"

Code: Select all

Sorry, but the referral plus data could not be found

DEBUG MODE

SQL Error : 1146 Table 'joshbuck_menewsha.REFER_TOP_TABLE' doesn't exist

SELECT rp_id, refer_id, refer_new, rp_time FROM REFER_TOP_TABLE WHERE refer_id != '-1' ORDER BY rp_id DESC

Line : 40
File : admin_rp_rewards_log.php

Also, the rp_center.php just redirects me to the homepage