[BETA] 0.2.0 User Control Panel for 2.0.17

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
president
Registered User
Posts: 169
Joined: Thu Apr 04, 2002 11:31 pm

Post by president » Wed Aug 17, 2005 7:33 am

ajp wrote: I understand that you have submitted it, but there is no way to just make a few changes to the code that I can then add.

If I knew enough about php I would try it, but I don't :cry:


Don't get me wrong. I'd love to put the time in if I had it :)

Unfortunatly my priorities are:

College Degree
phpBB
Work

ajp
Registered User
Posts: 158
Joined: Thu Apr 21, 2005 7:47 pm
Location: Kansas
Contact:

Post by ajp » Wed Aug 17, 2005 7:40 am

president wrote: Don't get me wrong. I'd love to put the time in if I had it :)

Unfortunatly my priorities are:

College Degree
phpBB
Work


I understand what you are saying, just my board is screaming for a control panel, and they want to use it to track subscribed threads, but they don't want to have to click an extra link everytime to subscribe. I thought about pthrick's panel but it is to bloated. I love the look and feel of your panel, I just hope that another php guy may be able to figure out the issue.

Krezno
Registered User
Posts: 73
Joined: Sat Nov 22, 2003 10:20 pm
Contact:

Post by Krezno » Fri Aug 19, 2005 10:45 am

Awesome work!

I was developing a similar MOD like this that just reorganized the editprofile page. Right now my mod just uses javascript to switch between the different sections, and I was really hopeing I could ditch the javascript for modes. Since I'm such a dummy when it comes to php I just couldn't figure out how to create the new modes and switches for usercp_register, and your code worked perfect for what I was trying to accomplish.

So I frankensteined your code from usercp_register with mine and it works great! I just had to edit it a little to get everything to work. I was wondering if I may ask permission to use that small peice of your MOD to add to mine? Of course all the credit for the original code would go to you :D

If not it's cool, I'll just keep it to myself :P


Edit: I found a small bug in usercp_register.php

Code: Select all

$s_hidden_fields .= '<input type="hidden" name="hideonline" value="' . $allowviewonline . '" />';
should be

Code: Select all

$s_hidden_fields .= '<input type="hidden" name="hideonline" value="' . !$allowviewonline . '" />';
it was missing a !

ajp
Registered User
Posts: 158
Joined: Thu Apr 21, 2005 7:47 pm
Location: Kansas
Contact:

Post by ajp » Tue Aug 23, 2005 6:19 pm

Still wondering if anyone out there can make it so that when people post to a topic they are auto subscribed to the topic.

ajp
Registered User
Posts: 158
Joined: Thu Apr 21, 2005 7:47 pm
Location: Kansas
Contact:

Post by ajp » Sat Oct 01, 2005 3:55 pm

Bump for an auto-subsribe.

Ken Kenobi
Registered User
Posts: 34
Joined: Fri Aug 12, 2005 10:17 am

Post by Ken Kenobi » Sun Oct 23, 2005 2:59 pm

president wrote:
Patrick Simmons wrote:I'm having only one problem. If someone goes into the control panel, then profile it automatically defaults the hide online status to yes, do you know where something may be wrong at. I haven't never had that problem but noticed all my members where hidden and knew it was a problem


I'd say that it would be worth going back over the instructions for includes/usercp_register.php in the install.txt file. That's more than likely where your mistake has happened.
#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_register.php


Hehe, it wasn't his mistake. Same happened to me.

Krezno, does that "!" added into the usercp_register fix this problem?

Anyways, besides that Online Status problem this works perfect.

killa99
Registered User
Posts: 63
Joined: Wed Mar 23, 2005 1:26 am

Is there any way?

Post by killa99 » Wed Nov 09, 2005 1:02 am

Is there any way to add an "Add Buddy" link to viewprofile.

Also is there any way to add the friends list on to viewprofile as well.

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Post by MHobbit » Wed Nov 09, 2005 1:23 am

Hello,

Could you please change your MODs version number as outlined in MOD Development forum rules section 2. Your MOD as being in development requires a development version number as stated in the phpBB versioning scheme.

For example if your MOD is currently displaying v1.0.0, you can change it to 0.1.0 or 1.1.0, depending on your feelings of it's development status. Even minor version numbers (y of x.y.z) are reserved for release versions. If you believe your MOD is of a quality that deserves a release version, please do not hesitate to submit your MOD to the phpBB.com MODDB (MOD release database) for validation pending release.

Thank you,
The phpBB MOD Team
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

president
Registered User
Posts: 169
Joined: Thu Apr 04, 2002 11:31 pm

Post by president » Thu Nov 10, 2005 8:35 am

back to 0.2.0 which was renamed to 1.0.0

hopefully I won't be able to complete this mod next summer which is when I get my next bout of free time.

(as hopefully 3.0 will be out)

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Post by MHobbit » Thu Nov 10, 2005 8:38 pm

Hello,

Could you please change your MODs version number as outlined in MOD Development forum rules section 2. Your MOD as being in development requires a development version number as stated in the phpBB versioning scheme.

For example if your MOD is currently displaying v1.0.0, you can change it to 0.1.0 or 1.1.0, depending on your feelings of it's development status. Even minor version numbers (y of x.y.z) are reserved for release versions. If you believe your MOD is of a quality that deserves a release version, please do not hesitate to submit your MOD to the phpBB.com MODDB (MOD release database) for validation pending release.

Thank you,
The phpBB MOD Team
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Fri Nov 11, 2005 5:07 am

Umm, MennoniteHobbit, when he says "2.0.17" he is referring to phpBB 2.0.17. However, it is confusing.

yveslebeau
Registered User
Posts: 9
Joined: Sat Jun 17, 2006 8:10 pm
Location: Cape Town / South Africa
Contact:

Problem

Post by yveslebeau » Sat Jun 17, 2006 10:43 pm

How do I fix this please ????

Critical Error

FIND FAILED: In file [templates/subSilver/profile_add_body.tpl] could not find:

<textarea name="signature"style="width: 300px" rows="6" cols="30" class="post">{SIGNATURE}</textarea>
</td>
</tr>
<tr>
<td class="catSides" colspan="2" height="28">&nbsp;</td>
</tr>

MOD script line #798 :: FAQ :: Report

gamerxgirl
Registered User
Posts: 379
Joined: Tue Feb 22, 2005 4:13 pm

Re: Problem

Post by gamerxgirl » Sat Jul 08, 2006 2:07 pm

yveslebeau wrote: How do I fix this please ????

Critical Error

FIND FAILED: In file [templates/subSilver/profile_add_body.tpl] could not find:

<textarea name="signature"style="width: 300px" rows="6" cols="30" class="post">{SIGNATURE}</textarea>
</td>
</tr>
<tr>
<td class="catSides" colspan="2" height="28">&nbsp;</td>
</tr>

MOD script line #798 :: FAQ :: Report


That just means that it could not find those exact lines in profile_add_body.tpl, another mod might have changed them, or they might be different in the phpbb version you are using.

LaHrr.S
Registered User
Posts: 7
Joined: Wed Jan 10, 2007 2:34 pm
Contact:

Post by LaHrr.S » Wed Jan 10, 2007 2:40 pm

I've installed the mod on my forum and everything seems to work fine.

I have one problem and one question.

The problem is:

http://forum.unknownprofile.net
Username: ls
Password: 123456

If you enter the User Control Panel, you can see that there is nothing there, the page is empty. Has anyone got a solution?

The question is:

When you've added someone to your buddy list, how can I make it so that the image Image won't show up anymore, or show a different image, maybe allowing you to remove the buddy.

Thank you.

/LaHrr.s

president
Registered User
Posts: 169
Joined: Thu Apr 04, 2002 11:31 pm

Post by president » Wed Jan 10, 2007 3:41 pm

LaHrr.S wrote: If you enter the User Control Panel, you can see that there is nothing there, the page is empty. Has anyone got a solution?


The User CP is there.

When you click on profile, your profile doesn't show up. Maybe you added the changes to the profile files incorrectly?

but with this particular issue, you should note that I haven't tested this mod on any version of phpBB since 2.0.17.

Jeez, I'd have thought phpBB 3 would've been out by now. It has a User CP of its own.

I'll start updating this mod this summer when I'm finished college (COMPLETELY FINISHED :D) if phpBB 3 hasn't come out.
LaHrr.S wrote: When you've added someone to your buddy list, how can I make it so that the image Image won't show up anymore, or show a different image, maybe allowing you to remove the buddy.


It looks like you've either done this yourself or I already had the functionality built in.

Post Reply

Return to “[2.0.x] MODs in Development”