[DEV] Mobile Online phpBB

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
pashmak
Registered User
Posts: 55
Joined: Sun Apr 10, 2005 12:07 am

Post by pashmak » Sun Dec 31, 2006 6:02 am

I totally support that and you diffently have my respect. I really enjoy this product. Im just confuse whether I should get 1.6.3 or the latest.

I think it's because I need to let my users in my forum try with the post/reply function to increase the popularity and then buy the full package.

If I just had the chance to try 1.6.3 for a couple of weeks. Im sure I will get tempted to go for the full package right after.
Can you possibly send or give me a direction of where I can get in touch with 1.6.3 ?

pashmak
Registered User
Posts: 55
Joined: Sun Apr 10, 2005 12:07 am

Post by pashmak » Sun Dec 31, 2006 9:46 am

It's solved now.
Since I feel that there are lots of advantages in the full package feature, I decided to purchase the full version of MOphpBB.
Great product

Blisk
Registered User
Posts: 270
Joined: Wed Aug 20, 2003 10:43 am
Location: Slovenia

Post by Blisk » Thu Jan 11, 2007 8:57 am

rickey29 wrote:
Blisk wrote:OK thanks for the tips.

I did test that
and see that online the charters are ok, but not on my mobile.
there are missing, don't know why, because on other sites are shown ok, just on mine not, I use sony erricson phone.

http://www.povej.net/forum/mo/

Check your mobile phone language/character setting. Good luck.


now I was testing this a little more and notice that this two displays wrong charters, you can test it.
http://www.povej.net/forum/mo/index.php?type=wap
http://www.povej.net/forum/mo/index.php?type=xhtml

but this one displays right charters
http://www.povej.net/forum/mo/index.php?type=html


what can be wrong?

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Thu Jan 11, 2007 1:59 pm

Blisk wrote:
rickey29 wrote:
Blisk wrote:OK thanks for the tips.

I did test that
and see that online the charters are ok, but not on my mobile.
there are missing, don't know why, because on other sites are shown ok, just on mine not, I use sony erricson phone.

http://www.povej.net/forum/mo/

Check your mobile phone language/character setting. Good luck.


now I was testing this a little more and notice that this two displays wrong charters, you can test it.
http://www.povej.net/forum/mo/index.php?type=wap
http://www.povej.net/forum/mo/index.php?type=xhtml

but this one displays right charters
http://www.povej.net/forum/mo/index.php?type=html


what can be wrong?

I understand your question/problem now: you want to display Slovenian on your mobile phone through MOphpBB.

My web site provides the general solution for this issue: http://www.mobileonlinestyle.com/index.php?id=faq#4

For your problem, you should search "utf-8 conversion Slovenian" in Google to find solution. (Search "utf-8 conversion Slovenian php" to find php programming solution.) I am sorry I can not help you because I can not read Slovenian. It would be better if you can find a programmer to do this job.

Good luck.

Blisk
Registered User
Posts: 270
Joined: Wed Aug 20, 2003 10:43 am
Location: Slovenia

Post by Blisk » Thu Jan 11, 2007 2:55 pm

Is this a problem because of database or because of PHP?

because my forum works great with oru charters.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Fri Jan 12, 2007 2:43 am

Blisk wrote: Is this a problem because of database or because of PHP?

because my forum works great with oru charters.

PC web browser works well because IE is very powerful and complex than mobile browser, it can support a lot of character set directly, such as Slovenian. While, for mobile, the browser can only support UTF-8 format of Slovenian. MOphpBB should make the conversion for mobile/end user. The reason I did not make it is because I can not read other language than Chinese and English. So you have to find somebody to make it before use it.

I search in the Google and find some interesting links:
http://www.columbia.edu/kermit/utf8.html
http://forum.joomla.org/index.php?topic ... .msg636124

For the Russian and Japanese conversion, someone has already contribute the solution procedure, I share them on my web page "How To" section. For you, it is better if you can want someone who can both (1) do PHP programming and (2) read Slovenian.

Good luck.

Blisk
Registered User
Posts: 270
Joined: Wed Aug 20, 2003 10:43 am
Location: Slovenia

Post by Blisk » Fri Jan 12, 2007 7:17 am

rickey29 wrote:
Blisk wrote:Is this a problem because of database or because of PHP?

because my forum works great with oru charters.

PC web browser works well because IE is very powerful and complex than mobile browser, it can support a lot of character set directly, such as Slovenian. While, for mobile, the browser can only support UTF-8 format of Slovenian. MOphpBB should make the conversion for mobile/end user. The reason I did not make it is because I can not read other language than Chinese and English. So you have to find somebody to make it before use it.

I search in the Google and find some interesting links:
http://www.columbia.edu/kermit/utf8.html
http://forum.joomla.org/index.php?topic ... .msg636124

For the Russian and Japanese conversion, someone has already contribute the solution procedure, I share them on my web page "How To" section. For you, it is better if you can want someone who can both (1) do PHP programming and (2) read Slovenian.

Good luck.


TNX I will try to find a solution, when I do, I will notice you about it.

djingo
Registered User
Posts: 58
Joined: Thu Mar 30, 2006 1:15 am

Post by djingo » Sat Jan 13, 2007 3:01 am

I also get a blank screen when default language = english.

I have done everything the same as on my testsite where it works, just not on my real forum.

Any ideas what the problem might be?

djingo
Registered User
Posts: 58
Joined: Thu Mar 30, 2006 1:15 am

Post by djingo » Mon Jan 15, 2007 9:46 am

Another thing.

On the login - My cellphone (SE K700i) only gives me 2 options -

* numbers only

* Capital letters only

since my password contains small letters I cant login...

If I fx. access www.google.com in my phone theres no problem, I can write both small and capital letters.

bbnewbie
Registered User
Posts: 36
Joined: Sun Aug 20, 2006 5:02 pm

Post by bbnewbie » Thu Mar 08, 2007 4:03 pm

Blisk wrote:
rickey29 wrote:
Blisk wrote:OK thanks for the tips.

I did test that
and see that online the charters are ok, but not on my mobile.
there are missing, don't know why, because on other sites are shown ok, just on mine not, I use sony erricson phone.

http://www.povej.net/forum/mo/

Check your mobile phone language/character setting. Good luck.


now I was testing this a little more and notice that this two displays wrong charters, you can test it.
http://www.povej.net/forum/mo/index.php?type=wap
http://www.povej.net/forum/mo/index.php?type=xhtml

but this one displays right charters
http://www.povej.net/forum/mo/index.php?type=html


what can be wrong?


same problem with italian charset

sql collation: latin1_swedish_ci

a CONVERT in sql queries may solve this?

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Fri Mar 09, 2007 12:59 am

bbnewbie wrote:
Blisk wrote:
rickey29 wrote:
Blisk wrote:OK thanks for the tips.

I did test that
and see that online the charters are ok, but not on my mobile.
there are missing, don't know why, because on other sites are shown ok, just on mine not, I use sony erricson phone.

http://www.povej.net/forum/mo/

Check your mobile phone language/character setting. Good luck.


now I was testing this a little more and notice that this two displays wrong charters, you can test it.
http://www.povej.net/forum/mo/index.php?type=wap
http://www.povej.net/forum/mo/index.php?type=xhtml

but this one displays right charters
http://www.povej.net/forum/mo/index.php?type=html


what can be wrong?


same problem with italian charset

sql collation: latin1_swedish_ci

a CONVERT in sql queries may solve this?

I do not know if a convert in SQL may solve this issue or not.

My web site FAQ section provides the general solution for this issue. I can not do it for you because I can not read Italian. I also suggest you search in Google with the key words: Italian, UTF-8, conversion. I did a search. I believe the search result provide the right conversion procedure.

Good luck.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Do NOT use this software while you are driving!

Post by rickey29 » Fri Apr 20, 2007 11:33 am

I get the information that there are many Radio Area Update/Roaming in U.S. wireless data network. Since there is often one people in a car in U.S., I assume the driver is using his/her mobile phone while driving .

Please no NOT use this software while you are driving, looking at mobile phone screen while driving is very dangerous.

Please tell the end users do not do it.

Ron2K
Registered User
Posts: 247
Joined: Sun May 25, 2003 6:10 pm
Location: Cape Town, South Africa
Name: Kieron Thwaites
Contact:

Re: [DEV] Mobile Online phpBB

Post by Ron2K » Tue May 22, 2007 8:44 am

Hi,

I've put in a MOD request for something like this to be done for phpBB 3.

Link

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Re: [DEV] Mobile Online phpBB

Post by rickey29 » Tue May 22, 2007 8:59 am

Ron2K wrote:Hi,

I've put in a MOD request for something like this to be done for phpBB 3.

Link
I am developing MOphpBB for phpBB3. Currently, I have completed most "read/view" features, like MOphpBB demo version for phpBB2. I will add more "new/reply" features. I will release it after phpBB3 Ready For Application.

mocap69
Registered User
Posts: 25
Joined: Sat Aug 14, 2004 3:49 am
Location: LA, CA, USA
Contact:

Re: [DEV] Mobile Online phpBB

Post by mocap69 » Tue Jul 31, 2007 6:12 pm

I love this mod and installed it on our forum: http://thefanseye.com/forum/mo/index.php?type=html.
I have 2 questions that I need to resolve to allow this to be used. I try to use the WAP option on my
cell and get an error but I can use the XHTML version. I can use other WAP sites but not this one.
I have Version: 1.9.1 installed. The other question: Is there anyway to control the size displayed on the
screen? I hate having to scroll to read the posts. Any suggestions would be awesome!!
Talk to REAL NFL players on the LARGEST forum on the WEB!!
http://www.thefanseye.com

Post Reply

Return to “[2.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 5 guests

cron