[DEV] Mobile Online phpBB

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Thu Jul 28, 2005 2:47 am

mophpbb update, version 1.1: http://www.mobileonlinelifestyle.com/do ... bb_1_1.zip

In this version, I
1. use "limit $start,$size" to optimize database query;
2. add xHTML and simple text only HTML interface for mobile phone / PDA;
3. use "mo" as prefix for every function and global variable to avoid conflict.

Again, for more / latest information of this module, please visit my web site: http://www.mobileonlinelifestyle.com

Enjoy it.

ihere
Registered User
Posts: 13
Joined: Wed Feb 16, 2005 11:54 am

Post by ihere » Sun Jul 31, 2005 2:12 am

Thank you ! :P :P :P
I will try it !

neticus
Registered User
Posts: 80
Joined: Wed Feb 23, 2005 6:51 pm

Post by neticus » Sun Jul 31, 2005 4:51 pm

I would like a WAP mod, yet please, what is the difference/benefits/advantages/between phpbbWapGate and your WAP mod?

thanks in advance
Neticus
Im not judgmental... Im just a mental judge lol. ;)

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Mon Aug 01, 2005 7:44 am

neticus wrote: I would like a WAP mod, yet please, what is the difference/benefits/advantages/between phpbbWapGate and your WAP mod?

thanks in advance
Neticus


The reason I re-write a wap module is right now no one declare he/she will support Wap Forum or phpbbwapWapGate module. I try to improve or fix bug for Wap Forum/phpbbWapGate, but I find that improving the code is harder than re-write it from scratch.

So, the advantage of phpbbWapGate is it has more functions, but it does not have support. My module has less functions, while I will try to improve it and support it. (I hope so.)

If you want a wap module right now, please use phpbbWapGate. And you can trace the progress of my module at the same time.

neticus
Registered User
Posts: 80
Joined: Wed Feb 23, 2005 6:51 pm

Post by neticus » Mon Aug 01, 2005 11:26 am

rickey29 wrote: If you want a wap module right now, please use phpbbWapGate. And you can trace the progress of my module at the same time.


That sounds like good advice :D
Good luck with the Mod
Thanks
Im not judgmental... Im just a mental judge lol. ;)

ihere
Registered User
Posts: 13
Joined: Wed Feb 16, 2005 11:54 am

Post by ihere » Thu Aug 04, 2005 2:47 am

:lol: !
there is no notes in your codes !
:roll: !
And next step , what will you do ?

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Thu Aug 04, 2005 3:12 am

ihere wrote: :lol: !
there is no notes in your codes !
:roll: !
And next step , what will you do ?


I am refactoring my code -- you can find it from the difference between v1.1 and v1.0. I will not add notes until the code is stable. (My code should be easy to read. Most of the subroutines is less than 50 lines.)

My plan is:
Login / Logout (v1.2)
New / Replay post (v1.3)
Private message (v1.4)

One month of one version. v1.2 is under testing.

BTW, did you find any bug in v1.1? Thanks.

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Post by kulinar » Thu Aug 04, 2005 10:12 am

rickey29 wrote: BTW, did you find any bug in v1.1? Thanks.
My default language is bulgarian. When i try to open http://forum.bgkulinar.net/wap/ with WinWAP Pro, it forces open my browser where I see this message

Code: Select all

Warning: main(lang_bulgarian.php): failed to open stream: No such file or directory in /home/.............../forum.bgkulinar.net/html/mo/lib.php on line 14

Warning: main(): Failed opening 'lang_bulgarian.php' for inclusion (include_path='.:/usr/share/pear') in /home/.............../forum.bgkulinar.net/html/mo/lib.php on line 14

Fatal error: Call to undefined function: mo_get_lang() in /home/................/forum.bgkulinar.net/html/mo/lib.php on line 21

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Thu Aug 04, 2005 10:36 am

kulinar wrote:
rickey29 wrote:BTW, did you find any bug in v1.1? Thanks.
My default language is bulgarian. When i try to open http://forum.bgkulinar.net/wap/ with WinWAP Pro, it forces open my browser where I see this message

Code: Select all

Warning: main(lang_bulgarian.php): failed to open stream: No such file or directory in /home/.............../forum.bgkulinar.net/html/mo/lib.php on line 14

Warning: main(): Failed opening 'lang_bulgarian.php' for inclusion (include_path='.:/usr/share/pear') in /home/.............../forum.bgkulinar.net/html/mo/lib.php on line 14

Fatal error: Call to undefined function: mo_get_lang() in /home/................/forum.bgkulinar.net/html/mo/lib.php on line 21


I am sorry for this problem. Right now, my module only provide English language file. If you want to use other language, for example Bulgarian, you should make a copy of the "lang_english.php" file in "mo" directory, rename it as "lang_bulgarian.php", and translate every string in this file into Bulgarian.

One thing you should take care, when I do Simple Chinese translation, besides translate the string into Chinese, I need also translate these string in UTF-8 format. My mobile phone and PC WAP simulator do not accept gb2312 character set. I do not know if you need do this step or not, because I can not read Bulgarian.

Good luck. And tell me if it works.

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Post by kulinar » Fri Aug 05, 2005 11:43 am

I made a copy of lang_english.php, named it lang_bulgarian.php and uploaded it to mo directory but I still get this message.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

mophpbb v1.2

Post by rickey29 » Wed Aug 10, 2005 2:31 am

mophpbb v1.2: http://www.mobileonlinelifestyle.com/do ... bb_1_2.zip

I add two features in this version:
* Login / Logout
* Who's online

I provide a demo forum for this module: http://www.mobileonlinelifestyle.com/index.php?id=demo

And I add more Q/A in my web site: http://www.mobileonlinelifestyle.com/index.php?id=faq

raven007
Registered User
Posts: 82
Joined: Tue May 17, 2005 9:19 pm

Post by raven007 » Wed Aug 10, 2005 9:40 pm

excellent..thank you

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Aug 17, 2005 12:52 am

I want to collect your opinion on which mophpbb mod beginning URL should be. There are four choices, please tell me which one is your prefer.

Option One:
Currently, to access from xHTML interface, user should input "http://www.yourdomain.com/forum/xhtml/"
For this option, I have to maintain three copy of code for xhtml, wap and html.

Option Two:
User should input "http://www.yourdomain.com/forum/mo/index.php?type=xhtml"
For this option, I only have one copy of code. But it is hard for end user to remember the link.

Option Three:
User should input "http://www.yourdomain.com/forum/xhtml/" (same as option one), while I will add a .htaccess file in "xhtml" directory to automatic redirect the link to "http://www.yourdomain.com/forum/mo/index.php?type=xhtml" (option two). It is the compromise of the first and the second options.

Option Four:
You (the web administrator) will add some sub-domain, such as "http://xhtml.forum.yourdomain.com/", which can redirect the link to "http://www.yourdomain.com/forum/mo/index.php?type=xhtml"

Other option if you suggest.

Thanks.

ihere
Registered User
Posts: 13
Joined: Wed Feb 16, 2005 11:54 am

Post by ihere » Wed Aug 17, 2005 1:05 am

4 :D

good job!

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Aug 17, 2005 1:10 am

There is an issue for my module when you want to use other language as the end user interface than English. Let me use Simplified Chinese as the example. phpBB Simplified Chinese version uses gb2312 character set -- when phpBB save the post in database, it is in gb2312 character format. But most mobile can not accept gb2312 character set directly, it can only read UTF-8 format of gb2312.

The point is, for other language than English, it is possible that the mobile can NOT read the post inputted from PC interface!

Even if this issue will not happen on every language, it will happen on some of the language. So I would like to ask if you have any solution/suggestion to this issue.

My current work around is I change the code of phpBB itself (not mophpbb mod) to make it use UTF-8 format of gb2312 when it do save in database. This work is outside the scope of my module, and it can not help other than Simplified Chinese.

Post Reply

Return to “[2.0.x] MODs in Development”