[DEV] Mobile Online phpBB

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Mistainu
Registered User
Posts: 44
Joined: Thu Jul 14, 2005 2:57 pm
Location: Nusantara
Contact:

Post by Mistainu » Mon Sep 05, 2005 6:32 am

hey dood! i'm trying to get tehre soon too! i was thinking once my dektop site if all proper n has some active users...i'll head on tto the mobile side. for mobile side you CAN use the template solution.it's rather complicated so i rathewr skip it :P i'm kinda having exams now so will collaborate on with project in December? shall we? :wink:
EoM, eNjOy~!
My site! > http://unlimitedinfinity.com/
How could one man, one ritual, hope to knit such immensity into a garment fitted to all men?
-Paul Atreides

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Sep 07, 2005 2:37 am

rickey29 wrote:
abidjantalkcom wrote:
rickey29 wrote:I want to collect your opinion on which mophpbb mod beginning URL should be. There are four choices, please tell me which one is your prefer.

Option Four:
You (the web administrator) will add some sub-domain, such as "http://xhtml.forum.yourdomain.com/", which can redirect the link to "http://www.yourdomain.com/forum/mo/index.php?type=xhtml"

Other option if you suggest.
Thanks.

I didn't see any response to this message.
Option Four is my choice.


I make a redirection from "http://www.yourdomain.com/forum/xhtml/" to "http://www.yourdomain.com/forum/mo/index.php?type=xhtml" in my code. So, from user view point, he/she can still use "http://www.yourdomain.com/forum/xhtml/"; from web administrator view point, he/she can add subdomain "http://xhtml.forum.yourdomain.com/", which redirect to either "http://www.yourdomain.com/forum/xhtml/" or "http://www.yourdomain.com/forum/mo/index.php?type=xhtml". In this case, user have one more choice -- "http://xhtml.forum.yourdomain.com/".

I will provide this function in version 1.3.x. Please check readme.txt or my web page for detail when it is available.


Sorry, I find the redirection in my implementation has problem. I will defer this function to version 1.4.x.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

mophpbb v1.3.3

Post by rickey29 » Wed Sep 07, 2005 3:08 am

mophpbb v1.3.3: http://www.mobileonlinelifestyle.com/do ... _1_3_3.zip

Thanks for Dagon's help, I fix a serious bug in v1.3. Please do backup your database before you install my mod. You can restore the database in case of any unhappy.

Good luck to you and me.

perfectlover
Registered User
Posts: 2
Joined: Wed Sep 07, 2005 6:56 pm

Post by perfectlover » Wed Sep 07, 2005 6:59 pm

Hi,
I am getting this error. Any idea? However first page is loading fine when i click on forum links it gives me:

Could not get URL http://www.domain.com/wap/mo/forum.php? ... p&cat_id=3
HTTP Error : 404 (Not Found

youngone
Registered User
Posts: 7
Joined: Sat May 07, 2005 1:34 am

Post by youngone » Wed Sep 07, 2005 11:00 pm

rickey29 wrote:
youngone wrote:with this mod is there a way to show what type of phone replied in the post instead of it saying (posted by mobile device)


I can get the mobile type from HTTP header info "User-Agent" field, and then append the mobile name after new/reply post. I will do it later.


any update on this portion of the mod

expert01
Registered User
Posts: 25
Joined: Sat Jul 31, 2004 4:53 am

Post by expert01 » Fri Sep 16, 2005 7:44 pm

Have you considered using WURFL (http://wurfl.sourceforge.net/php/index.php)?

Dagon
Registered User
Posts: 422
Joined: Tue Jun 03, 2003 8:59 pm

Post by Dagon » Sat Sep 17, 2005 8:00 pm

Sorry, I just now got a chance to try out your newest version. 1.3.3 does work correctly on my forums. I hope all of the trouble helped to created a more stable post/reply function that is not prone to failure. Thanks, very nice improvement. This mod has a lot of potential.

I would also like to see the text that shows what type of device the post was made from.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Mon Sep 19, 2005 6:19 am

expert01 wrote: Have you considered using WURFL (http://wurfl.sourceforge.net/php/index.php)?


You mean I use WURFL to find the mobile type, right? Yes, this is my technical solution to append device type after new/reply post.

Currently, there are three requests for this feature/function. I will think if I should do it earlier.

youngone
Registered User
Posts: 7
Joined: Sat May 07, 2005 1:34 am

Post by youngone » Tue Oct 18, 2005 2:09 pm

has this mod stopped development

User avatar
Smokeydogg
Registered User
Posts: 240
Joined: Sat Dec 06, 2003 8:02 am
Contact:

Post by Smokeydogg » Tue Oct 18, 2005 4:05 pm

i wanna make it so my forum works on psp :D

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Oct 19, 2005 8:03 am

I am sorry my email box does not work right now. Please use PM instead of email. Thanks.

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Oct 19, 2005 8:20 am

youngone wrote: has this mod stopped development


Still going. I am testing PM feature right now. Please be patient.

NevilleX
Registered User
Posts: 4
Joined: Sat Oct 15, 2005 8:35 pm

Post by NevilleX » Wed Oct 19, 2005 10:03 pm

Great mod, however there is some security problems with it.
There are no support for forum permissions. All users and guests can see all private forums that only members of various usergroups should see. Also guests can post new topics and reply to topics in all forums even private ones. In the "real" forum registration is required for posting and replying.

albertz
Registered User
Posts: 19
Joined: Thu Feb 20, 2003 6:35 pm
Location: Edinburgh
Contact:

Post by albertz » Sun Oct 23, 2005 6:09 pm

Greatr Mod but I can't use it due to the problem with permissions :cry:

I don't want any user accessing my admin forums and guests posting and seeing my admin forums :?

Any idea how it is possible to prevent non-auth access?

rickey29
Registered User
Posts: 259
Joined: Tue Apr 27, 2004 11:35 am
Location: Beijing, China
Contact:

Post by rickey29 » Wed Oct 26, 2005 4:38 am

rickey29 wrote: I am sorry my email box does not work right now. Please use PM instead of email. Thanks.


My email box (rickey29@bj1860.net) recovered.

Post Reply

Return to “[2.0.x] MODs in Development”