[ABD] Report Posts (2.1.5)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Mon Sep 26, 2005 10:36 am

Version 2.1.2c is out:

Code: Select all

##	2005-09-26 - Version 2.1.2c (alpha)
##	- Changed sql UPDATE code (again) in order to be compatible with all possible sql versions
##	- Disabled displaying of report icon when users cannot report their own reports (Thanks James78)
##
See 1st post for download link and details...

To update from previous version just copy over all files, and make the changes mentioned in install.txt regarding file "viewtopic.php".

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

WinstonFl
Registered User
Posts: 19
Joined: Mon Jan 17, 2005 9:40 pm

Post by WinstonFl » Tue Sep 27, 2005 12:08 am

Thanks for all your work on this script.

This mod is excellent and I know that I really appreciate all the updates to fix the small issues that we have found!

Keep up the great work.

User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 » Tue Sep 27, 2005 4:57 am

when I click on the report icon to report a post:

Code: Select all

Fatal error: Cannot redeclare get_template_name() (previously declared in /home/(Removed)/public_html/forums/includes/functions.php:444) in /home/(Removed)/public_html/forums/includes/functions_report.php on line 31
it is clashing with AbelaJohnB's "Welcome & Avatar On phpBB Index" mod. any fixes?

whozyodaddy
Registered User
Posts: 186
Joined: Sat May 08, 2004 4:26 am

Post by whozyodaddy » Tue Sep 27, 2005 5:06 am

Thanks, the delete problem is gone.

User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 » Tue Sep 27, 2005 5:18 am

Edit: Post content removed.

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Tue Sep 27, 2005 8:10 am

James78 wrote: when I click on the report icon to report a post:

Code: Select all

Fatal error: Cannot redeclare get_template_name() (previously declared in /home/(Removed)/public_html/forums/includes/functions.php:444) in /home/(Removed)/public_html/forums/includes/functions_report.php on line 31
it is clashing with AbelaJohnB's "Welcome & Avatar On phpBB Index" mod. any fixes?

I'm using the same mod and i though i had solved that :x
Let me have a look at my server, because i think i forgot to update all the mod files uploaded here. :?

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Tue Sep 27, 2005 8:36 am

Version 2.1.2d is out:

Code: Select all

##	2005-09-27 - Version 2.1.2d (alpha)
##	- Changed some function names to avoid conflicts
##	- Small code cleanup
See 1st post for download link and details...

To update from the previous version just copy over all *.php files.

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 » Tue Sep 27, 2005 11:31 am

A little bug I noticed. When you have reported 0 posts, it shows this mistake.

It should actually say, "This post has already been reported 0 time(s)"
Image

DeadDingo
Registered User
Posts: 129
Joined: Tue Sep 13, 2005 1:07 pm

Post by DeadDingo » Tue Sep 27, 2005 12:16 pm

chatasos wrote: Version 2.1.2d is out:

Code: Select all

##	2005-09-27 - Version 2.1.2d (alpha)
##	- Changed some function names to avoid conflicts
##	- Small code cleanup
See 1st post for download link and details...

To update from the previous version just copy over all *.php files.


Does this include upgrading from 2.1.2a or are there more changes?

User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 » Tue Sep 27, 2005 12:31 pm

Does this include upgrading from 2.1.2a or are there more changes?

No, but to upgrade to the latest, just replace all php files, then redo all the file edits and you'll be upgraded. Oh, one thing, delete the file "admin_report_post.php" in the folder admin and replace it with "admin_report_posts.php".
Last edited by James78 on Tue Sep 27, 2005 12:39 pm, edited 3 times in total.

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Tue Sep 27, 2005 12:35 pm

DeadDingo wrote:
chatasos wrote:Version 2.1.2d is out:

Code: Select all

##	2005-09-27 - Version 2.1.2d (alpha)
##	- Changed some function names to avoid conflicts
##	- Small code cleanup
See 1st post for download link and details...

To update from the previous version just copy over all *.php files.


Does this include upgrading from 2.1.2a or are there more changes?

DeadDingo, this only refers to the case you're updating from the previous version 2.1.2c.
If you want to upgrade from 2.1.2a to 2.1.2d, you'll have to copy over (overwrite) all files and do the changes mentioned in install.txt, regarding files "viewtopic.php" & "page_tail.php".

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Tue Sep 27, 2005 12:44 pm

James78 wrote: A little bug I noticed. When you have reported 0 posts, it shows this mistake.

It should actually say, "This post has already been reported 0 time(s)"
Image


If i'm not mistaken, you have reported the same problem here too.
http://www.phpbb.com/phpBB/viewtopic.ph ... 32#1783632

The strange thing with it, is that it shouldn't happen since you get the other message ("There isn't any previous report information available for this post") too.

Have you by any chance changed the code in report.php or report_post.tpl?
Can you try to reupload only these 2 files?

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

User avatar
James78
Registered User
Posts: 811
Joined: Sat Jul 30, 2005 4:54 pm
Location: Washington, USA
Contact:

Post by James78 » Tue Sep 27, 2005 1:01 pm

Yeah, I reported this before, but I thought a screenshot would be more descriptive as to what I'm talking about. No, I didn't change any coding (except to upgrade). what could the problem be? I just re-uploaded those files and replaced them. The same problem is still there...

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos » Tue Sep 27, 2005 1:51 pm

James78 wrote: Yeah, I reported this before, but I thought a screenshot would be more descriptive as to what I'm talking about. No, I didn't change any coding (except to upgrade). what could the problem be? I just re-uploaded those files and replaced them. The same problem is still there...


ok, can you try the following and report here the results (screenshot)?

in file report.php

[FIND]

Code: Select all

$report_details = get_report_details($post_id, 'post');
[AFTER ADD]

Code: Select all

echo"*";print_r($report_details);echo"*";
In your case you should get some characters between the two asterisks, which appear at the top left of the page, just under your forum logo.

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)

DeadDingo
Registered User
Posts: 129
Joined: Tue Sep 13, 2005 1:07 pm

Post by DeadDingo » Tue Sep 27, 2005 2:37 pm

I now get the following error (on every page) after updating the Mod and ammending the 2 files you suggested.

Parse error: parse error, unexpected T_DOUBLE_ARROW in /includes/page_tail.php on line 61

Any ideas?

EDIT: FIXED it. had a couple of // in the wrong place
Last edited by DeadDingo on Tue Sep 27, 2005 2:52 pm, edited 1 time in total.

Locked

Return to “[2.0.x] MODs in Development”