[BETA] FreeCap Visual Confirmation 0.0.3

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
gansert
Registered User
Posts: 581
Joined: Wed Mar 08, 2006 8:48 pm
Location: KÖLN, GERMANY
Contact:

Post by gansert » Sun Sep 10, 2006 6:37 pm

joeydee wrote:
A_Jelly_Doughnut wrote:As far as making images easier to read, that doesn't seem to be done in any easy manner.
So what about using NUMBERS ( 0 - 9 ) only?

Numbers can read everybody...

Is that possible?

wkitty42
Registered User
Posts: 191
Joined: Sat Apr 03, 2004 1:11 pm
Location: Central North Carolina, USA
Contact:

Post by wkitty42 » Mon Sep 11, 2006 11:35 pm

A_Jelly_Doughnut wrote: One way to say it: It doesn't matter what fonts you start with because of the morphing mechanism.

As far as making images easier to read, that doesn't seem to be done in any easy manner.


should it be mentioned that if it is easier for a human to read, then it is easier for a 'bot/ocr-reader to read? the whole idea is to thwart the 'bots and their ocr readers, isn't it??
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.

- Richard Cook

User avatar
Saeru
Registered User
Posts: 622
Joined: Sun Feb 19, 2006 5:44 am
Location: Under a pile of PHP code.
Contact:

Post by Saeru » Sun Sep 17, 2006 8:28 pm

I still have an issue with the mod not using any of the backgrounds I make for it. All it shows are the three default images, how can i change it to display my own instead?
"Naku ga yousuru ichidanto tsuyosa kyaku ga icchuu wo yusuru."[/size]

gansert
Registered User
Posts: 581
Joined: Wed Mar 08, 2006 8:48 pm
Location: KÖLN, GERMANY
Contact:

Post by gansert » Thu Sep 21, 2006 8:09 pm

No one is complaining on my board. Everybody can read the image fine.

It is actually even very easy compared to others..

webmaster@bttr-software.de

rr@bttr-software.de
Last edited by gansert on Thu Oct 19, 2006 12:41 pm, edited 1 time in total.

baerenwurm
Registered User
Posts: 131
Joined: Wed Nov 06, 2002 2:38 pm
Location: Germany

Post by baerenwurm » Mon Sep 25, 2006 2:32 pm

After deinstalling your MOD (cause sometimes the image just does not load on the registration page), the regular visual confirmation doesn't work anymore:

Image

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Mon Sep 25, 2006 2:54 pm

By "uninstalling", do you mean you undid the changes to usercp_confirm.php, or that you copied an unmodified one into its place? If you have not done so, copy an unmodified file in, and see if it still does it.

There have been several reports of this happening with the usercp_confirm.php that comes with 2.0.20 and later. It seems that some systems do not like the way the image gets generated. If you force the old behaviour (generate 6 separate images when ZLib isn't installed), the letters and numbers are fine - it's in the stage that combines the images into one, adds speckling, and compresses the whole lot. I've seen a few dozen such cases... and I have not had time to try and identify the common feature(s) of each one.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

baerenwurm
Registered User
Posts: 131
Joined: Wed Nov 06, 2002 2:38 pm
Location: Germany

Post by baerenwurm » Mon Sep 25, 2006 2:59 pm

Well, I have the latest version of phpBB and just undid the changes. Now I tried to overwrite the usercp_confirm.php with an unmodified one though it does not work neither.
Before I installed this MOD everything worked fine :?

Black-Hole
Registered User
Posts: 29
Joined: Fri Sep 09, 2005 7:58 pm
Location: The Netherlands
Contact:

Post by Black-Hole » Tue Oct 03, 2006 10:10 am

Just installed this mod on my test forum but it doesn't seems to work correctly. When trying to register I see an image at the visual confirmation part but there is no confirmation code visable, only a background image.

What could be the problem?

Edit: checked the install file and might have something to do with this:

Code: Select all

Note the included fonts only work on little-endian processors like x86
##  You'll need to generate your own fonts for UltraSparc and similar architectures.
But how can I add my own fonts?

Dave H
Registered User
Posts: 9
Joined: Thu Dec 23, 2004 12:09 am

Post by Dave H » Wed Oct 18, 2006 12:35 pm

Hi all,

I had this mod working on my forum..but then moved the forum over to a new provider.. and now.. i'm getting the old grey background from the initial captcha..and no text..but no new backgrounds /text from this mod.

I've confirmed GD and zlib are installed

$ rpm -qa |grep zlib
zlib1-devel-1.1.4-8mdk
zlib1-1.1.4-8mdk

$ rpm -qa |grep gd2
libgd2-2.0.9-3mdk
libgd2-devel-2.0.9-3mdk

$ rpm -qa |grep gd
gdk-pixbuf-loaders-0.22.0-1mdk
ifplugd-0.13-3mdk
libgdbm2-1.8.0-19mdk
libgdk-pixbuf2-0.22.0-1mdk
libgd2-2.0.9-3mdk
libgdk-pixbuf-gnomecanvas1-0.22.0-1mdk
gdb-5.3-22mdk
libgd2-devel-2.0.9-3mdk
libgdbm3-1.8.3-2mdk
sysklogd-1.4.1-4mdk
libgdk_pixbuf2.0_0-2.2.1-2mdk
php-gd-5.0.4-1mdk


Anyone got any ideas ?

The forum works fine, so all paths are correctly set up.

Cheers :D

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Wed Oct 18, 2006 5:25 pm

Dave H: Does php know about GD and zlib? You can check with phpinfo(). PHP must know for extension_loaded() to return the expected value. If it does know about GD, then I'm not really sure what the issue could be.

Black-Hole: There is a GD fonts generator in the comments in function_freecap.php. You should be able to use that for non-little-endian processors.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

Dave H
Registered User
Posts: 9
Joined: Thu Dec 23, 2004 12:09 am

Post by Dave H » Wed Oct 18, 2006 5:40 pm

Hiya,
I'm a bit :oops: :oops: I checked and re-checked everything...


.... or so I thought.

gd.so was commented out in the additional ini's (as the host is running an old mandrake 9.1).. and urpmi was broken.

And when it tries to run gd.so it gives an error... but I've fixed urpmi now and the error it gives suggests there are 2 versions of gd installed...so i'm going to get the webhost to remove all instances of GD and then re-install.

..so it's probably (my) user error!
Apologies for that... but will report back once i've got GD installed.

Thanks for your help though :D

User avatar
Saeru
Registered User
Posts: 622
Joined: Sun Feb 19, 2006 5:44 am
Location: Under a pile of PHP code.
Contact:

Post by Saeru » Sun Oct 22, 2006 9:27 am

Am I ever going to be told how to get this to display the background images I make rather then the three default ones? I've asked several times with no answer.
"Naku ga yousuru ichidanto tsuyosa kyaku ga icchuu wo yusuru."[/size]

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3471
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Post by bonelifer » Wed Oct 25, 2006 11:48 pm

Was wondering if you were going to create an addon or if there is an addon that applies the Freecap captcha to the posting page. Unfortunately we have to allow guest posting in certain forums(beyond our control for certain forums) and since installing this mod they've reverted back to posting anonymously.
Knowledge Base | phpBB Board Rules | Search Customisation Database
Image
Please don't contact me via PM or email for phpBB support .

User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin » Fri Oct 27, 2006 5:53 am

Well, I finally got around to installing this and I have to say it looks good! Thanks A_Jelly_Doughnut!! :D

Two things: the MOD script needs this fix: http://www.phpbb.com/phpBB/viewtopic.ph ... 38#2176438

And your COPY command is wrong.
This is the correct version:

Code: Select all

#
#----[ COPY ]---------------------
#
# Note that you can replace any of these fonts or images with your own should you desire.
# Just keep the names the same.
copy freecap/.ht_freecap_font1.gdf to includes/freecap/.ht_freecap_font1.gdf
copy freecap/.ht_freecap_font2.gdf to includes/freecap/.ht_freecap_font2.gdf
copy freecap/.ht_freecap_font3.gdf to includes/freecap/.ht_freecap_font3.gdf
copy freecap/.ht_freecap_font4.gdf to includes/freecap/.ht_freecap_font4.gdf
copy freecap/.ht_freecap_font5.gdf to includes/freecap/.ht_freecap_font5.gdf
copy freecap/.ht_freecap_im1.jpg to includes/freecap/.ht_freecap_jpg
copy freecap/.ht_freecap_im2.jpg to includes/freecap/.ht_freecap_jpg
copy freecap/.ht_freecap_im3.jpg to includes/freecap/.ht_freecap_jpg
copy freecap/.ht_freecap_im4.jpg to includes/freecap/.ht_freecap_jpg
copy freecap/.ht_freecap_im5.jpg to includes/freecap/.ht_freecap_jpg
copy functions_freecap.php to includes/functions_freecap.php
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.

User avatar
Saeru
Registered User
Posts: 622
Joined: Sun Feb 19, 2006 5:44 am
Location: Under a pile of PHP code.
Contact:

Post by Saeru » Fri Oct 27, 2006 6:24 am

Black-Hole wrote: Just installed this mod on my test forum but it doesn't seems to work correctly. When trying to register I see an image at the visual confirmation part but there is no confirmation code visable, only a background image.

What could be the problem?

Edit: checked the install file and might have something to do with this:

Code: Select all

Note the included fonts only work on little-endian processors like x86
##  You'll need to generate your own fonts for UltraSparc and similar architectures.
But how can I add my own fonts?


Pm me, I can help make you fonts for it.
"Naku ga yousuru ichidanto tsuyosa kyaku ga icchuu wo yusuru."[/size]

Post Reply

Return to “[2.0.x] MODs in Development”