[RC1] BetterSMTP

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Re: [RC1] BetterSMTP

Post by DivErTido » Wed Feb 06, 2008 2:50 pm

Void Main wrote:I have found this BetterSMTP is not needed to send mail through smtp.gmail.com. If you are running phpBB on PHP 5 you only have to make a slight addition to includes/smtp.php. I am running 2.0.20 but it will probably work on later versions too. Just find this section:

Code: Select all

        if( !empty($board_config['smtp_username']) && !empty($board_config['smtp_password']) )
        {
                fputs($socket, "EHLO " . $board_config['smtp_host'] . "\r\n");
                server_parse($socket, "250", __LINE__);
and right after it add this:

Code: Select all

fputs($socket, "STARTTLS\r\n");
server_parse($socket, "220", __LINE__);
stream_socket_enable_crypto($socket, true, STREAM_CRYPTO_METHOD_TLS_CLIENT);
That would be right before the "AUTH LOGIN" section. Then in your board configuration settings use "smtp.gmail.com", port 25 (or 587 I presume) and your gmail address and password for the username and password. Basically this starts TLS right before the auth.
Great code mate!
Can you write the same code for PHP 4? :)
P.S. Please sorry for my poor english...
Legendas Divx

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Fri Feb 15, 2008 1:53 pm

Hy, guys! :)

I'm trying to use Gmail as my SMTP, but all I see after I send a mass email is a blank screen. :(
I think I've set it okay...

Image

My php mailer is not working, and I really don't know what do to. I'll need some help, please. :cry:

O.S.: Linux
Apache: 2.0.61
PHP: 5.2.4
SQL: 4.1.22

DivErTido
Registered User
Posts: 642
Joined: Fri Aug 08, 2003 10:11 pm
Contact:

Re: [RC1] BetterSMTP

Post by DivErTido » Fri Feb 15, 2008 3:29 pm

I think that moderators can close this thread, because I have sent a mail to the author beucause in the MOD official page have read this:
7. Additional help
Since I have no idea what obstacles you may stumble upon, send me an e-mail and I'll post your question (hopefully along with an answer) here as soon as possible.
and I got this from him:
Hi,

I've decided to discontinue BetterSMTP since everybody were so good at pointing out bugs and feature requests, but no one was willing to help.

Sorry,
Christian
P.S. Please sorry for my poor english...
Legendas Divx

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Sat Feb 16, 2008 10:17 am

If the thread would be closed, we'll not be able to receive help anymore. :?
Like the guy said, we should help each other. ;)

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Fri Apr 04, 2008 6:49 pm

Since noone wants to help me fix it, I want to uninstall it. So please, I'm begging you, tell me at least what setting should I leave before uninstall it?
Server's port 587 is okay? Authentification method "login" is okay? The server is using SSL/ TLS authentification yes/ no?
LANFS wrote:Hy, guys! :)

I'm trying to use Gmail as my SMTP, but all I see after I send a mass email is a blank screen. :(
I think I've set it okay...

Image

My php mailer is not working, and I really don't know what do to. I'll need some help, please. :cry:

O.S.: Linux
Apache: 2.0.61
PHP: 5.2.4
SQL: 4.1.22

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Thu Apr 24, 2008 7:15 pm

OH MY GOD :!: :!: :!:

I just wanna uninstall this MOD. Since I won't be able to change the SMTP setting after uninstall it, please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please tell me what setting should I leave.

OMG... Zero support. :| :| :| :|

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Sun Apr 27, 2008 9:04 pm

Is there any support for phpBB2 on this board? :roll: :roll: :roll:

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Thu May 01, 2008 10:30 am

bump!

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Thu May 01, 2008 6:30 pm

bump!

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Mon May 12, 2008 5:51 pm

bump!

LANFS
I've Been Banned!
Posts: 62
Joined: Sun Aug 12, 2007 5:10 pm
Contact:

Re: [RC1] BetterSMTP

Post by LANFS » Tue May 13, 2008 10:24 am

Since no one wants to help me fix it, I want to uninstall it. So please, I'm begging you, tell me at least what setting should I leave before uninstall it?
Server's port 587 is okay? Authentification method "login" is okay? The server is using SSL/ TLS authentification yes/ no?
LANFS wrote:Hy, guys! :)

I'm trying to use Gmail as my SMTP, but all I see after I send a mass email is a blank screen. :(
I think I've set it okay...

Image

My php mailer is not working, and I really don't know what do to. I'll need some help, please. :cry:

O.S.: Linux
Apache: 2.0.61
PHP: 5.2.4
SQL: 4.1.22

101104
Registered User
Posts: 1
Joined: Tue Jun 03, 2008 8:53 am

Re: [RC1] BetterSMTP

Post by 101104 » Tue Jun 03, 2008 8:57 am

THANKS

Post Reply

Return to “[2.0.x] MODs in Development”