[ABD] AJAXed (MMW)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Mistainu wrote: um... exactly how do i use this mod. yes i saw the screenshots and i know what it's supposed to do but. how do i use it? right click on post? no... double click? just click? what?!

EDIT PM namelist thing understood, instant preview understood.how about those lil boxes u have on the screenshots?



You get the post menu or the poll menu you double click on the post text or double click on the poll options. In version 2.0.6 I'll have it set up differently. Made have it right click or have it have a button that the user can just click to get the menus.

User avatar
Zelonght
Translator
Posts: 53
Joined: Tue Apr 19, 2005 7:26 am
Contact:

Post by Zelonght »

Hi Matt
I test again in your web. It's cool since Unicode Chars works well now !

I will waiting for 2.0.6


Zelonght - www.zelda.com

User avatar
Zelonght
Translator
Posts: 53
Joined: Tue Apr 19, 2005 7:26 am
Contact:

Post by Zelonght »

Google uses Ajax, Yahoo not. And I like Google for the fast speed

If phpbb develop AJAX as a powerful feature of phpbb, I think phpbb will be better than IPB, vBB ? I hope so

:idea:

01satkins
Registered User
Posts: 82
Joined: Sat Sep 03, 2005 8:12 pm

Post by 01satkins »

ipb already uses ajax for the quick edit feature (which is really cool)

tauntry
Registered User
Posts: 4
Joined: Thu Mar 16, 2006 5:20 pm

Re: For some reason I lost my edit button

Post by tauntry »

Nux wrote:
tauntry wrote:Hey I lost my edit button (the original one) And now I don't know which file it is in.) To put it back. Does any one know which file I need to put the original edit button back and what the code is, I realize it was my mistake sooo....
I would appreciate the help.

I guess it's viewtopic_body.tpl, but you would have to give a link to your forum to be sure.

PS: Remember it's still RC1 - so it is NOT released yet and it might have some serious bugs.


I'm sorry I have a million things going at once and YES my forums are heavily modded out, yea I thought it was in view topic , but let me give you my link.
Please please before you go this is adult oriented website , I have to give you a warning. You are welcome to make an account , i have tons of mods going on in this forum , there alot of little problems I'm having , but it is in working condition, so I will just leave it and then when I get time I work on it! I have the blog mod, ajaxed, airheadtheme, classifieds and more!
Its amazing I have them all working ...well it s a good way for me to learn but I search and search and I can not find where the old edit button, your welcome to shoot me an email , maybe it will help if I posted the airhead theme view topic ccodesa? I ahve the origial file somewhere. Obviously its not a huge concern you can still double click and make the edits. THANKS!
http://knaughtyknickers.com/boards/

User avatar
nedka
Registered User
Posts: 162
Joined: Tue Jun 28, 2005 8:55 am
Location: Ho Chi Minh City
Name: Khoa Nguyen

Post by nedka »

Why don't use AJAX to re-update info about online users (every 1 min or custom) without refresh page (index.php) :d
VinaBB - Republic of phpBB

01satkins
Registered User
Posts: 82
Joined: Sat Sep 03, 2005 8:12 pm

Post by 01satkins »

thats a good idea, although it will increase the load on webservers. if you were doing that you could do the same for the last post in each forum

tauntry
Registered User
Posts: 4
Joined: Thu Mar 16, 2006 5:20 pm

Re: For some reason I lost my edit button

Post by tauntry »

Nux wrote:
tauntry wrote:Hey I lost my edit button (the original one) And now I don't know which file it is in.) To put it back. Does any one know which file I need to put the original edit button back and what the code is, I realize it was my mistake sooo....
I would appreciate the help.

I guess it's viewtopic_body.tpl, but you would have to give a link to your forum to be sure.

PS: Remeber it's still RC1 - so it is NOT released yet and it might have some serious bugs.

here my file. it actualy does have the edit button so I am not clear whats going on here....maybe one of you can have a look
<table width="95%" cellspacing="0" cellpadding="0" border="0">
<tr>
<td id="topic">
<table width="95%" cellspacing="2" cellpadding="2" border="0">
<tr>
<td align="left" valign="bottom" colspan="2"><a class="maintitle" href="{U_VIEW_TOPIC}"><div id="topic_title">{TOPIC_TITLE}</div></a><br />
<span class="gensmall"><b>{PAGINATION}</b><br />
&nbsp; </span></td>
</tr>
</table>

<table width="95%" cellspacing="2" cellpadding="2" border="0">
<tr>
<td align="left" valign="bottom"id="ttop" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
<td align="left" valign="middle"id="ttop_nav" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a>
-> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
</tr>
</table>

<table class="forumline" width="95%" cellspacing="1" cellpadding="3" border="0">
<tr align="right">
<td class="catHead" colspan="2" height="28"><span class="nav"><a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a> &nbsp;</span></td>
</tr>
<tr><td id="poll_display" colspan="2">
{POLL_DISPLAY} </td></tr>
<tr>
<th class="thLeft" width="150" height="26" nowrap="nowrap">{L_AUTHOR}</th>
<th class="thRight" nowrap="nowrap">{L_MESSAGE}</th>
</tr>
<!-- BEGIN postrow -->

<tr id="postrow_{postrow.AJAXED_I}">
<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}</span><br /></td>
<td ondblclick="{postrow.AJAXED_POST_MENU}" class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">

<tr>
<td width="100%"onDblClick="{postrow.AJAXED_EDIT_SUBJECT}"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}: <div id="p_{postrow.AJAXED_I}_subject" style="display: inline;">{postrow.POST_SUBJECT}</div><form action="" method="post" id="p_{postrow.AJAXED_I}_edit_subject" style="display: none;" onSubmit="ss({postrow.U_POST_ID},{postrow.AJAXED_I}); oc('p_{postrow.AJAXED_I}_subject', 'p_{postrow.AJAXED_I}_edit_subject'); return false;"><input type="text" name="{postrow.U_POST_ID}_subject" id="{postrow.U_POST_ID}_subject" class="post" size="40" value="{postrow.POST_SUBJECT}" /></form></span></td>
<td valign="top" nowrap="nowrap"> {postrow.EDIT_IMG} {postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td>
</tr>
<tr>
<td colspan="2"></td>
</tr>
<tr>
<td colspan="2"><span class="postbody"><div id="p_{postrow.U_POST_ID}_message" style="display: inline;">{postrow.MESSAGE}</div></span>{postrow.ATTACHMENTS}<span class="postbody">{postrow.SIGNATURE}</span><span class="gensmall"id="p_{postrow.U_POST_ID}_edited">{postrow.EDITED_MESSAGE}</span></td>
</tr>
</table></td>
</tr>
<tr id="postrow_{postrow.AJAXED_I}_third">
<td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td>
<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap="nowrap"><table cellspacing="0" cellpadding="0" border="0" height="18" width="18">
<tr>
<td valign="middle" nowrap="nowrap">{postrow.PROFILE_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!--

if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 && navigator.userAgent.indexOf('6.') == -1 )
document.write(' {postrow.ICQ_IMG}');
else
document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>');

//--></script><noscript>{postrow.ICQ_IMG}</noscript></td>
</tr>
</table></td>
</tr>
<tr>
<td class="spaceRow" colspan="2" height="1"><img src="templates/AirHead/images/spacer.gif" alt="" width="1" height="1" /></td>
</tr>

<!-- END postrow -->
<tr align="center">
<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
<tr><form method="post" action="{S_POST_DAYS_ACTION}">
<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
</form></tr>
</table></td>
</tr>
</table>

<table width="95%" cellspacing="2" cellpadding="2" border="0" align="center">
<tr>
<td align="left" valign="middle"id="bottom" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
<td align="left" valign="middle" id="bottom_nav"width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a>
-> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
<td align="right" valign="top" nowrap="nowrap"><span class="gensmall">{S_TIMEZONE}</span><br /><span class="nav">{PAGINATION}</span>
</td>
</tr>
<tr>
<td align="left" colspan="3"><span class="nav">{PAGE_NUMBER}</span></td>
</tr>
</table>

<table width="95%" cellspacing="2" border="0" align="center">
<tr>
<td width="40%" valign="top" nowrap="nowrap" align="left"><span class="gensmall"id="watch_topic">{S_WATCH_TOPIC}</span><br />
&nbsp;<br />
{S_TOPIC_ADMIN}</td>
<td align="right" valign="top" nowrap="nowrap">{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
</tr>
</table>
</td>
</tr>
</table>

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Hello tauntry,
Please send me your viewtopic.php file in an email to. Removed to stop spam

Thank You,
*=Matt=*

Anyways, I broke up with my girlfriend soo that is why 2.0.6 has not been released anytime soon. I have added a few features to 2.0.6 and I am planning on having it up for download sunday.

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Lets give 2.0.6 a try :) Sorry its taken so long. For the past week I have not been on the top of things. Finals, girls, and family have all been crazy. lol I hope you all like version 2.0.6

danb00
Registered User
Posts: 1025
Joined: Sun Dec 15, 2002 9:41 pm
Location: Inside Mod:Extreme PHPBB
Contact:

Post by danb00 »

anyone doing a guide for those running subforums 2.0.5?
phpBBModded.com - Modding phpBB

TS_Death_Angel
Registered User
Posts: 4
Joined: Sun Mar 20, 2005 2:15 pm

Post by TS_Death_Angel »

Matt, the link to 2.0.6 doesn't seem to be working :(

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Okay the download link works now :) My site got moved onto a brand new server and all the folders premissions got all messed up. I'm sorry about that.

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Well I looked over the upgrade from 2.0.20 to 2.0.21 and I don't see anything that would mess with this MOD. I'm pretty sure its safe to say it well work with 2.0.21. I have also decide to submit this into the MOD database for the second time :) I think it should past. All the problem form the first time have been fixed. Let me look over my coding agian. Well it looks good to me, lets see what the MOD team have to say :D

I have created a Google Calender for this MOD :)
ImageImage

papango
Registered User
Posts: 52
Joined: Mon Nov 04, 2002 9:07 pm
Location: France
Contact:

Post by papango »

nedka wrote: Why don't use AJAX to re-update info about online users (every 1 min or custom) without refresh page (index.php) :d


i've done it on my forum. See on Portal at the bottom of the page.

So for the "random blog" section.

:)
Heavy PhpBB customisation.... to feed our needs http://www.tsenagasy.com

Locked

Return to “[2.0.x] MODs in Development”