[ABD] AJAXed (MMW)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
sportman1280
Registered User
Posts: 19
Joined: Mon Apr 04, 2005 10:00 pm
Contact:

Post by sportman1280 »

has development on this stopped?

colin_bb
Registered User
Posts: 104
Joined: Tue Feb 14, 2006 8:40 pm

Post by colin_bb »

When i view this in my nosebleed template, there's a huge blue section across the top of the page. Whats this, and how do i get rid of it?

I also get the following error when i delete a post using the quick (double-left-click) menu:

Code: Select all

r /> Warning: Missing argument 9 for delete_post() in C:\wamp\www\myDomain\www\forum\includes\functions_post.php on line 534
+:  
I also wanted to know if this (seamlessly) updates the who is online list (i can't tell yet as i'm developing locally), or should i install the ajax online updater mod to complement this?

estario
Registered User
Posts: 14
Joined: Mon Jan 01, 2007 1:38 pm

I can't get it to work.

Post by estario »

So I have installed everything, but the board is as before. There was one part in the install.mod file I couldn't understand:
How to:

Code: Select all

##   - How to add ajax to a phpBB page?
##    -> add this code above the "include($phpbb_root_path . 'includes/page_header.'.$phpEx);"
##-------------------------------------------------------------
##       include($phpbb_root_path . 'includes/sajax.'.$phpEx);
##       $sajax->request_type = 'POST';
##       $sajax->init('ajax.'.$phpEx);
##       $sajax->export('whatever'); // You can have more then one just put , 'whatever'
##       $sajax->handle_client_request();
##       $sajax->show_javascript();
##       $template->assign_block_vars('switch_ajax', array());
##-------------------------------------------------------------
##      All the stuff in between the dashes and minus the spaces and number signs.
What should I do? Do I need to enable anything in the ACP?

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw »

That part is for modders who want to add ajax to some other page in phpbb.
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three

estario
Registered User
Posts: 14
Joined: Mon Jan 01, 2007 1:38 pm

Why?

Post by estario »

Than why isn't it working? Has there been another complaint about a similar problem? I am pretty sure i did everything right.

colin_bb
Registered User
Posts: 104
Joined: Tue Feb 14, 2006 8:40 pm

Post by colin_bb »

I found the mod works perfectly in, and only in, subsilver. Any other template, and it acts like a monkey on lsd: erratic.

Like i say 3 posts up, i've got it on nosebleed, and not even the javascript works properly or the images show up, for example, in viewforumbody, where you can edit or move the post etc.

I'm waiting for version 3 of this before i add it to my live site, and i'm hoping it will be a bit more flexible.

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Hello everyone and Happy new year. I'm really sorry for the long wait. I was planning on having version 3.0.0 out before new years but didnt :( I've just recently moved and dont have internet at my new place yet. I'm hoping to get it soon. Version 3 well fix the alted letters, and be more better then the older versions. Right not I have about 85% of the base coding done and going to work on the permissions next. When i get my internet back I'll pick this MOD back up and finish it ASAP.

Thank you for anyone who is still hanging in there.

Jayso
Registered User
Posts: 168
Joined: Tue Dec 20, 2005 11:14 am
Location: Brisbane, Australia

Post by Jayso »

*=Matt=* wrote: Hello everyone and Happy new year. I'm really sorry for the long wait. I was planning on having version 3.0.0 out before new years but didnt :( I've just recently moved and dont have internet at my new place yet. I'm hoping to get it soon. Version 3 well fix the alted letters, and be more better then the older versions. Right not I have about 85% of the base coding done and going to work on the permissions next. When i get my internet back I'll pick this MOD back up and finish it ASAP.

Thank you for anyone who is still hanging in there.


I can't wait till this is released to the MODDB :D - I hope you can fix it up so other styles work too ;)
Jayso

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Jayson: When this MOD gets released I dont think it is going to work with any other templates besides the ones based off of subSilver. What I'm planning on doing is having people tell me what templates that dont work and I'll make a "patch/addon"(Seperate download) for the template to work with AJAXed.

Jayso
Registered User
Posts: 168
Joined: Tue Dec 20, 2005 11:14 am
Location: Brisbane, Australia

Post by Jayso »

*=Matt=* wrote: Jayson: When this MOD gets released I dont think it is going to work with any other templates besides the ones based off of subSilver. What I'm planning on doing is having people tell me what templates that dont work and I'll make a "patch/addon"(Seperate download) for the template to work with AJAXed.


Okay, thanks for the info :D

You look nearly done on this mod (judging by the first post with ur pretty completion bars :P - and the fact you're up to RC6) - will the mod be submitted after the release of V3 + testing?
Jayso

estario
Registered User
Posts: 14
Joined: Mon Jan 01, 2007 1:38 pm

Post by estario »

Isn't RedSilver Based on subSilver? Why isn't it working?

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Good news :D My mom said we might be getting internet today :D

Jayso: Will on the first post that is mainly features for 2.0. and is different from 3.0. I'm going to update the first post soon. And Yeah I'm going to resubmit it to the MODDB once I've done many tests on and other peoples comments.

estario: Sorry I should specify it better. What I mean is template that are just like subSliver but the images are different.

User avatar
*=Matt=*
Registered User
Posts: 389
Joined: Mon Dec 20, 2004 11:56 pm
Location: Oakdale, Wisconsin

Post by *=Matt=* »

Well we sorta have internet. My mom has it all paid for but we have to wait until Monday of weekend so the guy can come out and fix it. :( I'll be back Monday for sure and I'll try an planning on getting 3.0 out next weekend MAYBE.

Jayso
Registered User
Posts: 168
Joined: Tue Dec 20, 2005 11:14 am
Location: Brisbane, Australia

Post by Jayso »

*=Matt=* wrote: Well we sorta have internet. My mom has it all paid for but we have to wait until Monday of weekend so the guy can come out and fix it. :( I'll be back Monday for sure and I'll try an planning on getting 3.0 out next weekend MAYBE.


Can't wait :D - this'll be one of the greatest phpBB 2 mods :D
Jayso

Tuxman
Registered User
Posts: 420
Joined: Sun Jun 08, 2003 6:24 pm
Location: Germany
Contact:

Post by Tuxman »

Hi, I just wanted to tell you that I'm back and I'm able to create the German translation again... if you want to... just send me some eMail. :)
[ randomly phpBBing ]

Locked

Return to “[2.0.x] MODs in Development”