[RC1] The wGEric Store MOD vRC1 (15 November 2007)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Post by Prizem »

>>zachpl
if nothing else, you can try the sql updates

then for user-owned stores, would deleting the inventory place when the amount reaches 0 be good?

User avatar
alh31
Registered User
Posts: 72
Joined: Fri May 05, 2006 4:21 pm

Post by alh31 »

Prizem wrote: then for user-owned stores, would deleting the inventory place when the amount reaches 0 be good?


Yes :D

zachpl
Registered User
Posts: 175
Joined: Wed Nov 15, 2006 2:40 am

Post by zachpl »

well can someone help me step by step becuz im kinda a noob at this and the only way i can get the mods installed is though easymod :p I also have a few questions.

1. Is this the one i press? Image

2. this is what comes up what do i do?
Image

and if i have to do the sql updates thing i need help. thanks. -zach

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51984
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

No.

Store Mod
Configuration

zachpl
Registered User
Posts: 175
Joined: Wed Nov 15, 2006 2:40 am

Post by zachpl »

Where?

Image
Image

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51984
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

Image

zachpl
Registered User
Posts: 175
Joined: Wed Nov 15, 2006 2:40 am

Post by zachpl »

why dont I have that on mine? .... . . . . .

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51984
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

I dunno. Do you have the mod you think you have?

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Post by Prizem »

weird, his shows the setup from way back when, did you download the mod from the first post in this topic and upload those files to your server? did you perhaps upload files from an older version of the store mod?

zachpl
Registered User
Posts: 175
Joined: Wed Nov 15, 2006 2:40 am

Post by zachpl »

thats what i did.... lol.... Now I installed that and this came up when i press configureation


Please ensure that admin_store_list.php, admin_store_items.php,
admin_store_users.php, and admin_store_config.php have been deleted.
Store MOD will not function properly if those files aren't removed.

but those files are no where.

Btw i am thankful for u guyses help.

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Post by Prizem »

really? weird, have you ever installed any other version of the store mod before? the line for that is just a series of file_exists() functions checking if they exist in the /admin folder

zachpl
Registered User
Posts: 175
Joined: Wed Nov 15, 2006 2:40 am

Post by zachpl »

zachpl wrote: thats what i did.... lol.... Now I installed that and this came up when i press configureation


Please ensure that admin_store_list.php, admin_store_items.php,
admin_store_users.php, and admin_store_config.php have been deleted.
Store MOD will not function properly if those files aren't removed.

but those files are no where.

Btw i am thankful for u guyses help.


Did you just read my last post? lol. I installed 0.0.5 or whaterever that waw....

expx
Registered User
Posts: 111
Joined: Mon Oct 30, 2006 9:16 am

Post by expx »

Hi,
I was wondering if there is any kind of exploit for the wgeric store mod. I have a store on my site, where users can download files for points. A couple of people have managed to download files worth 20-300 points with 0 posts. (it pm's me when someone buys something from the store). I need this to be fixed so if anyone can help that would be great.

Thanks

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Post by Prizem »

>>zachpl
You installed 0.0.5? If you have, and have also deleted those two mentioned files in /admin, the only thing I could suggest is that you try uninstalling it except for the database. I dont know otherwise, since I'm pretty confident that file_exists works properly. You could, however, try copying and pasting the file_exists check from admin_store to your own test page and try it. If it still gives the error and you still dont believe the files exist, you could try accessing the file in php with something like fopen() or file()

>>expx
There is an exploit in versions < 0.2.1 that did not process purchases correctly. 0.2.1 was a critical release that fixed that. Now, there are no other exploits that we know of for the current version.

Greywing
Registered User
Posts: 37
Joined: Wed May 17, 2006 9:01 pm

Post by Greywing »

Follow all steps in the current install.txt or upgrade.txt, or run easyMOD.


.. does that mean it's compatible? :S

I tried it but I get some templating error (I think it's probably because we have some mods already installed, though).
Warning

FIND FAILED: In file [templates/xandblue/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu">

Post Reply

Return to “[2.0.x] MODs in Development”