[RC1] The wGEric Store MOD vRC1 (15 November 2007)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
GebbethKing
Registered User
Posts: 7
Joined: Wed Jan 24, 2007 6:51 pm

Post by GebbethKing »

huh...well this might be it...it shows a phpbb2 folder...i dont think i have one. im using free powerboards. did i just say something dumb? please help

GebbethKing
Registered User
Posts: 7
Joined: Wed Jan 24, 2007 6:51 pm

Post by GebbethKing »

oh, and should i have something like zend or dreamweaver downloaded?

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Post by Prizem »

What do you mean by powerboards? You need to have phpBB forums installed, which is why this website is phpBB.com.

Zend and Dreamweaver are completely unrelated.

Rizzn.
Registered User
Posts: 264
Joined: Wed Dec 28, 2005 9:53 am
Contact:

Post by Rizzn. »

You will need to contact Free Powerboards in reference to the use of their MOD Center. They will explain to you how to use it to install modifications to your forum. We cannot help you with that in any way. Their support staff should be able to help walk you through the steps needed to use that system.

Using they MOD Center should preclude the need for easyMOD, but I'm not absolutely certain about that. You should also ask them about it.
[Alpha] Store MOD (phpBB3)
- Support site forthcoming -
--------------------------------------
[RC1] wGEric Store MOD (phpBB2)
Additional Usable Items and Store MOD Support Forums (separate site)

GebbethKing
Registered User
Posts: 7
Joined: Wed Jan 24, 2007 6:51 pm

Post by GebbethKing »

oh wow im dumb...okay, i got phpbb downloaded. so now, when i click admin, theres no mod folder...

Rizzn.
Registered User
Posts: 264
Joined: Wed Dec 28, 2005 9:53 am
Contact:

Post by Rizzn. »

GebbethKing wrote: oh wow im dumb...okay, i got phpbb downloaded. so now, when i click admin, theres no mod folder...
Rizzn. wrote: You will need to contact Free Powerboards in reference to the use of their MOD Center. They will explain to you how to use it to install modifications to your forum. We cannot help you with that in any way. Their support staff should be able to help walk you through the steps needed to use that system.
Look, I've even gotten the link to their support page for you: http://s3.freepowerboards.com/support/

And here's their support number: 1 (860) 331-8207
[Alpha] Store MOD (phpBB3)
- Support site forthcoming -
--------------------------------------
[RC1] wGEric Store MOD (phpBB2)
Additional Usable Items and Store MOD Support Forums (separate site)

falafelboy
Registered User
Posts: 29
Joined: Fri Oct 06, 2006 10:36 pm
Location: canada
Contact:

Post by falafelboy »

Hi guys,

Amazing mod. Thank you for all the great work.

One issue: I tried uploading a pdf file to my store_downloads folder and then when I try to re-download the file (via cpanel) and open it, it tells me that the file is damaged.

Any ideas? I'm assuming that if I can't download via cpanel, then my users won't be able to either via the store mechanism.

I tried uploading the file via FTP and the Cpanel upload with same result.

thanks.

p.s. I tried uploading an mp3 file and worked beautifully.

Rizzn.
Registered User
Posts: 264
Joined: Wed Dec 28, 2005 9:53 am
Contact:

Post by Rizzn. »

I have no problems with downloading a pdf file off of my server through store mod. I would suggest creating the item and giving yourself one via the ACP to test the download yourself. If it works for you, then it should work for the rest of your members too.
[Alpha] Store MOD (phpBB3)
- Support site forthcoming -
--------------------------------------
[RC1] wGEric Store MOD (phpBB2)
Additional Usable Items and Store MOD Support Forums (separate site)

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Post by Peter77sx »

Hello, can members download items? pics, avys ect?

falafelboy
Registered User
Posts: 29
Joined: Fri Oct 06, 2006 10:36 pm
Location: canada
Contact:

Post by falafelboy »

Rizzn. wrote: I have no problems with downloading a pdf file off of my server through store mod. I would suggest creating the item and giving yourself one via the ACP to test the download yourself. If it works for you, then it should work for the rest of your members too.


Sorry for wasting your time. I guess I shouldn't be making assumptions. Via cpanel, the download does not work.

But it does via the normal functioning from within the forum.

thanks for your hard work. This is one my favorites mods.

Rizzn.
Registered User
Posts: 264
Joined: Wed Dec 28, 2005 9:53 am
Contact:

Post by Rizzn. »

Peter77sx wrote: Hello, can members download items? pics, avys ect?
Downloading items has worked for the past few releases without problem.

If you are referring to an item that enables the user to have an avatar or something when they otherwise would not, that is something you would still need to code yourself. Alternatively, you can make a request for such an item on our support forum.


falafelboy: Not a problem.
[Alpha] Store MOD (phpBB3)
- Support site forthcoming -
--------------------------------------
[RC1] wGEric Store MOD (phpBB2)
Additional Usable Items and Store MOD Support Forums (separate site)

Jenssperro
Registered User
Posts: 1
Joined: Sun Jan 28, 2007 3:44 pm

Help

Post by Jenssperro »

Can someone please help me:

My Easy Mod had problems with it...

FIND FAILED: In file [templates/wow_alliance/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu">

MOD script line #466 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/wow_royal/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu">

MOD script line #466 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/profile_add_body.tpl] could not find:

<tr>
<td class="row1"><span class="gen">{L_POPUP_ON_PRIVMSG}:</span><br /><span class="gensmall">{L_POPUP_ON_PRIVMSG_EXPLAIN}</span></td>
<td class="row2">
<input type="radio" name="popup_pm" value="1" {POPUP_PM_YES} />
<span class="gen">{L_YES}</span>&nbsp;&nbsp;
<input type="radio" name="popup_pm" value="0" {POPUP_PM_NO} />
<span class="gen">{L_NO}</span></td>
</tr>

MOD script line #486 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/wow_royal/profile_add_body.tpl] could not find:

<tr>
<td class="row1"><span class="gen">{L_POPUP_ON_PRIVMSG}:</span><br /><span class="gensmall">{L_POPUP_ON_PRIVMSG_EXPLAIN}</span></td>
<td class="row2">
<input type="radio" name="popup_pm" value="1" {POPUP_PM_YES} />
<span class="gen">{L_YES}</span>&nbsp;&nbsp;
<input type="radio" name="popup_pm" value="0" {POPUP_PM_NO} />
<span class="gen">{L_NO}</span></td>
</tr>

MOD script line #486 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/wow_royal/profile_view_body.tpl] could not find:

{CASH}

MOD script line #517 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/wow_alliance/viewtopic_body.tpl] could not find:

<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}">

MOD script line #538 :: FAQ :: Report


Error Detail

Warning

IN-LINE FIND FAILED: In file [templates/wow_royal/viewtopic_body.tpl] could not find:

<br />{postrow.CASH}

MOD script line #550 :: FAQ :: Report


now I have only shop icons by subsilver

honie
Registered User
Posts: 54
Joined: Sat May 22, 2004 5:51 pm

Post by honie »

I still can not get this to work, in the admin it is still just wanting me to install. Is there a way to remove the installer from the admin files ?

Rizzn.
Registered User
Posts: 264
Joined: Wed Dec 28, 2005 9:53 am
Contact:

Post by Rizzn. »

Jenssperro: Based on the first few errors, it looks as if you are using a template that does not have the same basic elements as the default subSilver. To install Store MOD, you're going to have to manually update the appropriate template files.

Based on the last few errors, it appears that Cash MOD is not installed. If you don't have it installed, then you should check the installation steps on page 1 of this thread.

honie wrote: I still can not get this to work, in the admin it is still just wanting me to install. Is there a way to remove the installer from the admin files ?
I've sent you a PM. Please check it.
[Alpha] Store MOD (phpBB3)
- Support site forthcoming -
--------------------------------------
[RC1] wGEric Store MOD (phpBB2)
Additional Usable Items and Store MOD Support Forums (separate site)

honie
Registered User
Posts: 54
Joined: Sat May 22, 2004 5:51 pm

Post by honie »

It now works ! Thank you so much to Rizzn for going above and beyond in helping me resolve this !

Post Reply

Return to “[2.0.x] MODs in Development”