[RC1] The wGEric Store MOD vRC1 (15 November 2007)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
chery
Registered User
Posts: 95
Joined: Wed Mar 22, 2006 7:30 pm
Location: terra australia
Contact:

Constant variables not installed successfully!

Post by chery »

Everything was working great until: Constant variables not installed successfully! when I tried to go to /shop.php.

Please help as I'm not sure what is going on???

i did accidentally delete the mod and then reinstalled it. However it doesn't seem to reinstall correctly as after I got the variables message I tried uninstalling it again and got errors that certain fields didn't exist.

Is there a current mysql db file that I can use to check what is there and what isn't? All of the links I've found for the sql files are extinct.

chery
Registered User
Posts: 95
Joined: Wed Mar 22, 2006 7:30 pm
Location: terra australia
Contact:

Re: Constant variables not installed successfully!

Post by chery »

chery wrote:Everything was working great until: Constant variables not installed successfully! when I tried to go to /shop.php.

Please help as I'm not sure what is going on???

i did accidentally delete the mod and then reinstalled it. However it doesn't seem to reinstall correctly as after I got the variables message I tried uninstalling it again and got errors that certain fields didn't exist.

Is there a current mysql db file that I can use to check what is there and what isn't? All of the links I've found for the sql files are extinct.
I found the sql tables but it didn't help.

I've uninstalled the mod and reinstalled it several times now and I still get this error.
Can anyone tell me what file is causing the problem so I can at least install a vanilla version then add all my mod edits to it (not that I'm looking forward to that but I really want this mod). Everything else on my board is working fine I think.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51980
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Constant variables not installed successfully!

Post by Brf »

chery wrote: Constant variables
I would assume that is refering to the additions to constants.php

chery
Registered User
Posts: 95
Joined: Wed Mar 22, 2006 7:30 pm
Location: terra australia
Contact:

Re: Constant variables not installed successfully!

Post by chery »

Brf wrote:
chery wrote: Constant variables
I would assume that is refering to the additions to constants.php
yes I'm going through it now.

chery
Registered User
Posts: 95
Joined: Wed Mar 22, 2006 7:30 pm
Location: terra australia
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by chery »

I have even used a vanilla constants.php and then reapplied the edits for all my mods. I don't know what else to do - can someone help please?

User avatar
Jackanape
Registered User
Posts: 1076
Joined: Wed Oct 13, 2004 6:01 am
Location: Capitol of the Great State of New York
Name: Jack Drury
Contact:

Re: Constant variables not installed successfully!

Post by Jackanape »

chery wrote:Everything was working great until: Constant variables not installed successfully! when I tried to go to /shop.php.
In this mod, the file is /store.php. You're having trouble with Zarath's SHOP mod, and are confusing the two...I'm not sure where to go for Shop mod support.

May I recommend switching to this mod?
~Extending the rule of meticulous exactitude to exaspirating punctillio...still.~
Treat your phpBB like a member of the family--Update and MOD her by hand, with HTML-Kit
: : Wanna Talk Poker? : : Image : :

chery
Registered User
Posts: 95
Joined: Wed Mar 22, 2006 7:30 pm
Location: terra australia
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by chery »

My apologies I was working for 32 hours straight and got completely confused - I am using this mod I just got myself completely confused.

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by Prizem »

Yeah, you should try fully uninstalling the shop mod and see how that goes.

TheEmperor
Registered User
Posts: 21
Joined: Fri Apr 06, 2007 1:25 am

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by TheEmperor »

When i try and change a users username on my forum i get the following error

Code: Select all

General Error
Admin_user_fail

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE user_id = 5' at line 3

UPDATE phpbb_users SET username = 'Valkynaz', user_email = '************@hotmail.com', user_icq = '', user_website = 'http://www.***.net/forum', user_occ = 'Writer', user_from = 'Canada', user_interests = '', user_sig = 'People are stupid; given proper motivation, almost anyone will believe almost anything. Because people are stupid, they will believe a lie because they want to believe it’s true, or because they are afraid it might be true', user_viewemail = 0, user_aim = '', user_yim = '', user_msnm = '', user_attachsig = 1, user_sig_bbcode_uid = '92f6ac4768', user_allowsmile = 1, user_allowhtml = 0, user_allowavatar = 1, user_allowbbcode = 1, user_allow_viewonline = 1, user_notify = 0, user_allow_pm = 1, user_notify_pm = 1, user_popup_pm = 1, user_lang = 'english', user_style = 1, user_timezone = 0, user_dateformat = 'D M d, Y g:i a', user_active = 1, user_rank = 2, stores_max = WHERE user_id = 5

Line : 713
File : admin_users.php
I do not know php or sql very well so your help would be greatly apperciated

I was told in another thread to ask for help here

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by Prizem »

check that you installed the directions correctly for admin/admin_users.php (especially for the first direction there), as well as templates/subSilver/admin/user_edit_body.tpl

TheEmperor
Registered User
Posts: 21
Joined: Fri Apr 06, 2007 1:25 am

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by TheEmperor »

I actually do not use this store, i install it tested it and did not like. It has been uninstalled for about a month.

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by Prizem »

Well then read the instructions backwards to uninstall it. If you continue to have problems, please reread the instructions for the files I mentioned. Everything you need is there.

dragon2h
Registered User
Posts: 10
Joined: Tue Jun 12, 2007 12:01 am

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by dragon2h »

Three errors and I have no idea what to do

Warning

FIND FAILED: In file [templates/Chronicles/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu">

MOD script line #468 :: FAQ :: Report


-------------------------------------------------------------------------------------------------------------------------------

Warning

FIND FAILED: In file [templates/Chronicles/profile_add_body.tpl] could not find:

<tr>
<td class="row1"><span class="gen">{L_POPUP_ON_PRIVMSG}:</span><br /><span class="gensmall">{L_POPUP_ON_PRIVMSG_EXPLAIN}</span></td>
<td class="row2">
<input type="radio" name="popup_pm" value="1" {POPUP_PM_YES} />
<span class="gen">{L_YES}</span>&nbsp;&nbsp;
<input type="radio" name="popup_pm" value="0" {POPUP_PM_NO} />
<span class="gen">{L_NO}</span></td>
</tr>

MOD script line #488 :: FAQ :: Report


-------------------------------------------------------------------------------------------------------------------------------


Warning

FIND FAILED: In file [templates/Chronicles/admin/user_edit_body.tpl] could not find:

<tr>
<td class="row1"><span class="gen">{L_SELECT_RANK}</span></td>
<td class="row2"><select name="user_rank">{RANK_SELECT_BOX}</select></td>
</tr>

MOD script line #562 :: FAQ :: Report

Prizem
Registered User
Posts: 249
Joined: Sun Sep 07, 2003 9:14 am
Contact:

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by Prizem »

It's not finding those sections in your template files, since the template isn't the standard one. Manually go in and use the instructions for:
  • templates/Chronicles/overall_header.tpl
  • templates/Chronicles/profile_add_body.tpl
  • templates/Chronicles/admin/user_edit_body.tpl

dragon2h
Registered User
Posts: 10
Joined: Tue Jun 12, 2007 12:01 am

Re: [BETA] The wGEric Store MOD v0.2.3 (21 May 2007)

Post by dragon2h »

I dont know HOW to though. I hardly know anything... im stupid like that

Post Reply

Return to “[2.0.x] MODs in Development”