[DEV] PhpbbMyChat (phpMyChat Integration) V0.1.4

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Newbie Needing Help Please

Post by Dolfan23 » Tue Jan 28, 2003 8:23 am

Okay today is my 3rd day having PHPBB and I am trying to get this chat to work, but I am having some problems. I would appreciate any help that anyone can give. I believe that I have copied every file to the appropriate area and when I try and go to www.dolfanz.com/phpbb2/chat I get this......
Warning: Access denied for user: 'username@localhost' (Using password: YES) in /home/virtual/site7/fst/var/www/html/phpBB2/chat/lib/database/mysql.lib.php3 on line 26

Warning: MySQL Connection Failed: Access denied for user: 'username@localhost' (Using password: YES) in /home/virtual/site7/fst/var/www/html/phpBB2/chat/lib/database/mysql.lib.php3 on line 26
Database error: Link_ID == false, connect failed
MySQL error: 0 ()
Session halted.


I tried to open the config.php file for PHPBB but the file is blank so I have no idea what is has for my database name and I am not sure what to use. I believe that I am using the wrong user name, password, and database name in the config.lib file for the chat, which I have left at the default settings. Any help would be greatly appreciated.

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Post by Nathan_Anderson » Tue Jan 28, 2003 8:33 am

Is the forum actually working?

Nathan.

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Yes

Post by Dolfan23 » Tue Jan 28, 2003 8:43 am

Yes the forums work, but I just installed them and havent notified the people I plan on inviting from various sites yet....

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Post by Nathan_Anderson » Tue Jan 28, 2003 4:11 pm

Hmm,

So the /phpBB2/config.php file is empty? Or did you perhaps try to open a config.php file in a different directory.

Nathan.

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Oh boy

Post by Dolfan23 » Tue Jan 28, 2003 4:39 pm

well I am stupid. This is the first time I have ever tried to do anything with database coding and I hadnt thought for a second about PHPBB writing to the config file so I hadnt downloaded the version of the config file that was on the server, I had only been opening the original file. I am going to try and get this working now with the information from that config file and I will let you know if that works. Damn newbies right lol.

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Re: Oh boy

Post by Nathan_Anderson » Tue Jan 28, 2003 4:53 pm

Dolfan23 wrote: well I am stupid.


Nah, you aren't stupid; you just didn't know. Everybody has to start somewhere. :)
Damn newbies right lol.


Newbies are cool. They sometimes come up with some really cool ideas! As long as a person is willing to work with me on my suggestions when I am trying to help -- then I don't care if s/he is a newie of an experinced coder. :)

Nathan.

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Damn

Post by Dolfan23 » Tue Jan 28, 2003 4:56 pm

Okay so I updated the config.lib file and uploaded it and now I am getting this message when I go to www.dolfanz.com/phpBB2/chat/
Database error: Invalid SQL: DELETE FROM phpbb_c_messages WHERE m_time < 1043426899
MySQL error: 1146 (Table 'layerfx_com.phpbb_c_messages' doesn't exist)
Session halted.


What does this mean? Hey I appreciate you taking the time to help me Nathan.

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Post by Nathan_Anderson » Tue Jan 28, 2003 5:47 pm

When you installed the chat did you remember to set in the config.li.php file the:

From:

Code: Select all

define("C_MSG_TBL", 'c_messages');    
define("C_USR_TBL", 'c_users');
define("C_REG_TBL", 'c_reg_users');
define("C_BAN_TBL", 'c_ban_users');
To:

Code: Select all

define("C_MSG_TBL", 'phpbb_c_messages');    
define("C_USR_TBL", 'phpbb_c_users');
define("C_REG_TBL", 'phpbb_c_reg_users');
define("C_BAN_TBL", 'phpbb_c_ban_users');
----
Otherwise your chat tables aren't prefixed. Like the phpbb portion expects them to be.

Nathan.

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Yes here is what I have

Post by Dolfan23 » Tue Jan 28, 2003 5:52 pm

define("C_MSG_TBL", 'phpbb_c_messages'); // Name of the table where messages are stored
define("C_USR_TBL", 'phpbb_c_users'); // Name of the table where user names are stored
define("C_REG_TBL", 'phpbb_c_reg_users'); // Name of the table where registered users are stored
define("C_BAN_TBL", 'phpbb_c_ban_users'); // Name of the table where banished users are stored


I checked my config file for phpbb and its set to
$table_prefix = 'phpbb_';


So everything should be right, I think.

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Re: Yes here is what I have

Post by Nathan_Anderson » Tue Jan 28, 2003 11:02 pm

Did you install phpmychat and get it working before doing my mod to it?

Nathan.

User avatar
Balint
Registered User
Posts: 952
Joined: Tue Aug 06, 2002 2:19 pm
Location: Germany
Contact:

Post by Balint » Tue Jan 28, 2003 11:06 pm

Hello!

BTW: Thanks Nathan, the fix is correct and solved my problem too.


Regards,
Bálint

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Well

Post by Dolfan23 » Wed Jan 29, 2003 2:13 am

Nathan_Anderson wrote: Did you install phpmychat and get it working before doing my mod to it?

Nathan.


I installed it and havent done the mods to it, as far I know I havent anyway. When you said mod you mean modifying the code right? I havent modified any code other than adding the phpbb_ line like you said to do. But to answer your question, no, I havent ever had it working yet.

Nathan_Anderson
Registered User
Posts: 755
Joined: Tue Mar 19, 2002 5:04 pm
Contact:

Post by Nathan_Anderson » Wed Jan 29, 2003 5:16 am

When you installed the phpmychat; you need to run the setup script so that it creates those tables.

Nathan.

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Okay I am thinking that this is what my problem is

Post by Dolfan23 » Wed Jan 29, 2003 6:30 am

Nathan_Anderson wrote: When you installed the phpmychat; you need to run the setup script so that it creates those tables.

Nathan.


I went ahead and deleted the entire chat folder and its contents from my server and have re-uploaded the chat folder, with the sub-folders set up the way its mentioned in the install.txt file. However I am wondering what files go in what directories though. When I unzipped it there werent any sub-folders, just files and I created the sub-folders according to the install.txt file. Thats what I think the main problem is right now, I just dont have the right files in the right place. Would it be possible to have a list of which files go in which directory?

Dolfan23
Registered User
Posts: 25
Joined: Tue Jan 28, 2003 8:14 am

Well

Post by Dolfan23 » Wed Jan 29, 2003 7:33 am

Well I reuploaded the entire directory and then went page by page fixing errors and refreshing the pages and have gotten the chat to work now. I am going to try and install your mods now Nathan and hopefully get those working and then hopefully work on making it look a little more pleasant than it is by default, if thats even possible to change the style. Thanks so much for your help and I will keep you updated as to the status of how its going. Thanks again, you are great!!

Locked

Return to “[2.0.x] MODs in Development”