[RC4] GYM Sitemaps & RSS (aka mx Google Sitemaps)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

reggien wrote: Please forgive me if this sounds stupid, but have I got my sitemap set up correctly:

http://www.talkingfooty.com/forums/sitemap.php

I found the install instructions difficult to follow. Does what I have in place look correct?


It works perfet ;)

Now two things :

You should have this folder structure in your phpbb install folder :

mx_ggsitemaps/includes/

with a blank index.html file in it plus two php files (all other do not apply to your case) : index_forum.php and forum_sitemap.php.

Then, since your site has also pages at the root level, you can follow the provided instruction to rather put your sitemap.php file at the root level (need to edit two lines in it to do so) so you can plan to add aditional sitemaps for the rest of your urls (the ones outside the forum) as my small tutorial explains.

But you can also stay like this for now, submit your sitemap.php, this won't geopardize anything if you decide to use this modular sitemap system for all your site later (since you can change sitemaps in your google account there are no problems doing this).

++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
Blue Ninja
Registered User
Posts: 52
Joined: Sun Feb 19, 2006 4:58 am
Contact:

Unsupported format only on some forums?

Post by Blue Ninja »

Google Sitemaps gives me this error, and I'm not sure why:

Unsupported file format in Sitemap http://blueninja.boldlygoingnowhere.org ... php?fid=29

Unsupported file format in Sitemap http://blueninja.boldlygoingnowhere.org ... .php?fid=3

But, it doesn't seem to complain about any of the other forums in the main sitemap. When I compare some of those URLs manually, the XML looks about the same, so I'm not sure what the problem is. Any thoughts?
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

http://www.smart-it-consulting.com/inte ... /index.htm
Schema validating with XSV 2.10-1 of 2005/04/22 13:10:49

* Target: http://blueninja.boldlygoingnowhere.org ... php?fid=29
(Real name: http://blueninja.boldlygoingnowhere.org ... php?fid=29
Length: 989 bytes

Server: Apache)
* docElt: {http://www.google.com/schemas/sitemap/0.84}urlset
* Validation was strict, starting with type [Anonymous]
* schemaLocs: http://www.google.com/schemas/sitemap/0.84 -> http://www.google.com/schemas/sitemap/0.84/sitemap.xsd
* The schema(s) used for schema-validation had
no errors
* No schema-validity problems were found in the target


Schema resources involved

Attempt to load a schema document from
http://www.google.com/schemas/sitemap/0.84/sitemap.xsd
(source: schemaLoc) for
http://www.google.com/schemas/sitemap/0.84,
succeeded


and
Schema validating with XSV 2.10-1 of 2005/04/22 13:10:49

* Target: http://blueninja.boldlygoingnowhere.org ... .php?fid=3
(Real name: http://blueninja.boldlygoingnowhere.org ... .php?fid=3
Length: 1593 bytes

Server: Apache)
* docElt: {http://www.google.com/schemas/sitemap/0.84}urlset
* Validation was strict, starting with type [Anonymous]
* schemaLocs: http://www.google.com/schemas/sitemap/0.84 -> http://www.google.com/schemas/sitemap/0.84/sitemap.xsd
* The schema(s) used for schema-validation had
no errors
* No schema-validity problems were found in the target


Schema resources involved

Attempt to load a schema document from
http://www.google.com/schemas/sitemap/0.84/sitemap.xsd
(source: schemaLoc) for
http://www.google.com/schemas/sitemap/0.84,
succeeded


And I have no errors in my google accounts after many sitemap downloads, so I guess google is the one to blame for mystaking here.

Tell me though if this continues, and also consider writting them a mail if it lasts too long.

++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
Blue Ninja
Registered User
Posts: 52
Joined: Sun Feb 19, 2006 4:58 am
Contact:

Post by Blue Ninja »

Ok, thanks - I didn't *think* it was something on my end - I was just looking for confirmation that I'm not crazy :-)
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

Blue Ninja wrote: Ok, thanks - I didn't *think* it was something on my end - I was just looking for confirmation that I'm not crazy :-)


hehe, welcome on board ;)

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
reggien
Registered User
Posts: 84
Joined: Sat Feb 12, 2005 5:59 am

Post by reggien »

dcz wrote:
reggien wrote:Please forgive me if this sounds stupid, but have I got my sitemap set up correctly:

http://www.talkingfooty.com/forums/sitemap.php

I found the install instructions difficult to follow. Does what I have in place look correct?


It works perfet ;)


Great. Many thanks for your feedback. :D
dcz wrote: Now two things :

You should have this folder structure in your phpbb install folder :

mx_ggsitemaps/includes/

with a blank index.html file in it plus two php files (all other do not apply to your case) : index_forum.php and forum_sitemap.php.


I have mx_ggsitemaps/includes/ folder set up with the index.html file, index_forum.php and sitemap_forum.php. Correct?
dcz wrote: Then, since your site has also pages at the root level, you can follow the provided instruction to rather put your sitemap.php file at the root level (need to edit two lines in it to do so) so you can plan to add aditional sitemaps for the rest of your urls (the ones outside the forum) as my small tutorial explains.


I don't really understand how I'm supposed to do that. Is this what you refer to in your first post of this thread with your instructions for index_newsitemap.php and sitemap_newsitemap.php ? If so, that's where I get all confused. :oops:

I see from the install instructions that I should also be looking at lines 40 and 69 in sitemap.php. Not sure what I'm meant to do to set the correct path though. Perhaps if what you say below is correct, I should just leave it.
dcz wrote: But you can also stay like this for now, submit your sitemap.php, this won't geopardize anything if you decide to use this modular sitemap system for all your site later (since you can change sitemaps in your google account there are no problems doing this).


So if I leave it as it is currently, I should still get indexed by Google?

Once again many thanks for your advice.
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

Don't worry you did all well, and yes I am currently trying to figure out what could be the best install file to provide ;)

And your sitemap is 100% efficient as is, the newsitemap thing is for adding content in the same system, which is not a must at all, since you can register several sitemaps you could think of hard code one for your root level pages (the sitemap system only allows url from the same or under levels, so installed in the forum folder it cannot be used for url starting from root)

But if you don't have many other pages, or if they are pretty much static, then, you can just do nothing, those pages are to be found anyway by bots (root url are easyer to find for them).

The modular part is really helpfull for coder, since it's easy to add modules (they connect by themself, no need to edit the core file), which I have done for kb mod and mx portal (plan to add other mod's support, why not the blog mod or any other content mod).

And, if for example you run phpbb with another portal or cms script, then you can write down an add on for this system also, just a matter of writting a script to get proper infos.

My small tutorial is just ment to show basics about how to do so. It shows how you could add an hard coded url list in the system so that those url would appear in the same sitemap index and would have it's own sitemap.

As I told you, everything is ok with your sitemap, and there is no problem if latter, once you decide you need to add other url in it, you choose to move it to do so, since you can re register it at google without issues.

So I'd say, enjoy, and know you could ask this mod a bit more if needed ;)

And yes google should index your board at least a lot easyer, make sure you get rid of SIDs though. But as previously said this also depends on other parameter, google sitemaps should help google to find topics url in your forums.


++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
reggien
Registered User
Posts: 84
Joined: Sat Feb 12, 2005 5:59 am

Post by reggien »

dcz wrote: So I'd say, enjoy, and know you could ask this mod a bit more if needed ;)

And yes google should index your board at least a lot easyer, make sure you get rid of SIDs though. But as previously said this also depends on other parameter, google sitemaps should help google to find topics url in your forums.


Excellent. I think I'll just leave it as is and keep my fingers crossed that google starts indexing the topics rather than just the index as is presently the case. Did you getting SIDs when you had a look at my site? I thought I had them removed. :?

Anyway thanks again for all your help and this great mod to assist google.
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Post by dcz »

No SId I confirm ;)

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
SHH
Registered User
Posts: 52
Joined: Wed Feb 22, 2006 1:06 am
Contact:

Hi, just wanted to see if I did everything correctly...

Post by SHH »

Have SEO mod rewrite activated


www.domain.com/forum (have sitemap.php, sitemap_forum.php and .htaccess in this folder)

Code: Select all

Options +FollowSymlinks

RewriteEngine On 
RewriteCond %{HTTP_HOST} !^.*domain\.com [NC]
RewriteRule (.*) http://www.domain.com/forum/$1 [R=301,L] 

RewriteRule ^forums.* index.php [L,NC]
RewriteRule ^post-([0-9]*).html&highlight=([a-zA-Z0-9]*) viewtopic.php?p=$1&highlight=$2 [L,NC]
RewriteRule ^post-([0-9]*).* viewtopic.php?p=$1 [L,NC]
RewriteRule ^view-poll([0-9]*)-([0-9]*)-([a-zA-Z]*).* viewtopic.php?t=$1&postdays=$2&postorder=$3&vote=viewresult [L,NC]
RewriteRule ^about([0-9]*).html&highlight=([a-zA-Z0-9]*) viewtopic.php?t=$1&highlight=$2 [L,NC]
RewriteRule ^about([0-9]*).html&view=newest viewtopic.php?t=$1&view=newest [L,NC]
RewriteRule ^about([0-9]*)-([0-9]*)-([a-zA-Z]*)-([0-9]*).* viewtopic.php?t=$1&postdays=$2&postorder=$3&start=$4 [L,NC]
RewriteRule ^about([0-9]*)-([0-9]*).* viewtopic.php?t=$1&start=$2 [L,NC]
RewriteRule ^about([0-9]*).* viewtopic.php?t=$1 [L,NC]
RewriteRule ^about([0-9]*).html viewtopic.php?t=$1&start=$2&postdays=$3&postorder=$4&highlight=$5 [L,NC]
RewriteRule ^mark-forum([0-9]*).html* viewforum.php?f=$1&mark=topics [L,NC]
RewriteRule ^updates-topic([0-9]*).html* viewtopic.php?t=$1&watch=topic [L,NC]
RewriteRule ^stop-updates-topic([0-9]*).html* viewtopic.php?t=$1&unwatch=topic [L,NC]
RewriteRule ^forum-([0-9]*).html viewforum.php?f=$1 [L,NC]
RewriteRule ^forum-([0-9]*).* viewforum.php?f=$1 [L,NC]
RewriteRule ^topic-([0-9]*)-([0-9]*)-([0-9]*).* viewforum.php?f=$1&topicdays=$2&start=$3 [L,NC]
RewriteRule ^ptopic([0-9]*).* viewtopic.php?t=$1&view=previous [L,NC]
RewriteRule ^ntopic([0-9]*).* viewtopic.php?t=$1&view=next [L,NC]

RewriteRule ^sitemaps.xml$ sitemap.php [L]
RewriteRule ^mx-sitemap.xml$ sitemap.php?mx [L]
RewriteRule ^forum-sitemap-([0-9]+).xml$ sitemap.php?fid=$1 [L]
RewriteRule ^kb-sitemap-([0-9]+).xml$ sitemap.php?kbid=$1 [L]
RewriteRule ^sitemap-forum.xml$ sitemap.php?forum [L]
RewriteRule ^sitemap-kbcat.xml$ sitemap.php?kbcat [L]
My mode rewrite is working fine for converting php-->html

But when I go to, http://www.domain.com/forum/sitemap.php
it says "No sitemaps" (I just submitted to google??)

Also not sure what to make of this

Code: Select all

Module Installation Information
Installation mx Google Sitemaps : Default Param.

Building required dB tables

[Added/Updated] line: 1 , DROP TABLE IF EXISTS phpbb_ggsitemap_config
[Added/Updated] line: 2 , CREATE TABLE phpbb_ggsitemap_config( config_name varchar(255) NOT NULL, config_value varchar(255) NOT NULL, PRIMARY KEY (config_name) )
[Added/Updated] line: 3 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_sql_limit', '200')
[Added/Updated] line: 4 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_url_limit', '2500')
[Added/Updated] line: 5 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_sort', 'DESC')
[Added/Updated] line: 6 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_rewrited', 'FALSE')
[Added/Updated] line: 7 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_announce_priority', '0.5')
[Added/Updated] line: 8 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_default_priority', '1.0')
[Added/Updated] line: 9 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_sticky_priority', '0.75')
[Added/Updated] line: 10 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_limitdown', '5')
[Added/Updated] line: 11 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_limitup', '5')
[Added/Updated] line: 12 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_kb_mx_page', 'FALSE')
[Added/Updated] line: 13 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_c_info', '(C) 2006 dcz - http://www.phpbb-seo.com/')
[Added/Updated] line: 14 , INSERT INTO phpbb_ggsitemap_config VALUES ('sitemap_ver', 'v1.0.0RC1')

If you get some Errors, Already Added or Updated messages, relax, this is normal when updating modules
Please advise...


In your instructions
copy sitemap.php to sitemap.php

copy mx_ggsitemaps/language/lang_english/lang_google_sitemap.php to language/lang_english/lang_google_sitemap.php
copy mx_ggsitemaps/language/lang_french/lang_google_sitemap.php to language/lang_french/lang_google_sitemap.php
copy mx_ggsitemaps/admin/admin_mx_ggsitemap.php to admin/admin_mx_ggsitemap.php
copy mx_ggsitemaps/includes/index_forum.php to mx_ggsitemaps/includes/index_forum.php
copy mx_ggsitemaps/includes/sitemap_forum.php to mx_ggsitemaps/includes/sitemap_forum.php
copy mx_ggsitemaps/db_install.php to db_install.php



Do we need to upload?
\templates\subSilver\admin\admin_mx_ggsitemap.tpl

I uploaded it and it shows up in the admin panel....

Cheers,
Thanks for your time spent on this mod.
SHH
Registered User
Posts: 52
Joined: Wed Feb 22, 2006 1:06 am
Contact:

Con't

Post by SHH »

Got this error from google which doesn't say to much...

Sitemap Errors
Error Detail
Unsupported file format Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit. More
littleking57
Registered User
Posts: 3
Joined: Thu Feb 16, 2006 11:09 pm

im getting errors too

Post by littleking57 »

http://www.huntohio.net/forums/google.php

Invalid date (Line 47) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 103) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 110) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 152) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 159) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 208) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 341) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 439) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 516) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
Invalid date (Line 523) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
littleking57
Registered User
Posts: 3
Joined: Thu Feb 16, 2006 11:09 pm

also this:

Post by littleking57 »

http://www.fishingohio.net/forums/google.php


Sitemap Errors
Error Detail
URL not allowed (Line 3) with URL http://www.huntohio.net/forums/viewtopic.php?t=1294 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 10) with URL http://www.huntohio.net/forums/viewtopic.php?t=1293 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 17) with URL http://www.huntohio.net/forums/viewtopic.php?t=1292 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 24) with URL http://www.huntohio.net/forums/viewtopic.php?t=1291 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 31) with URL http://www.huntohio.net/forums/viewtopic.php?t=1289 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 38) with URL http://www.huntohio.net/forums/viewtopic.php?t=1288 This url is not allowed for a Sitemap at this location. More
Invalid date (Line 47) An invalid date was found. Please see How do I specify time? for more information before resubmitting. More
URL not allowed (Line 45) with URL http://www.huntohio.net/forums/viewtopic.php?t=1287 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 52) with URL http://www.huntohio.net/forums/viewtopic.php?t=1286 This url is not allowed for a Sitemap at this location. More
URL not allowed (Line 59) with URL http://www.huntohio.net/forums/viewtopic.php?t=1285 This url is not allowed for a Sitemap at this location. More
dcz
Registered User
Posts: 787
Joined: Sun Feb 13, 2005 5:37 am
Contact:

Re: Hi, just wanted to see if I did everything correctly...

Post by dcz »

SHH wrote: Have SEO mod rewrite activated


www.domain.com/forum (have sitemap.php, sitemap_forum.php and .htaccess in this folder)

My mode rewrite is working fine for converting php-->html

But when I go to, http://www.domain.com/forum/sitemap.php
it says "No sitemaps" (I just submitted to google??)

Do we need to upload?
\templates\subSilver\admin\admin_mx_ggsitemap.tpl

I uploaded it and it shows up in the admin panel....

Cheers,
Thanks for your time spent on this mod.


Hello,

You are welcome ;)

So you should have this folder structure in your phpbb install folder :

mx_ggsitemaps/includes/

with a blank index.html file in it plus two php files (all other do not apply to your case if running phpbb without mx or kb) : index_forum.php and forum_sitemap.php.

Then you should have all languages files in phpbb language folders, and admin file in phpbb admin folder and admin tpl in the admin tpl folder.

I will really work on explaining how to install this mod better, it's too bad for now ;) It supposed to be so easy, just upload, no edit.

Once this is done, make sure you have set up db properly (this is done by lunching the db instal script)
The message you posted is just the result, when it's ok, so I guess you have done that, but you can redo it, all you'll loose is your sitemap config, phpbb table won't be affected.

Then off course you need the sitemap.php file itself in your phpbb folder.
As explained you can also put it one level up if you want to use the sitemap system for url above phpbb folder. But you should first make sure it is working in the phpbb folder.

And do not submit it before you make sure it is working.

The no sitemap thing could have come from several problems, the first being files not being in the right place, second is ftp transfert problem.
If it does not work, consider re dl the archive and re upload files (yesterday I saw soemone for whom it ended up being the only working solution, which by the way is really odd but)

If you experience further problem, please send or pm me a link to your sitemap.

Note that you should first try to install the sitemap without url rewriting for sitemap links, just to proceed with one problem at a time (since proper .htaccess setup is needed for the sitemaps).
The .htaccess you posted seem all right though, even if I tend to prefer using just one at the root for my sites (for the rewriterules).

Then for the error you get, I would first need to see you sitemap working to see what's happening, for sure if the sitemap says no sitemap, it's not going to be valid.

Then, as you can see three posts above, google does trick himself sometimes too.

I never had any errors from google with this system myself, nor with the online validating tools so ...

Then littleking57 :

It seems you are not using this mod :

http://www.fishingohio.net/forums/google.php

Code: Select all

<url>
−
	<loc>
http://www.huntohio.net/forums/viewtopic.php?t=1293
</loc>
<lastmod>2006-03-20T18:00:24+00:00</lastmod>
<changefreq>daily</changefreq>
<priority>0.5</priority>
</url>
But your problem comes frome the fact you are listing url from different domains here, and google is strict about that, you can only list url from the same domains, starting from the directory where stands your sitemap.

++

phpBB SEO || phpBB3 SEO Premod || SEO phpBB3
GYM Sitemaps & RSS for phpBB3: GYM Sitemaps & RSS
SHH
Registered User
Posts: 52
Joined: Wed Feb 22, 2006 1:06 am
Contact:

Post by SHH »

HH wrote:
Hi,

Thank you soo much for doing this...

http://www.pathway2curis.com/forum/sitemap.php


Is this ok, or should I have sitemap.xml?

~hedgehog

Well yes and no, the sitemap is working fine, but you activated mod rewrite for sitemaps without implementing the rewriterules provided in the contrib folder's .htacess.

So links like this one don't work : http://pathway2curis.com/forum/forum-sitemap-38.xml

Instead this one (the normal one) is working with good urls : http://www.pathway2curis.com/forum/sitemap.php?fid=38

So you need to put this in your .htaccess :

Code:
RewriteRule ^sitemaps.xml$ /forum/sitemap.php [L]
RewriteRule ^forum-sitemap-([0-9]+).xml$ /forum/sitemap.php?fid=$1 [L]
RewriteRule ^sitemap-forum.xml$ /forum/sitemap.php?forum [L]



Sorry for my questions but, i have my .htaccess in the php install directory(forum)

www.pathway2curis.com/forum(location of .htaccess)

.htaccess code

Code: Select all

RewriteEngine On 
RewriteCond %{HTTP_HOST} !^.*pathway2curis\.com [NC]
RewriteRule (.*) http://www.pathway2curis.com/forum/$1 [R=301,L] 

RewriteRule ^forums.* index.php [L,NC]
RewriteRule ^post-([0-9]*).html&highlight=([a-zA-Z0-9]*) viewtopic.php?p=$1&highlight=$2 [L,NC]
RewriteRule ^post-([0-9]*).* viewtopic.php?p=$1 [L,NC]
RewriteRule ^view-poll([0-9]*)-([0-9]*)-([a-zA-Z]*).* viewtopic.php?t=$1&postdays=$2&postorder=$3&vote=viewresult [L,NC]
RewriteRule ^about([0-9]*).html&highlight=([a-zA-Z0-9]*) viewtopic.php?t=$1&highlight=$2 [L,NC]
RewriteRule ^about([0-9]*).html&view=newest viewtopic.php?t=$1&view=newest [L,NC]
RewriteRule ^about([0-9]*)-([0-9]*)-([a-zA-Z]*)-([0-9]*).* viewtopic.php?t=$1&postdays=$2&postorder=$3&start=$4 [L,NC]
RewriteRule ^about([0-9]*)-([0-9]*).* viewtopic.php?t=$1&start=$2 [L,NC]
RewriteRule ^about([0-9]*).* viewtopic.php?t=$1 [L,NC]
RewriteRule ^about([0-9]*).html viewtopic.php?t=$1&start=$2&postdays=$3&postorder=$4&highlight=$5 [L,NC]
RewriteRule ^mark-forum([0-9]*).html* viewforum.php?f=$1&mark=topics [L,NC]
RewriteRule ^updates-topic([0-9]*).html* viewtopic.php?t=$1&watch=topic [L,NC]
RewriteRule ^stop-updates-topic([0-9]*).html* viewtopic.php?t=$1&unwatch=topic [L,NC]
RewriteRule ^forum-([0-9]*).html viewforum.php?f=$1 [L,NC]
RewriteRule ^forum-([0-9]*).* viewforum.php?f=$1 [L,NC]
RewriteRule ^topic-([0-9]*)-([0-9]*)-([0-9]*).* viewforum.php?f=$1&topicdays=$2&start=$3 [L,NC]
RewriteRule ^ptopic([0-9]*).* viewtopic.php?t=$1&view=previous [L,NC]
RewriteRule ^ntopic([0-9]*).* viewtopic.php?t=$1&view=next [L,NC]

RewriteRule ^sitemaps.xml$ /forum/sitemap.php [L]
RewriteRule ^forum-sitemap-([0-9]+).xml$ /forum/sitemap.php?fid=$1 [L]
RewriteRule ^sitemap-forum.xml$ /forum/sitemap.php?forum [L]

ErrorDocument 404 /Cantbefound.htm
it still displays, the sitmap.php as xml links...

also tried this

Code: Select all

RewriteRule ^sitemaps.xml$ sitemap.php [L]
RewriteRule ^forum-sitemap-([0-9]+).xml$ sitemap.php?fid=$1 [L]
RewriteRule ^sitemap-forum.xml$ sitemap.php?forum [L]
still get the same results[/code]
Post Reply

Return to “[2.0.x] MODs in Development”